aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--math/atlas-devel/Makefile4
-rw-r--r--math/atlas/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/math/atlas-devel/Makefile b/math/atlas-devel/Makefile
index ac69c0ad1e53..8f584c50fbdc 100644
--- a/math/atlas-devel/Makefile
+++ b/math/atlas-devel/Makefile
@@ -35,7 +35,11 @@ USE_GCC=3.4
# only affects for lapack sub project
.if defined(WITH_OPTIMIZED_FLAGS)
+.if defined(CPUTYPE)
FFLAGS+= -mtune=${CPUTYPE} -pipe -O2 -ffast-math -fomit-frame-pointer
+.else
+FFLAGS+= -pipe -O2 -ffast-math -fomit-frame-pointer
+.endif
.endif
post-patch:
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index c63854e4b599..5625f37aea05 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -35,7 +35,11 @@ USE_GCC=3.4
# only affects for lapack sub project
.if defined(WITH_OPTIMIZED_FLAGS)
+.if defined(CPUTYPE)
FFLAGS+= -mtune=${CPUTYPE} -pipe -O2 -ffast-math -fomit-frame-pointer
+.else
+FFLAGS+= -pipe -O2 -ffast-math -fomit-frame-pointer
+.endif
.endif
post-patch: