aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/mp3plot/Makefile4
-rw-r--r--graphics/ImageMagick/Makefile9
-rw-r--r--graphics/ImageMagick/distinfo4
-rw-r--r--graphics/ImageMagick/pkg-help8
-rw-r--r--graphics/ImageMagick/pkg-plist4
-rw-r--r--graphics/converseen/Makefile2
-rw-r--r--graphics/fpc-imagemagick/Makefile2
-rw-r--r--graphics/gimp-gmic-plugin/Makefile2
-rw-r--r--graphics/inkscape/Makefile2
-rw-r--r--graphics/pfstools/Makefile1
10 files changed, 22 insertions, 16 deletions
diff --git a/audio/mp3plot/Makefile b/audio/mp3plot/Makefile
index fb9e33ff79b3..f7c969750c33 100644
--- a/audio/mp3plot/Makefile
+++ b/audio/mp3plot/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mp3plot
DISTVERSION= 0.6.0
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= audio
MASTER_SITES= http://p.outlyer.net/mp3plot/files/
@@ -35,7 +35,7 @@ CONFIGURE_ARGS+= --disable-gd
.endif
.if ${PORT_OPTIONS:MIMAGEMAGICK}
-LIB_DEPENDS+= libMagick++.so:${PORTSDIR}/graphics/ImageMagick
+LIB_DEPENDS+= libMagick++-6.Q*.so:${PORTSDIR}/graphics/ImageMagick
.else
CONFIGURE_ARGS+= --disable-magick
.endif
diff --git a/graphics/ImageMagick/Makefile b/graphics/ImageMagick/Makefile
index f478c86e7a70..110a1a842c14 100644
--- a/graphics/ImageMagick/Makefile
+++ b/graphics/ImageMagick/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= ImageMagick
-DISTVERSION= 6.8.9-3
-PORTREVISION= 2
+DISTVERSION= 6.8.9-4
PORTEPOCH= 1
CATEGORIES= graphics perl5
MASTER_SITES= http://www.imagemagick.org/download/ \
@@ -34,7 +33,7 @@ COMMENT= Image processing tools
#LICENSE= APACHE20
-# This port uses .la files, keep libtool:keepla!
+# This port uses .la files, keep libtool:keepla! (magick/module.c)
USES= gmake libtool:keepla pathfix perl5 pkgconfig shebangfix tar:xz
SHEBANG_FILES= www/source/examples.pl
USE_AUTOTOOLS= libltdl
@@ -377,9 +376,7 @@ INSTALL_TARGET= install-strip install-docDATA install-data-html
INSTALL_TARGET= install-strip
.endif
-# Test suite, requires installed ghostscript to pass
-
-.if defined(PACKAGE_BUILDING) || ${PORT_OPTIONS:MTESTS}
+.if ${PORT_OPTIONS:MTESTS}
USE_GHOSTSCRIPT_BUILD=yes
.endif
diff --git a/graphics/ImageMagick/distinfo b/graphics/ImageMagick/distinfo
index bb260a909871..a4464514d39c 100644
--- a/graphics/ImageMagick/distinfo
+++ b/graphics/ImageMagick/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ImageMagick-6.8.9-3.tar.xz) = aca0c1af5b2db84a39dcb7ac109be542965af61ebab967c84d26541f475ba9d1
-SIZE (ImageMagick-6.8.9-3.tar.xz) = 7555684
+SHA256 (ImageMagick-6.8.9-4.tar.xz) = af89964a72ff9e54b754570842299784e2d644495cbb5e67ea391e67d262bcc5
+SIZE (ImageMagick-6.8.9-4.tar.xz) = 7544152
diff --git a/graphics/ImageMagick/pkg-help b/graphics/ImageMagick/pkg-help
new file mode 100644
index 000000000000..4f74f71a6137
--- /dev/null
+++ b/graphics/ImageMagick/pkg-help
@@ -0,0 +1,8 @@
+What is meant with half support for the 16BIT_PIXEL option and HDRI
+option is that either by disabling 16BIT_PIXEL or enabling HDRI the
+library names change. The ImageMagick port works fine and package
+correctly. But ports that depend on ImageMagick might not be able to
+find ImageMagick libraries anymore via the port framework.
+
+So please keep that in mind if you need a port that ImageMagick and
+you want to change these options.
diff --git a/graphics/ImageMagick/pkg-plist b/graphics/ImageMagick/pkg-plist
index 75fdffb29197..4e1fbc5e207f 100644
--- a/graphics/ImageMagick/pkg-plist
+++ b/graphics/ImageMagick/pkg-plist
@@ -412,8 +412,8 @@ lib/ImageMagick-%%PORTVERSION%%/config-%%QBIT%%%%HDRI%%/configure.xml
lib/libMagick++-6.%%QBIT%%%%HDRI%%.a
lib/libMagick++-6.%%QBIT%%%%HDRI%%.la
lib/libMagick++-6.%%QBIT%%%%HDRI%%.so
-lib/libMagick++-6.%%QBIT%%%%HDRI%%.so.4
-lib/libMagick++-6.%%QBIT%%%%HDRI%%.so.4.0.0
+lib/libMagick++-6.%%QBIT%%%%HDRI%%.so.5
+lib/libMagick++-6.%%QBIT%%%%HDRI%%.so.5.0.0
lib/libMagickCore-6.%%QBIT%%%%HDRI%%.a
lib/libMagickCore-6.%%QBIT%%%%HDRI%%.la
lib/libMagickCore-6.%%QBIT%%%%HDRI%%.so
diff --git a/graphics/converseen/Makefile b/graphics/converseen/Makefile
index a0bc8d2ecf5a..a33231fca65d 100644
--- a/graphics/converseen/Makefile
+++ b/graphics/converseen/Makefile
@@ -3,7 +3,7 @@
PORTNAME= converseen
PORTVERSION= 0.7.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/Converseen/Converseen%200.7/
diff --git a/graphics/fpc-imagemagick/Makefile b/graphics/fpc-imagemagick/Makefile
index 15157841bce5..75482f2ec102 100644
--- a/graphics/fpc-imagemagick/Makefile
+++ b/graphics/fpc-imagemagick/Makefile
@@ -1,7 +1,7 @@
# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
# $FreeBSD$
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics lang
PKGNAMESUFFIX= -imagemagick
diff --git a/graphics/gimp-gmic-plugin/Makefile b/graphics/gimp-gmic-plugin/Makefile
index ed35984aed74..8fb3a823ae5d 100644
--- a/graphics/gimp-gmic-plugin/Makefile
+++ b/graphics/gimp-gmic-plugin/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gmic
PORTVERSION= 1.5.9.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/older_versions/ \
SF/${PORTNAME}/
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index e48f87258adb..71ac0f370219 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -3,7 +3,7 @@
PORTNAME= inkscape
PORTVERSION= 0.48.4
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics gnome
MASTER_SITES= SF
MASTER_SITE_SUBDIR=${PORTNAME:tl}/${PORTNAME:tl}/${PORTVERSION}
diff --git a/graphics/pfstools/Makefile b/graphics/pfstools/Makefile
index a0fd8da8a5cf..40fc6337c3ff 100644
--- a/graphics/pfstools/Makefile
+++ b/graphics/pfstools/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pfstools
PORTVERSION= 1.8.5
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF