aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--print/catdvi/Makefile2
-rw-r--r--print/cups-pstoraster/Makefile3
-rw-r--r--print/flpsed/Makefile2
-rw-r--r--print/foomatic-db-hpijs/Makefile2
-rw-r--r--print/freetype-tools/Makefile2
-rw-r--r--print/ghostscript7/Makefile3
-rw-r--r--print/latex-cjk/Makefile2
-rw-r--r--print/latex-logpap/Makefile2
-rw-r--r--print/latex-supertabular/Makefile2
-rw-r--r--print/libgnomeprintmm/Makefile4
-rw-r--r--print/mftrace/Makefile2
-rw-r--r--print/panda/Makefile4
-rw-r--r--print/teTeX-base/Makefile2
-rw-r--r--print/tex-aleph/Makefile3
-rw-r--r--print/tex-dvipdfmx/Makefile3
-rw-r--r--print/tex-dvipsk/Makefile3
-rw-r--r--print/tex-luatex/Makefile4
-rw-r--r--print/tex-omegaware-old/Makefile3
-rw-r--r--print/tex-xetex/Makefile4
19 files changed, 19 insertions, 33 deletions
diff --git a/print/catdvi/Makefile b/print/catdvi/Makefile
index c876a6aa1c8b..aa61ca4f6db0 100644
--- a/print/catdvi/Makefile
+++ b/print/catdvi/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A DVI to text/plain translator
USE_TEX= latex
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
MAKEFILE= GNUmakefile
ALL_TARGET= # empty
diff --git a/print/cups-pstoraster/Makefile b/print/cups-pstoraster/Makefile
index 3fb086cb6513..58b35ad33a93 100644
--- a/print/cups-pstoraster/Makefile
+++ b/print/cups-pstoraster/Makefile
@@ -28,8 +28,7 @@ WRKSRC= ${WRKDIR}/espgs-${PORTVERSION}
DATADIR= ${PREFIX}/share/espgs
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
# We just need the ghostscript fonts, nothing more
USE_GHOSTSCRIPT_RUN= yes
GNU_CONFIGURE= yes
diff --git a/print/flpsed/Makefile b/print/flpsed/Makefile
index bca46b2dbe4a..28036fb1dcfc 100644
--- a/print/flpsed/Makefile
+++ b/print/flpsed/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS+= fltk.1:${PORTSDIR}/x11-toolkits/fltk
GNU_CONFIGURE= yes
USE_GHOSTSCRIPT=yes
-USE_GMAKE= yes
+USES= gmake
PLIST_FILES= bin/flpsed
MAN1= flpsed.1
diff --git a/print/foomatic-db-hpijs/Makefile b/print/foomatic-db-hpijs/Makefile
index 3b989b075ecc..ce87ebe67001 100644
--- a/print/foomatic-db-hpijs/Makefile
+++ b/print/foomatic-db-hpijs/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= ${LOCALBASE}/share/foomatic/db/oldprinterids:${PORTSDIR}/print/fo
RUN_DEPENDS= ${LOCALBASE}/share/foomatic/db/oldprinterids:${PORTSDIR}/print/foomatic-db
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
NO_STAGE= yes
post-patch:
diff --git a/print/freetype-tools/Makefile b/print/freetype-tools/Makefile
index 6877b3faee15..18a5a527aef8 100644
--- a/print/freetype-tools/Makefile
+++ b/print/freetype-tools/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= t1asm:${PORTSDIR}/print/t1utils
BUILD_DEPENDS:= ${RUN_DEPENDS}
USE_TEX= base texmf
-USE_GMAKE= yes
+USES= gmake
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --disable-nls --enable-static --enable-shared
diff --git a/print/ghostscript7/Makefile b/print/ghostscript7/Makefile
index 60abe191a40d..741f089ad981 100644
--- a/print/ghostscript7/Makefile
+++ b/print/ghostscript7/Makefile
@@ -32,8 +32,7 @@ CONFLICTS_INSTALL= \
ghostscript9-agpl-[0-9]* \
ghostscript9-agpl-nox11-[0-9]*
-USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake tar:bzip2
USE_LDCONFIG= yes
WANT_GNOME= yes
# normazile WRKSRC so things like cups-pstoraster may work
diff --git a/print/latex-cjk/Makefile b/print/latex-cjk/Makefile
index 64e6942fc74b..471615458c18 100644
--- a/print/latex-cjk/Makefile
+++ b/print/latex-cjk/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS:= ${RUN_DEPENDS} \
ttf2pt1:${PORTSDIR}/print/ttf2pt1
LIB_DEPENDS= ttf:${PORTSDIR}/print/freetype
-USE_GMAKE= yes
+USES= gmake
USE_TEX= tetex latex
MAN1= bg5conv.1 cef5conv.1 cefconv.1 cefsconv.1 extconv.1 \
diff --git a/print/latex-logpap/Makefile b/print/latex-logpap/Makefile
index b415621af8ac..68089df52149 100644
--- a/print/latex-logpap/Makefile
+++ b/print/latex-logpap/Makefile
@@ -18,7 +18,7 @@ PLIST_SUB= TEXMFLOCAL=${TEXMFLOCAL} MKTEXLSR=${MKTEXLSR} \
CLASSDIR=${CLASSDIR}
USE_TEX= latex
-USE_GMAKE= YES
+USES= gmake
TEXMFLOCAL= share/texmf-local
TEXMFLOCAL_LSR= ${LOCALBASE}/${TEXMFLOCAL}/ls-R
MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
diff --git a/print/latex-supertabular/Makefile b/print/latex-supertabular/Makefile
index 0b25d6d6e3c4..de5666dde2eb 100644
--- a/print/latex-supertabular/Makefile
+++ b/print/latex-supertabular/Makefile
@@ -15,7 +15,7 @@ COMMENT= A LaTeX package for a tabular that spans multiple pages
USE_TEX= latex
PLIST_SUB= TEXMFLOCAL=${TEXMFLOCAL} MKTEXLSR=${MKTEXLSR} \
CLASSDIR=${CLASSDIR}
-USE_GMAKE= yes
+USES= gmake
TEXMFLOCAL= share/texmf-local
TEXMFLOCAL_LSR= ${LOCALBASE}/${TEXMFLOCAL}/ls-R
MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
diff --git a/print/libgnomeprintmm/Makefile b/print/libgnomeprintmm/Makefile
index 191607fab9de..3ac1442eb9ce 100644
--- a/print/libgnomeprintmm/Makefile
+++ b/print/libgnomeprintmm/Makefile
@@ -14,10 +14,8 @@ COMMENT= C++ bindings for the GNOME print support library
LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
-USES= pkgconfig
+USES= pkgconfig gmake tar:bzip2
USE_AUTOTOOLS= libtool
-USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack libgnomeprint
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/print/mftrace/Makefile b/print/mftrace/Makefile
index ef7a6d384ec3..1afc017e775a 100644
--- a/print/mftrace/Makefile
+++ b/print/mftrace/Makefile
@@ -26,7 +26,7 @@ RUN_DEPENDS+= potrace:${PORTSDIR}/graphics/potrace
USE_PYTHON= yes
USE_TEX= base texmf
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
MAKEFILE= GNUmakefile
.if !defined(NO_INSTALL_MANPAGES)
diff --git a/print/panda/Makefile b/print/panda/Makefile
index fe47a34e8361..235d32f6b5bc 100644
--- a/print/panda/Makefile
+++ b/print/panda/Makefile
@@ -19,10 +19,8 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
-USE_BZIP2= yes
-USES= pathfix pkgconfig
+USES= pathfix pkgconfig gmake tar:bzip2
USE_BDB= yes
-USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --enable-berkeley-db
USE_LDCONFIG= yes
diff --git a/print/teTeX-base/Makefile b/print/teTeX-base/Makefile
index e01d849b8a0d..c452cd717e60 100644
--- a/print/teTeX-base/Makefile
+++ b/print/teTeX-base/Makefile
@@ -27,7 +27,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
GD_PORT?= graphics/gd
WRKSRC= ${WRKDIR}/tetex-src-${PORTVERSION}
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
USE_GHOSTSCRIPT_RUN= yes
CONFIGURE_ARGS= --disable-multiplatform \
--without-texinfo \
diff --git a/print/tex-aleph/Makefile b/print/tex-aleph/Makefile
index 3531bf965ae7..d341f73919dd 100644
--- a/print/tex-aleph/Makefile
+++ b/print/tex-aleph/Makefile
@@ -15,8 +15,7 @@ EXTRACT_ONLY= texlive-${DISTVERSION_TEXLIVE}-source${EXTRACT_SUFX}
MAINTAINER= hrs@FreeBSD.org
COMMENT= TeX Engine including Omega and e-TeX features
-USE_XZ= yes
-USE_GMAKE= yes
+USES= gmake tar:xz
USE_TEX= texlive kpathsea web2c texmf formats fmtutil
TEXHASHDIRS= ${TEXMFDISTDIR}
EXTRACT_AFTER_ARGS= ${EXTRACT_FILES:S,^,${DISTNAME}/,}
diff --git a/print/tex-dvipdfmx/Makefile b/print/tex-dvipdfmx/Makefile
index ca337991f33c..a05bb4f7f500 100644
--- a/print/tex-dvipdfmx/Makefile
+++ b/print/tex-dvipdfmx/Makefile
@@ -22,8 +22,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
paper:${PORTSDIR}/print/libpaper
RUN_DEPENDS= ${LOCALBASE}/share/fonts/adobe-cmaps/ai0/CMap/Identity-H:${PORTSDIR}/print/adobe-cmaps
-USE_XZ= yes
-USE_GMAKE= yes
+USES= gmake tar:xz
USE_TEX= texlive kpathsea web2c texmf texhash
TEXHASHDIR= ${TEXMFDISTDIR} ${TEXMFDIR}
USES= pkgconfig
diff --git a/print/tex-dvipsk/Makefile b/print/tex-dvipsk/Makefile
index 423db22347cf..bdd314740d88 100644
--- a/print/tex-dvipsk/Makefile
+++ b/print/tex-dvipsk/Makefile
@@ -19,8 +19,7 @@ LICENSE= GPLv2
LIB_DEPENDS= paper:${PORTSDIR}/print/libpaper
-USE_XZ= yes
-USE_GMAKE= yes
+USES= gmake tar:xz
USE_TEX= texlive kpathsea web2c texmf texhash
TEXHASHDIRS= ${TEXMFDISTDIR} ${TEXMFDIR}
EXTRACT_AFTER_ARGS= ${EXTRACT_FILES:S,^,${DISTNAME}/,}
diff --git a/print/tex-luatex/Makefile b/print/tex-luatex/Makefile
index ab6f01129274..2e5d429bfac0 100644
--- a/print/tex-luatex/Makefile
+++ b/print/tex-luatex/Makefile
@@ -23,10 +23,8 @@ LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
libTECkit.so:${PORTSDIR}/textproc/teckit \
libzzip.so:${PORTSDIR}/devel/zziplib
-USE_XZ= yes
-USE_GMAKE= yes
USE_TEX= texlive kpathsea web2c texmf formats fmtutil
-USES= pkgconfig
+USES= pkgconfig tar:xz gmake
EXTRACT_AFTER_ARGS= ${EXTRACT_FILES:S,^,${DISTNAME}/,}
EXTRACT_FILES= \
build-aux \
diff --git a/print/tex-omegaware-old/Makefile b/print/tex-omegaware-old/Makefile
index eed2d98bf775..aa0a65dfbb32 100644
--- a/print/tex-omegaware-old/Makefile
+++ b/print/tex-omegaware-old/Makefile
@@ -17,8 +17,7 @@ USE_TEX= base texmf
DIST_SUBDIR= teTeX
WRKSRC= ${WRKDIR}/tetex-src-${PORTVERSION}/texk/web2c
CONFIGURE_WRKSRC= ${WRKDIR}/tetex-src-${PORTVERSION}
-USE_GMAKE= yes
-USES= perl5
+USES= perl5 gmake
USE_PERL5= build
TETEX_SRC= tetex-src-${PORTVERSION}.tar.gz
diff --git a/print/tex-xetex/Makefile b/print/tex-xetex/Makefile
index 251c4a712597..3215e5f3dc2e 100644
--- a/print/tex-xetex/Makefile
+++ b/print/tex-xetex/Makefile
@@ -24,10 +24,8 @@ LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
libpoppler.so:${PORTSDIR}/graphics/poppler \
libTECkit.so:${PORTSDIR}/textproc/teckit
-USE_XZ= yes
-USE_GMAKE= yes
USE_TEX= texlive kpathsea web2c texmf formats fmtutil
-USES= pkgconfig
+USES= pkgconfig gmake tar:xz
EXTRACT_AFTER_ARGS= ${EXTRACT_FILES:S,^,${DISTNAME}/,}
EXTRACT_FILES= \
build-aux \