aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--japanese/libtomoe-gtk/Makefile6
-rw-r--r--japanese/scim-tomoe/Makefile20
-rw-r--r--japanese/tomoe/Makefile40
-rw-r--r--japanese/tomoe/pkg-plist12
-rw-r--r--japanese/uim-tomoe-gtk/Makefile6
5 files changed, 23 insertions, 61 deletions
diff --git a/japanese/libtomoe-gtk/Makefile b/japanese/libtomoe-gtk/Makefile
index 58bbb045ddd5..32893cd75553 100644
--- a/japanese/libtomoe-gtk/Makefile
+++ b/japanese/libtomoe-gtk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libtomoe-gtk
PORTVERSION= 0.6.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= japanese
MASTER_SITES= SF/tomoe/tomoe-gtk/tomoe-gtk-${PORTVERSION}
DISTNAME= tomoe-gtk-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
@@ -13,9 +13,9 @@ COMMENT= TOMOE GTK+ library
LIB_DEPENDS= libtomoe.so:${PORTSDIR}/japanese/tomoe
-USE_GNOME= lthack gnomehack gtk20
GNU_CONFIGURE= yes
-USES= gmake pkgconfig
+USES= gmake libtool:oldver pathfix pkgconfig
+USE_GNOME= gtk20
USE_LDCONFIG= yes
#OPTIONS= GUCHARMAP "Compile with gucharmap" on
diff --git a/japanese/scim-tomoe/Makefile b/japanese/scim-tomoe/Makefile
index 88e67d701840..62816ae1045d 100644
--- a/japanese/scim-tomoe/Makefile
+++ b/japanese/scim-tomoe/Makefile
@@ -3,7 +3,7 @@
PORTNAME= scim-tomoe
PORTVERSION= 0.6.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= japanese
MASTER_SITES= SF/tomoe/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -11,16 +11,13 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= SCIM IMEngine module using Tomoe
BUILD_DEPENDS= scim:${PORTSDIR}/textproc/scim
-LIB_DEPENDS= tomoe.1:${PORTSDIR}/japanese/tomoe \
- tomoe-gtk.1:${PORTSDIR}/japanese/libtomoe-gtk
+LIB_DEPENDS= libtomoe.so:${PORTSDIR}/japanese/tomoe \
+ libtomoe-gtk.so:${PORTSDIR}/japanese/libtomoe-gtk
-USE_GNOME= lthack intlhack
-USES= gettext gmake iconv pkgconfig
+USE_GNOME= intlhack
+USES= gettext gmake iconv libtool:keepla pkgconfig
GNU_CONFIGURE= yes
-CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
-
CPPFLAGS+= -I${LOCALBASE}/include -D__STDC_ISO_10646__
LDFLAGS+= -L${LOCALBASE}/lib
@@ -31,11 +28,4 @@ PLIST_FILES= bin/scim-tomoe \
share/locale/ja/LC_MESSAGES/scim-tomoe.mo \
share/scim/icons/scim-tomoe.png
-NO_STAGE= yes
-post-install:
- @${CAT} ${PKGMESSAGE}
- @${ECHO}
- @${ECHO} To display this message again, type \`pkg_info -D ${PKGNAME}\'
- @${ECHO}
-
.include <bsd.port.mk>
diff --git a/japanese/tomoe/Makefile b/japanese/tomoe/Makefile
index 9ea8763b4420..54614fabc51c 100644
--- a/japanese/tomoe/Makefile
+++ b/japanese/tomoe/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tomoe
PORTVERSION= 0.6.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= japanese
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@@ -12,35 +12,20 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ume@FreeBSD.org
COMMENT= Tegaki Online MOji-ninshiki Engine
-USE_GNOME= lthack gnomehack
+BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
+
GNU_CONFIGURE= yes
-USES= gettext pkgconfig gmake perl5
+USES= gettext gmake libtool pathfix perl5 pkgconfig
USE_LDCONFIG= yes
-USE_RUBY= yes
USE_PERL5= build
-BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
-
-# We cannot use ${ARCH} nor ${UNAME} which are defined in bsd.port.mk, here.
-UNAME?= /usr/bin/uname
-ARCH!= ${UNAME} -p
-.if !defined(OSVERSION)
-AWK?= /usr/bin/awk
-SYSCTL?= /sbin/sysctl
-.if exists(/usr/include/sys/param.h)
-OSVERSION!= ${AWK} '/^\#define __FreeBSD_version/ {print $$3}' < /usr/include/sys/param.h
-.elif exists(/usr/src/sys/sys/param.h)
-OSVERSION!= ${AWK} '/^\#define __FreeBSD_version/ {print $$3}' < /usr/src/sys/sys/param.h
-.else
-OSVERSION!= ${SYSCTL} -n kern.osreldate
-.endif
-.endif
+CONFIGURE_ENV= PYTHON_VERSION=${PYTHON_VERSION:S;python;;} \
+ pyexecdir=${PYTHON_SITELIBDIR} \
+ GMSGFMT="${LOCALBASE}/bin/msgfmt"
+CFLAGS+= -I${LOCALBASE}/include
OPTIONS_DEFINE= DICT_RUBY EST MYSQL PYTHON RUBY UNIHAN
OPTIONS_DEFAULT= PYTHON
-.if ${ARCH} != "sparc64" && ${OSVERSION} < 700042
-OPTIONS_DEFAULT+= UNIHAN
-.endif
OPTIONS_SUB= yes
DICT_RUBY_DESC= Enable Ruby based dictionary module
DICT_RUBY_CONFIGURE_ENABLE= dict-ruby
@@ -62,7 +47,7 @@ RUBY_CFLAGS= -I${LOCALBASE}/include/ruby-${RUBY_VER} \
UNIHAN_DESC= Enable Unihan database dictionary module
UNIHAN_CONFIGURE_ENABLE= unihan
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MRUBY}
BROKEN= Broken with gem version of glib2
@@ -83,11 +68,6 @@ BUILD_DEPENDS+= \
${RUBY_SITELIBDIR}/suikyo/suikyo.rb:${PORTSDIR}/japanese/suikyo
.endif
-CONFIGURE_ENV+= PYTHON_VERSION=${PYTHON_VERSION:S;python;;} \
- pyexecdir=${PYTHON_SITELIBDIR} \
- GMSGFMT="${LOCALBASE}/bin/msgfmt"
-CFLAGS+= -I${LOCALBASE}/include
-
.if ${PORT_OPTIONS:MUNIHAN}
post-extract:
cd ${WRKSRC}/module/dict && \
@@ -101,4 +81,4 @@ post-patch:
${WRKSRC}/lib/tomoe.c \
${WRKSRC}/lib/glib-utils.h
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/japanese/tomoe/pkg-plist b/japanese/tomoe/pkg-plist
index 315a8d3217f8..587a7a69af7c 100644
--- a/japanese/tomoe/pkg-plist
+++ b/japanese/tomoe/pkg-plist
@@ -17,30 +17,23 @@ include/tomoe/tomoe-writing.h
include/tomoe/tomoe.h
@dirrmtry include/tomoe
lib/libtomoe.a
-lib/libtomoe.la
lib/libtomoe.so
-lib/libtomoe.so.1
+lib/libtomoe.so.0
+lib/libtomoe.so.0.1.0
%%PYTHON%%%%PYTHON_SITELIBDIR%%/tomoe.a
-%%PYTHON%%%%PYTHON_SITELIBDIR%%/tomoe.la
%%PYTHON%%%%PYTHON_SITELIBDIR%%/tomoe.so
%%EST%%lib/tomoe/module/dict/est.a
-%%EST%%lib/tomoe/module/dict/est.la
%%EST%%lib/tomoe/module/dict/est.so
%%MYSQL%%lib/tomoe/module/dict/mysql.a
-%%MYSQL%%lib/tomoe/module/dict/mysql.la
%%MYSQL%%lib/tomoe/module/dict/mysql.so
%%DICT_RUBY%%lib/tomoe/module/dict/ruby.a
-%%DICT_RUBY%%lib/tomoe/module/dict/ruby.la
%%DICT_RUBY%%lib/tomoe/module/dict/ruby.so
%%UNIHAN%%lib/tomoe/module/dict/unihan.a
-%%UNIHAN%%lib/tomoe/module/dict/unihan.la
%%UNIHAN%%lib/tomoe/module/dict/unihan.so
lib/tomoe/module/dict/xml.a
-lib/tomoe/module/dict/xml.la
lib/tomoe/module/dict/xml.so
@dirrm lib/tomoe/module/dict
lib/tomoe/module/recognizer/simple.a
-lib/tomoe/module/recognizer/simple.la
lib/tomoe/module/recognizer/simple.so
@dirrm lib/tomoe/module/recognizer
@dirrm lib/tomoe/module
@@ -84,6 +77,5 @@ share/tomoe/xml2est.rb
@dirrm share/tomoe
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/rbtomoe.h
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/tomoe.a
-%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/tomoe.la
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/tomoe.so
%%RUBY%%%%RUBY_SITELIBDIR%%/tomoe.rb
diff --git a/japanese/uim-tomoe-gtk/Makefile b/japanese/uim-tomoe-gtk/Makefile
index 59643ae01d61..bb25a95fe612 100644
--- a/japanese/uim-tomoe-gtk/Makefile
+++ b/japanese/uim-tomoe-gtk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= uim-tomoe-gtk
PORTVERSION= 0.6.0
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= japanese
MASTER_SITES= SF/tomoe/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -14,8 +14,8 @@ LIB_DEPENDS= libtomoe.so:${PORTSDIR}/japanese/tomoe \
libtomoe-gtk.so:${PORTSDIR}/japanese/libtomoe-gtk \
libuim.so:${PORTSDIR}/textproc/uim
-USE_GNOME= lthack gtk20
-USES= gettext gmake pkgconfig
+USES= gettext gmake libtool pkgconfig
+USE_GNOME= gtk20
GNU_CONFIGURE= yes
PLIST_FILES= bin/uim-tomoe-gtk \