aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/freebooters/Makefile8
-rw-r--r--graphics/batik/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/games/freebooters/Makefile b/games/freebooters/Makefile
index 25a7a66183af..a208b2bef0c0 100644
--- a/games/freebooters/Makefile
+++ b/games/freebooters/Makefile
@@ -20,6 +20,12 @@ DOC_FILES= AUTHORS COPYING COPYRIGHT NEWS README \
README_BUCCANEER TODO manual.tex
MAN6= freebooters.6 buccaneer.6
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on 4.x"
+.endif
+
do-configure:
${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/sdl_setup.cc
${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' ${WRKSRC}/tools.cc
@@ -31,4 +37,4 @@ post-install:
cd ${WRKSRC}/doc/ && ${INSTALL_DATA} ${DOC_FILES} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/batik/Makefile b/graphics/batik/Makefile
index e855a1b30aa6..c6108c4cc4f6 100644
--- a/graphics/batik/Makefile
+++ b/graphics/batik/Makefile
@@ -30,6 +30,12 @@ BATIK_HOME= ${PREFIX}/batik
ANT_ALL_TARGET+= html
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on 4.x"
+.endif
+
do-build:
@cd ${WRKSRC} && ${ANT} ${ANT_ALL_TARGET}
@@ -41,4 +47,4 @@ do-install:
@${FIND} ${BATIK_HOME} -type d | ${SORT} -r | \
${SED} -e "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>