aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--irc/xchat-gnome/Makefile5
-rw-r--r--irc/xchat/Makefile5
-rw-r--r--irc/xchat1/Makefile5
-rw-r--r--irc/xchat2/Makefile5
4 files changed, 20 insertions, 0 deletions
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index 05b69f2c7f2e..c7c4572e9641 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -35,6 +35,11 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
CONFIGURE_ARGS+= --enable-socks
.endif
+.if defined(WITH_SSL)
+USE_OPENSSL= YES
+CONFIGURE_ARGS+= --enable-openssl
+.endif
+
.if defined(HAVE_GNOME)
USE_GNOME= yes
CONFIGURE_ARGS+= --enable-gnome --enable-panel --enable-gdk-pixbuf
diff --git a/irc/xchat/Makefile b/irc/xchat/Makefile
index 05b69f2c7f2e..c7c4572e9641 100644
--- a/irc/xchat/Makefile
+++ b/irc/xchat/Makefile
@@ -35,6 +35,11 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
CONFIGURE_ARGS+= --enable-socks
.endif
+.if defined(WITH_SSL)
+USE_OPENSSL= YES
+CONFIGURE_ARGS+= --enable-openssl
+.endif
+
.if defined(HAVE_GNOME)
USE_GNOME= yes
CONFIGURE_ARGS+= --enable-gnome --enable-panel --enable-gdk-pixbuf
diff --git a/irc/xchat1/Makefile b/irc/xchat1/Makefile
index 05b69f2c7f2e..c7c4572e9641 100644
--- a/irc/xchat1/Makefile
+++ b/irc/xchat1/Makefile
@@ -35,6 +35,11 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
CONFIGURE_ARGS+= --enable-socks
.endif
+.if defined(WITH_SSL)
+USE_OPENSSL= YES
+CONFIGURE_ARGS+= --enable-openssl
+.endif
+
.if defined(HAVE_GNOME)
USE_GNOME= yes
CONFIGURE_ARGS+= --enable-gnome --enable-panel --enable-gdk-pixbuf
diff --git a/irc/xchat2/Makefile b/irc/xchat2/Makefile
index 05b69f2c7f2e..c7c4572e9641 100644
--- a/irc/xchat2/Makefile
+++ b/irc/xchat2/Makefile
@@ -35,6 +35,11 @@ BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
CONFIGURE_ARGS+= --enable-socks
.endif
+.if defined(WITH_SSL)
+USE_OPENSSL= YES
+CONFIGURE_ARGS+= --enable-openssl
+.endif
+
.if defined(HAVE_GNOME)
USE_GNOME= yes
CONFIGURE_ARGS+= --enable-gnome --enable-panel --enable-gdk-pixbuf