aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--math/py-graphtool/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/math/py-graphtool/Makefile b/math/py-graphtool/Makefile
index 5743e664a107..790ef63b8fb1 100644
--- a/math/py-graphtool/Makefile
+++ b/math/py-graphtool/Makefile
@@ -15,7 +15,8 @@ MAINTAINER= dikshie@sfc.wide.ad.jp
COMMENT= Python module for complex network based on C++
BUILD_DEPENDS= ${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}matplotlib>=0.90.1:${PORTSDIR}/math/py-matplotlib
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=0.90.1:${PORTSDIR}/math/py-matplotlib \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.8.0:${PORTSDIR}/science/py-scipy
LIB_DEPENDS= boost_python.4:${PORTSDIR}/devel/boost-python-libs \
boost_graph.4:${PORTSDIR}/devel/boost-libs \
CGAL.5:${PORTSDIR}/math/cgal
@@ -26,4 +27,6 @@ USE_GMAKE= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV= PYTHON_VERSION=${PYTHON_VER}
+
.include <bsd.port.mk>