aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/fsplib/Makefile29
-rw-r--r--net/fsplib/distinfo2
-rw-r--r--net/fsplib/pkg-descr7
4 files changed, 39 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 55105915c418..35fc3433864d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -139,6 +139,7 @@
SUBDIR += frost
SUBDIR += fspclient
SUBDIR += fspd
+ SUBDIR += fsplib
SUBDIR += fugu
SUBDIR += gaim
SUBDIR += gaim-openq
diff --git a/net/fsplib/Makefile b/net/fsplib/Makefile
new file mode 100644
index 000000000000..187c701d10f9
--- /dev/null
+++ b/net/fsplib/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: fsplib
+# Date created: 15 Jan 2005
+# Whom: X
+#
+# $FreeBSD$
+
+PORTNAME= fsplib
+PORTVERSION= 0.6
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= fsp
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Library implementing FSP protocol
+
+BUILD_DEPENDS= scons:${PORTSDIR}/devel/scons
+
+PLIST_FILES= include/fsplib.h lib/libfsp.a
+NO_WRKSUBDIR= yes
+
+do-build:
+ @cd ${WRKSRC} && scons prefix=${PREFIX}
+
+do-install:
+ @cd ${WRKSRC} && scons prefix=${PREFIX} install
+ ${FIND} ${PREFIX}/include/ -name .sconsign -exec ${RM} {} \;
+ ${FIND} ${PREFIX}/lib/ -name .sconsign -exec ${RM} {} \;
+
+.include <bsd.port.mk>
diff --git a/net/fsplib/distinfo b/net/fsplib/distinfo
new file mode 100644
index 000000000000..6ae0ed855721
--- /dev/null
+++ b/net/fsplib/distinfo
@@ -0,0 +1,2 @@
+MD5 (fsplib-0.6.tar.gz) = 18f837120b5a185840dd16555728dc30
+SIZE (fsplib-0.6.tar.gz) = 17659
diff --git a/net/fsplib/pkg-descr b/net/fsplib/pkg-descr
new file mode 100644
index 000000000000..1ddcff6de4c2
--- /dev/null
+++ b/net/fsplib/pkg-descr
@@ -0,0 +1,7 @@
+FSPLIB is a set of routines that implement the FSP protocol. They allow
+applications to work with files on FSP server with the same style
+used to work with local files via libc.
+
+Note: GFTP prefers this package over its built in FSP stack.
+
+WWW: http://fsp.sourceforge.net/fsplib.html