aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/abills/Makefile8
-rw-r--r--net/beacon/Makefile6
-rw-r--r--net/entitymib/Makefile4
-rw-r--r--net/freedbd/Makefile2
-rw-r--r--net/kojoney/Makefile2
-rw-r--r--net/ldap2dns/Makefile4
-rw-r--r--net/ldapsh/Makefile10
-rw-r--r--net/lla/Makefile6
-rw-r--r--net/p5-Apache2-SOAP/Makefile2
-rw-r--r--net/p5-Gopher-Server/Makefile6
-rw-r--r--net/p5-IO-Socket-Multicast/Makefile2
-rw-r--r--net/p5-IP-Country/Makefile2
-rw-r--r--net/p5-Net-FS-Flickr/Makefile6
-rw-r--r--net/p5-Net-FS-Gmail/Makefile6
-rw-r--r--net/p5-Net-Frame-Layer-ICMPv6/Makefile4
-rw-r--r--net/p5-Net-Frame-Layer-IPv6/Makefile4
-rw-r--r--net/p5-Net-SMS-PChome/Makefile6
-rw-r--r--net/p5-Net-SSH-Expect/Makefile2
-rw-r--r--net/p5-Net-Telnet-Netscreen/Makefile2
-rw-r--r--net/p5-Net-TiVo/Makefile8
-rw-r--r--net/p5-Net-Twitter-Lite/Makefile2
-rw-r--r--net/p5-POE-Component-Client-Telnet/Makefile4
-rw-r--r--net/p5-XML-RPC/Makefile4
-rw-r--r--net/pbnc/Makefile2
-rw-r--r--net/prosearch/Makefile24
-rw-r--r--net/rude/Makefile2
-rw-r--r--net/shelldap/Makefile12
-rw-r--r--net/smbldap-tools/Makefile8
-rw-r--r--net/xbone/Makefile42
29 files changed, 96 insertions, 96 deletions
diff --git a/net/abills/Makefile b/net/abills/Makefile
index 6c3d24c9fd59..92597ad65664 100644
--- a/net/abills/Makefile
+++ b/net/abills/Makefile
@@ -19,10 +19,10 @@ COMMENT= Billing system for dialup, VPN and VoIP management
LICENSE= GPLv2
RUN_DEPENDS= radiusd:${PORTSDIR}/net/freeradius \
- ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD4.pm:${PORTSDIR}/security/p5-Digest-MD4 \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/DES.pm:${PORTSDIR}/security/p5-Crypt-DES
+ p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql \
+ p5-Digest-MD4>=0:${PORTSDIR}/security/p5-Digest-MD4 \
+ p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-Crypt-DES>=0:${PORTSDIR}/security/p5-Crypt-DES
USE_PERL5_RUN= yes
NO_BUILD= yes
diff --git a/net/beacon/Makefile b/net/beacon/Makefile
index 75f0b9ce558d..ea4cb8e75de0 100644
--- a/net/beacon/Makefile
+++ b/net/beacon/Makefile
@@ -14,8 +14,8 @@ MASTER_SITES= SF/multicastbeacon/multicastbeacon/beacon%20v${PORTVERSION}
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Beacon active measurement tool to monitor multicast
-BUILD_DEPENDS= ${SITE_PERL}/Net/Domain.pm:${PORTSDIR}/net/p5-Net
-RUN_DEPENDS= ${SITE_PERL}/Net/Domain.pm:${PORTSDIR}/net/p5-Net
+BUILD_DEPENDS= p5-Net>=0:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= p5-Net>=0:${PORTSDIR}/net/p5-Net
WWW_DIR?= ${PREFIX}/www/
PLIST_SUB+= VERSION=${PORTVERSION}
@@ -25,7 +25,7 @@ USE_AUTOTOOLS= autoconf
OPTIONS= IPV6 "Enable IPv6 PTR lookups" off
.ifdef(WITH_IPV6)
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Socket6.pm:${PORTSDIR}/net/p5-Socket6
+BUILD_DEPENDS+= p5-Socket6>=0:${PORTSDIR}/net/p5-Socket6
CONFIGURE_ARGS+= --enable-ipv6
.endif
diff --git a/net/entitymib/Makefile b/net/entitymib/Makefile
index 5c6ff3ff2e81..78c276ba7b0f 100644
--- a/net/entitymib/Makefile
+++ b/net/entitymib/Makefile
@@ -18,8 +18,8 @@ EXTRACT_ONLY=
MAINTAINER= wollman@FreeBSD.org
COMMENT=Display the Entity MIB of an SNMP agent
-RUN_DEPENDS= ${SITE_PERL}/Tree/DAG_Node.pm:${PORTSDIR}/devel/p5-Tree-DAG_Node \
- ${SITE_PERL}/${PERL_ARCH}/SNMP.pm:${PORTSDIR}/net-mgmt/net-snmp
+RUN_DEPENDS= p5-Tree-DAG_Node>=0:${PORTSDIR}/devel/p5-Tree-DAG_Node \
+ net-snmp>=0:${PORTSDIR}/net-mgmt/net-snmp
USE_PERL5_RUN= yes
MAN1= entitymib.1
diff --git a/net/freedbd/Makefile b/net/freedbd/Makefile
index 3c1af500bc29..658536b50e1f 100644
--- a/net/freedbd/Makefile
+++ b/net/freedbd/Makefile
@@ -27,7 +27,7 @@ OPTIONS= XML "XML support" off
.if defined(WITH_XML)
USE_GNOME+= libxml2
CONFIGURE_ARGS+=--with-xml
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+RUN_DEPENDS+= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
PLIST_FILES+= bin/freedbd-parse %%EXAMPLESDIR%%/sample_db.xml
.endif
diff --git a/net/kojoney/Makefile b/net/kojoney/Makefile
index d3d5a5a283a7..4f09f5da760d 100644
--- a/net/kojoney/Makefile
+++ b/net/kojoney/Makefile
@@ -15,7 +15,7 @@ COMMENT= A low level interaction honeypot that emulates an SSH server
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.interface>=3.3.0_1:${PORTSDIR}/devel/py-zope.interface \
${PYTHONPREFIX_SITELIBDIR}/Crypto:${PORTSDIR}/security/py-pycrypto \
- ${SITE_PERL}/IP/Country.pm:${PORTSDIR}/net/p5-IP-Country
+ p5-IP-Country>=0:${PORTSDIR}/net/p5-IP-Country
WRKSRC= ${WRKDIR}/kojoney
diff --git a/net/ldap2dns/Makefile b/net/ldap2dns/Makefile
index 772801698d48..be9ca806b01b 100644
--- a/net/ldap2dns/Makefile
+++ b/net/ldap2dns/Makefile
@@ -14,8 +14,8 @@ MASTER_SITES= http://projects.alkaloid.net/e107_files/downloads/
MAINTAINER= gerrit.beine@gmx.de
COMMENT= Maintain DNS zones using an LDAP directory
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
- ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap
+RUN_DEPENDS= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS \
+ p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap
USE_GMAKE= yes
USE_OPENLDAP= yes
diff --git a/net/ldapsh/Makefile b/net/ldapsh/Makefile
index 9a5158a69ba2..44d3fdeb77ba 100644
--- a/net/ldapsh/Makefile
+++ b/net/ldapsh/Makefile
@@ -16,11 +16,11 @@ MASTER_SITE_SUBDIR= CPAN:LOOSIFER
MAINTAINER= flz@FreeBSD.org
COMMENT= Interactive shell used to administer ldap directories
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
- ${SITE_PERL}/Term/ReadLine/Perl.pm:${PORTSDIR}/devel/p5-ReadLine-Perl \
- ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap \
- ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
- ${SITE_PERL}/Parse/Lex.pm:${PORTSDIR}/devel/p5-ParseLex
+BUILD_DEPENDS= p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey \
+ p5-ReadLine-Perl>=0:${PORTSDIR}/devel/p5-ReadLine-Perl \
+ p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap \
+ p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
+ p5-ParseLex>=0:${PORTSDIR}/devel/p5-ParseLex
RUN_DEPENDS:= ${BUILD_DEPENDS}
SUB_FILES= pkg-message
diff --git a/net/lla/Makefile b/net/lla/Makefile
index 8fa7ba894cb7..5a8906b2e20e 100644
--- a/net/lla/Makefile
+++ b/net/lla/Makefile
@@ -15,9 +15,9 @@ EXTRACT_SUFX= .pl
MAINTAINER= koj@ofug.net
COMMENT= Perl-based LDAP log statistics generator
-RUN_DEPENDS= ${SITE_PERL}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc \
- ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
- ${SITE_PERL}/Time/ParseDate.pm:${PORTSDIR}/devel/p5-Time-modules
+RUN_DEPENDS= p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc \
+ p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
+ p5-Time-modules>=0:${PORTSDIR}/devel/p5-Time-modules
NO_BUILD= yes
NO_WRKSUBDIR= yes
diff --git a/net/p5-Apache2-SOAP/Makefile b/net/p5-Apache2-SOAP/Makefile
index db035d9a13a5..38bb191ff12f 100644
--- a/net/p5-Apache2-SOAP/Makefile
+++ b/net/p5-Apache2-SOAP/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= numisemis@yahoo.com
COMMENT= Apache2 mod_perl2 SOAP Server
BUILD_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_perl.so:${PORTSDIR}/www/mod_perl2 \
- ${SITE_PERL}/SOAP/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite
+ p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Gopher-Server/Makefile b/net/p5-Gopher-Server/Makefile
index 3f2d11f3df3a..16b5b9048db7 100644
--- a/net/p5-Gopher-Server/Makefile
+++ b/net/p5-Gopher-Server/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= toni.viemero@iki.fi
COMMENT= Backend for Gopher Servers
-RUN_DEPENDS= ${SITE_PERL}/Net/Gopher.pm:${PORTSDIR}/net/p5-Net-Gopher \
- ${SITE_PERL}/IO/Scalar.pm:${PORTSDIR}/devel/p5-IO-stringy \
- ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception
+RUN_DEPENDS= p5-Net-Gopher>=0:${PORTSDIR}/net/p5-Net-Gopher \
+ p5-IO-stringy>=0:${PORTSDIR}/devel/p5-IO-stringy \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_MODBUILD= yes
diff --git a/net/p5-IO-Socket-Multicast/Makefile b/net/p5-IO-Socket-Multicast/Makefile
index 8fef1e7ab818..cd855948a060 100644
--- a/net/p5-IO-Socket-Multicast/Makefile
+++ b/net/p5-IO-Socket-Multicast/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Perl module to send and receive multicast messages
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/IO/Interface.pm:${PORTSDIR}/net/p5-IO-Interface
+RUN_DEPENDS= p5-IO-Interface>=0:${PORTSDIR}/net/p5-IO-Interface
BUILD_DEPENDS:= ${RUN_DEPENDS}
MAN3= IO::Socket::Multicast.3
diff --git a/net/p5-IP-Country/Makefile b/net/p5-IP-Country/Makefile
index 576d35416ef4..37d02151b509 100644
--- a/net/p5-IP-Country/Makefile
+++ b/net/p5-IP-Country/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= dikshie@lapi.itb.ac.id
COMMENT= Fast lookup of country codes from IP addresses
-BUILD_DEPENDS= ${SITE_PERL}/Geography/Countries.pm:${PORTSDIR}/misc/p5-Geography-Countries
+BUILD_DEPENDS= p5-Geography-Countries>=0:${PORTSDIR}/misc/p5-Geography-Countries
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Net-FS-Flickr/Makefile b/net/p5-Net-FS-Flickr/Makefile
index 478918751d3f..b92f4cf6e75f 100644
--- a/net/p5-Net-FS-Flickr/Makefile
+++ b/net/p5-Net-FS-Flickr/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= snowfly@yuntech.edu.tw
COMMENT= A Perl interface for store and retrieve files on Flickr
-BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/Acme/Steganography/Image/Png.pm:${PORTSDIR}/graphics/p5-Acme-Steganography-Image-Png \
- ${SITE_PERL}/Flickr/Upload.pm:${PORTSDIR}/www/p5-Flickr-Upload
+BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-Acme-Steganography-Image-Png>=0:${PORTSDIR}/graphics/p5-Acme-Steganography-Image-Png \
+ p5-Flickr-Upload>=0:${PORTSDIR}/www/p5-Flickr-Upload
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
diff --git a/net/p5-Net-FS-Gmail/Makefile b/net/p5-Net-FS-Gmail/Makefile
index 232f915f1fee..20697777ef1f 100644
--- a/net/p5-Net-FS-Gmail/Makefile
+++ b/net/p5-Net-FS-Gmail/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= snowfly@yuntech.edu.tw
COMMENT= A Perl interface for store and retrieve files on Gmail
-BUILD_DEPENDS= ${SITE_PERL}/Mail/Webmail/Gmail.pm:${PORTSDIR}/mail/p5-Mail-Webmail-Gmail \
- ${SITE_PERL}/Time/ParseDate.pm:${PORTSDIR}/devel/p5-Time-modules \
- ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= p5-Mail-Webmail-Gmail>=0:${PORTSDIR}/mail/p5-Mail-Webmail-Gmail \
+ p5-Time-modules>=0:${PORTSDIR}/devel/p5-Time-modules \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Net-Frame-Layer-ICMPv6/Makefile b/net/p5-Net-Frame-Layer-ICMPv6/Makefile
index d36791572aa1..0bc645d34846 100644
--- a/net/p5-Net-Frame-Layer-ICMPv6/Makefile
+++ b/net/p5-Net-Frame-Layer-ICMPv6/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= spry@anarchy.in.the.ph
COMMENT= Perl encoding/decoding implementation of the ICMPv6 layer
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Bit/Vector.pm:${PORTSDIR}/math/p5-Bit-Vector \
- ${SITE_PERL}/Net/Frame.pm:${PORTSDIR}/net/p5-Net-Frame \
+BUILD_DEPENDS= p5-Bit-Vector>=0:${PORTSDIR}/math/p5-Bit-Vector \
+ p5-Net-Frame>=0:${PORTSDIR}/net/p5-Net-Frame \
p5-Net-Pcap>=0.12:${PORTSDIR}/net/p5-Net-Pcap \
p5-Class-Gomor>=1.00:${PORTSDIR}/devel/p5-Class-Gomor
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/net/p5-Net-Frame-Layer-IPv6/Makefile b/net/p5-Net-Frame-Layer-IPv6/Makefile
index 9ca0855b951f..ff3c2fc48bcf 100644
--- a/net/p5-Net-Frame-Layer-IPv6/Makefile
+++ b/net/p5-Net-Frame-Layer-IPv6/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= spry@anarchy.in.the.ph
COMMENT= Perl encoding/decoding implementation of the IPv6 layer
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Bit/Vector.pm:${PORTSDIR}/math/p5-Bit-Vector \
- ${SITE_PERL}/Net/Frame.pm:${PORTSDIR}/net/p5-Net-Frame \
+BUILD_DEPENDS= p5-Bit-Vector>=0:${PORTSDIR}/math/p5-Bit-Vector \
+ p5-Net-Frame>=0:${PORTSDIR}/net/p5-Net-Frame \
p5-Net-Pcap>=0.12:${PORTSDIR}/net/p5-Net-Pcap \
p5-Class-Gomor>=1.00:${PORTSDIR}/devel/p5-Class-Gomor
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/net/p5-Net-SMS-PChome/Makefile b/net/p5-Net-SMS-PChome/Makefile
index 2f121771c73e..d66e47d7f248 100644
--- a/net/p5-Net-SMS-PChome/Makefile
+++ b/net/p5-Net-SMS-PChome/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= snowfly@yuntech.edu.tw
COMMENT= Send SMS messages via the sms.pchome.com.tw service
-BUILD_DEPENDS= ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize \
- ${SITE_PERL}/HTML/TagParser.pm:${PORTSDIR}/www/p5-HTML-TagParser \
- ${SITE_PERL}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc
+BUILD_DEPENDS= p5-WWW-Mechanize>=0:${PORTSDIR}/www/p5-WWW-Mechanize \
+ p5-HTML-TagParser>=0:${PORTSDIR}/www/p5-HTML-TagParser \
+ p5-Date-Calc>=0:${PORTSDIR}/devel/p5-Date-Calc
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Net-SSH-Expect/Makefile b/net/p5-Net-SSH-Expect/Makefile
index 1b025931a276..b5e3cd4db8b3 100644
--- a/net/p5-Net-SSH-Expect/Makefile
+++ b/net/p5-Net-SSH-Expect/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= snowfly@yuntech.edu.tw
COMMENT= SSH wrapper to execute remote commands
-RUN_DEPENDS= ${SITE_PERL}/Expect.pm:${PORTSDIR}/lang/p5-Expect
+RUN_DEPENDS= p5-Expect>=0:${PORTSDIR}/lang/p5-Expect
BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Net-Telnet-Netscreen/Makefile b/net/p5-Net-Telnet-Netscreen/Makefile
index a3b18dd26df9..ccf2187dd4c6 100644
--- a/net/p5-Net-Telnet-Netscreen/Makefile
+++ b/net/p5-Net-Telnet-Netscreen/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= snowfly@yuntech.edu.tw
COMMENT= A Perl interface for interact with a Netscreen firewall
-BUILD_DEPENDS= ${SITE_PERL}/Net/Telnet.pm:${PORTSDIR}/net/p5-Net-Telnet
+BUILD_DEPENDS= p5-Net-Telnet>=0:${PORTSDIR}/net/p5-Net-Telnet
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Net-TiVo/Makefile b/net/p5-Net-TiVo/Makefile
index 4c33c2e34a47..327912418b68 100644
--- a/net/p5-Net-TiVo/Makefile
+++ b/net/p5-Net-TiVo/Makefile
@@ -14,10 +14,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= eg@fbsd.lt
COMMENT= Framework for accessing TiVo using XML/HTTP
-BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
- ${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay
+BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-Net-Twitter-Lite/Makefile b/net/p5-Net-Twitter-Lite/Makefile
index e7e76dcb170b..6e7368cdff1d 100644
--- a/net/p5-Net-Twitter-Lite/Makefile
+++ b/net/p5-Net-Twitter-Lite/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= max@FreeBSD.org
COMMENT= A perl interface to the Twitter API
BUILD_DEPENDS= p5-JSON>=2.02:${PORTSDIR}/converters/p5-JSON \
- ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-Memoize>=0:${PORTSDIR}/devel/p5-Memoize \
p5-URI>=1.4:${PORTSDIR}/net/p5-URI \
p5-Net-OAuth>=0.25:${PORTSDIR}/net/p5-Net-OAuth \
diff --git a/net/p5-POE-Component-Client-Telnet/Makefile b/net/p5-POE-Component-Client-Telnet/Makefile
index 7f7610554d27..9e09d010bec2 100644
--- a/net/p5-POE-Component-Client-Telnet/Makefile
+++ b/net/p5-POE-Component-Client-Telnet/Makefile
@@ -16,8 +16,8 @@ MAINTAINER= tjs@cdpa.nsysu.edu.tw
COMMENT= A POE component that provides non-blocking access to Net::Telnet
BUILD_DEPENDS= p5-POE>=0.31:${PORTSDIR}/devel/p5-POE \
- ${SITE_PERL}/Net/Telnet.pm:${PORTSDIR}/net/p5-Net-Telnet \
- ${SITE_PERL}/Devel/Symdump.pm:${PORTSDIR}/devel/p5-Devel-Symdump
+ p5-Net-Telnet>=0:${PORTSDIR}/net/p5-Net-Telnet \
+ p5-Devel-Symdump>=0:${PORTSDIR}/devel/p5-Devel-Symdump
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-XML-RPC/Makefile b/net/p5-XML-RPC/Makefile
index 94e29d0f9980..c3e2e3a26b7a 100644
--- a/net/p5-XML-RPC/Makefile
+++ b/net/p5-XML-RPC/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= catone@cpan.org
COMMENT= Pure Perl implementation for an XML-RPC client and server
-BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/XML/TreePP.pm:${PORTSDIR}/textproc/p5-XML-TreePP
+BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-XML-TreePP>=0:${PORTSDIR}/textproc/p5-XML-TreePP
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/pbnc/Makefile b/net/pbnc/Makefile
index fc6a4c7ad92d..89c2597de25e 100644
--- a/net/pbnc/Makefile
+++ b/net/pbnc/Makefile
@@ -14,7 +14,7 @@ DISTNAME= pbnc
MAINTAINER= hrs@FreeBSD.org
COMMENT= Simple userspace TCP port bouncer
-RUN_DEPENDS= ${SITE_PERL}/Net/Netmask.pm:${PORTSDIR}/net-mgmt/p5-Net-Netmask
+RUN_DEPENDS= p5-Net-Netmask>=0:${PORTSDIR}/net-mgmt/p5-Net-Netmask
NO_BUILD= yes
USE_PERL5_RUN= yes
diff --git a/net/prosearch/Makefile b/net/prosearch/Makefile
index d1ff86b4cc6a..57aac2e90665 100644
--- a/net/prosearch/Makefile
+++ b/net/prosearch/Makefile
@@ -49,16 +49,16 @@ OPTIONS=\
.include <bsd.port.pre.mk>
RUN_DEPENDS+=\
-${SITE_PERL}/lib/abs.pm:${PORTSDIR}/devel/p5-lib-abs
+p5-lib-abs>=0:${PORTSDIR}/devel/p5-lib-abs
.if defined(WITH_CRAWLER)
RUN_DEPENDS+=\
-${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
-${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
-${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
-${SITE_PERL}/${PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser \
+p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+p5-URI>=0:${PORTSDIR}/net/p5-URI \
+p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
nmap:${PORTSDIR}/security/nmap \
-${SITE_PERL}/Net/DirectConnect.pm:${PORTSDIR}/net-p2p/p5-Net-DirectConnect
+p5-Net-DirectConnect>=0:${PORTSDIR}/net-p2p/p5-Net-DirectConnect
.endif
.if defined(WITH_SAMBA)
@@ -90,7 +90,7 @@ ${LOCALBASE}/${APACHEMODDIR}/mod_perl.so:${PORTSDIR}/www/mod_perl2
.if defined(WITH_MOD_FASTCGI)
RUN_DEPENDS+=\
${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi \
-${SITE_PERL}/${PERL_ARCH}/FCGI.pm:${PORTSDIR}/www/p5-FCGI
+p5-FCGI>=0:${PORTSDIR}/www/p5-FCGI
.endif
.if defined(WITH_SPHINX)
@@ -102,7 +102,7 @@ searchd:${PORTSDIR}/textproc/sphinxsearch-devel
.if defined(WITH_MYSQL)
USE_MYSQL= client
RUN_DEPENDS+=\
-${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
.endif
.if defined(WITH_DB) && defined(WITH_MYSQL)
@@ -111,7 +111,7 @@ USE_MYSQL= server
.if defined(WITH_MARIA)
RUN_DEPENDS+=\
-${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql \
+p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql \
${LOCALBASE}bin/mysql:${PORTSDIR}/databases/mariadb-client
.endif
@@ -123,12 +123,12 @@ ${LOCALBASE}/libexec/mysqld:${PORTSDIR}/databases/mariadb-server
.if defined(WITH_PGSQL)
USE_PGSQL= yes
RUN_DEPENDS+=\
-${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
.endif
.if defined(WITH_PGPP)
RUN_DEPENDS+=\
-${SITE_PERL}/DBD/PgPP.pm:${PORTSDIR}/databases/p5-DBD-PgPP
+p5-DBD-PgPP>=0:${PORTSDIR}/databases/p5-DBD-PgPP
.endif
.if (defined(WITH_PGSQL) || defined(WITH_PGPP)) && defined(WITH_DB)
@@ -140,7 +140,7 @@ ${LOCALBASE}/bin/postgres:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
.if defined(WITH_SQLITE)
USE_SQLITE= yes
RUN_DEPENDS+=\
-${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite
+p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
.endif
WRKSRC= ${WRKDIR}/search
diff --git a/net/rude/Makefile b/net/rude/Makefile
index 9cfa47398e9c..d09cc2520a4a 100644
--- a/net/rude/Makefile
+++ b/net/rude/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= Janos.Mohacsi@bsd.hu
COMMENT= Rude is a Real-time UDP Data Emitter and Collector (crude)
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk
+RUN_DEPENDS= p5-Tk>=0:${PORTSDIR}/x11-toolkits/p5-Tk
HAS_CONFIGURE= yes
CONFIGURE_ENV= --with-debug-lvl=3
diff --git a/net/shelldap/Makefile b/net/shelldap/Makefile
index b697bce02537..96c758f66a49 100644
--- a/net/shelldap/Makefile
+++ b/net/shelldap/Makefile
@@ -13,12 +13,12 @@ MASTER_SITES= http://www.martini.nu/misc/
MAINTAINER= mahlon@martini.nu
COMMENT= A shell-like environment for LDAP
-RUN_DEPENDS= ${SITE_PERL}/Algorithm/Diff.pm:${PORTSDIR}/devel/p5-Algorithm-Diff \
- ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap \
- ${SITE_PERL}/Term/Shell.pm:${PORTSDIR}/devel/p5-Term-Shell \
- ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
- ${SITE_PERL}/${PERL_ARCH}/Term/ReadLine/Gnu.pm:${PORTSDIR}/devel/p5-ReadLine-Gnu \
- ${SITE_PERL}/${PERL_ARCH}/YAML/Syck.pm:${PORTSDIR}/textproc/p5-YAML-Syck
+RUN_DEPENDS= p5-Algorithm-Diff>=0:${PORTSDIR}/devel/p5-Algorithm-Diff \
+ p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap \
+ p5-Term-Shell>=0:${PORTSDIR}/devel/p5-Term-Shell \
+ p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey \
+ p5-ReadLine-Gnu>=0:${PORTSDIR}/devel/p5-ReadLine-Gnu \
+ p5-YAML-Syck>=0:${PORTSDIR}/textproc/p5-YAML-Syck
USE_PERL5= yes
diff --git a/net/smbldap-tools/Makefile b/net/smbldap-tools/Makefile
index 151491069c29..459fb9497fd3 100644
--- a/net/smbldap-tools/Makefile
+++ b/net/smbldap-tools/Makefile
@@ -13,10 +13,10 @@ MASTER_SITES= http://download.gna.org/smbldap-tools/sources/${PORTVERSION}/
MAINTAINER= mm@FreeBSD.org
COMMENT= Samba-LDAP management and support tools
-BUILD_DEPENDS= ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap \
- ${SITE_PERL}/Crypt/SmbHash.pm:${PORTSDIR}/security/p5-Crypt-SmbHash \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
- ${SITE_PERL}/${PERL_ARCH}/Unicode/Map8.pm:${PORTSDIR}/converters/p5-Unicode-MapUTF8
+BUILD_DEPENDS= p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap \
+ p5-Crypt-SmbHash>=0:${PORTSDIR}/security/p5-Crypt-SmbHash \
+ p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-Unicode-MapUTF8>=0:${PORTSDIR}/converters/p5-Unicode-MapUTF8
RUN_DEPENDS:= ${BUILD_DEPENDS}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/a//}
diff --git a/net/xbone/Makefile b/net/xbone/Makefile
index 4b38ff4ba899..6068dbba2762 100644
--- a/net/xbone/Makefile
+++ b/net/xbone/Makefile
@@ -14,30 +14,30 @@ MASTER_SITES= http://www.isi.edu/xbone/software/xbone/
MAINTAINER= xbone@isi.edu
COMMENT= Deploys and manages IP-based VPNs (aka "virtual Internets")
-BUILD_DEPENDS= ${SITE_PERL}/AppConfig.pm:${PORTSDIR}/devel/p5-AppConfig \
- ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
- ${SITE_PERL}/${PERL_ARCH}/IO/Socket/Multicast.pm:${PORTSDIR}/net/p5-IO-Socket-Multicast \
- ${SITE_PERL}/IO/Socket/INET6.pm:${PORTSDIR}/net/p5-IO-Socket-INET6 \
+BUILD_DEPENDS= p5-AppConfig>=0:${PORTSDIR}/devel/p5-AppConfig \
+ p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ p5-IO-Socket-Multicast>=0:${PORTSDIR}/net/p5-IO-Socket-Multicast \
+ p5-IO-Socket-INET6>=0:${PORTSDIR}/net/p5-IO-Socket-INET6 \
p5-IO-Socket-Multicast>=0.25:${PORTSDIR}/net/p5-IO-Socket-Multicast \
p5-IO-Socket-Multicast6>=0:${PORTSDIR}/net/p5-IO-Socket-Multicast6 \
- ${SITE_PERL}/Parallel/ForkManager.pm:${PORTSDIR}/devel/p5-Parallel-ForkManager \
- ${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent \
- ${SITE_PERL}/Graph.pm:${PORTSDIR}/math/p5-Graph \
+ p5-Parallel-ForkManager>=0:${PORTSDIR}/devel/p5-Parallel-ForkManager \
+ p5-Parse-RecDescent>=0:${PORTSDIR}/devel/p5-Parse-RecDescent \
+ p5-Graph>=0:${PORTSDIR}/math/p5-Graph \
p5-NetAddr-IP>0:${PORTSDIR}/net-mgmt/p5-NetAddr-IP \
- ${SITE_PERL}/Net/IP.pm:${PORTSDIR}/net-mgmt/p5-Net-IP \
- ${SITE_PERL}/Net/Netmask.pm:${PORTSDIR}/net-mgmt/p5-Net-Netmask \
- ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
- ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
- ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
- ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
- ${SITE_PERL}/Mail/Sendmail.pm:${PORTSDIR}/mail/p5-Mail-Sendmail \
- ${SITE_PERL}/${PERL_ARCH}/Socket6.pm:${PORTSDIR}/net/p5-Socket6 \
- ${SITE_PERL}/Net/SSH/Perl.pm:${PORTSDIR}/net/p5-Net-SSH-Perl \
- ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap \
- ${SITE_PERL}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk \
- ${SITE_PERL}/Tk/Getopt.pm:${PORTSDIR}/x11-toolkits/p5-Tk-Getopt \
- ${SITE_PERL}/${PERL_ARCH}/Tk/TableMatrix.pm:${PORTSDIR}/x11-toolkits/p5-Tk-TableMatrix
+ p5-Net-IP>=0:${PORTSDIR}/net-mgmt/p5-Net-IP \
+ p5-Net-Netmask>=0:${PORTSDIR}/net-mgmt/p5-Net-Netmask \
+ p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML \
+ p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay \
+ p5-Mail-Sendmail>=0:${PORTSDIR}/mail/p5-Mail-Sendmail \
+ p5-Socket6>=0:${PORTSDIR}/net/p5-Socket6 \
+ p5-Net-SSH-Perl>=0:${PORTSDIR}/net/p5-Net-SSH-Perl \
+ p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap \
+ p5-Tk>=0:${PORTSDIR}/x11-toolkits/p5-Tk \
+ p5-Tk-Getopt>=0:${PORTSDIR}/x11-toolkits/p5-Tk-Getopt \
+ p5-Tk-TableMatrix>=0:${PORTSDIR}/x11-toolkits/p5-Tk-TableMatrix
USE_GMAKE= yes
#IS_INTERACTIVE= yes