aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/py-simplejson/Makefile6
-rw-r--r--devel/py-simplejson/pkg-plist5
2 files changed, 10 insertions, 1 deletions
diff --git a/devel/py-simplejson/Makefile b/devel/py-simplejson/Makefile
index 15ae9b823678..5ff225371d46 100644
--- a/devel/py-simplejson/Makefile
+++ b/devel/py-simplejson/Makefile
@@ -7,6 +7,7 @@
PORTNAME= simplejson
PORTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= http://cheeseshop.python.org/packages/source/s/simplejson/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,4 +21,9 @@ RUN_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYSIMPLEJSON_EGG= ${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+PLIST_SUB+= PYSIMPLEJSON_EGG=${PYSIMPLEJSON_EGG} \
+ EGG_VER="${PORTNAME}==${PORTVERSION}"
+
.include <bsd.port.mk>
diff --git a/devel/py-simplejson/pkg-plist b/devel/py-simplejson/pkg-plist
index d2363b639720..cef763fff859 100644
--- a/devel/py-simplejson/pkg-plist
+++ b/devel/py-simplejson/pkg-plist
@@ -1 +1,4 @@
-%%PYTHON_SITELIBDIR%%/simplejson-1.4-py2.4.egg
+@comment $FreeBSD$
+@unexec easy_install -q -m -S %D/%%PYTHON_SITELIBDIR%% %%EGG_VER%%
+%%PYTHON_SITELIBDIR%%/%%PYSIMPLEJSON_EGG%%
+@exec easy_install -q -N -S %D/%%PYTHON_SITELIBDIR%% %%EGG_VER%%