aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/mono/Makefile4
-rw-r--r--lang/mono/files/patch-aa10
2 files changed, 13 insertions, 1 deletions
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index 8753df01f996..b443d7759c95 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mono
PORTVERSION= 0.13
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://www.go-mono.com/archive/
@@ -17,12 +18,13 @@ LIB_DEPENDS= glib-2.0.0:${PORTSDIR}/devel/glib20 \
gc.1:${PORTSDIR}/devel/boehm-gc
USE_LIBTOOL= yes
+USE_AUTOCONF= yes
USE_REINPLACE= yes
USE_BISON= yes
CONFIGURE_ARGS= --program-transform-name=\'\'
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include " \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd{OSREL}
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= mcs.1 mint.1 mono.1 monoburg.1 monodis.1 monostyle.1
MAN5= mono-config.5
diff --git a/lang/mono/files/patch-aa b/lang/mono/files/patch-aa
new file mode 100644
index 000000000000..13c652621cc0
--- /dev/null
+++ b/lang/mono/files/patch-aa
@@ -0,0 +1,10 @@
+--- configure.in.orig Mon Aug 12 18:20:14 2002
++++ configure.in Mon Aug 12 18:20:37 2002
+@@ -273,6 +273,7 @@
+ AC_CACHE_VAL(cv_mono_sizeof_sunpath,
+ [AC_TRY_RUN([
+ #include <stdio.h>
++ #include <sys/types.h>
+ #include <sys/un.h>
+
+ int main(void) {