aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/gedit/Makefile7
-rw-r--r--editors/gedit2/Makefile7
-rw-r--r--sysutils/gnome-system-monitor/Makefile6
-rw-r--r--sysutils/gnomesystemmonitor/Makefile6
-rw-r--r--sysutils/gtop/Makefile6
5 files changed, 27 insertions, 5 deletions
diff --git a/editors/gedit/Makefile b/editors/gedit/Makefile
index ac2f8dc552aa..9ff2a61118f8 100644
--- a/editors/gedit/Makefile
+++ b/editors/gedit/Makefile
@@ -7,18 +7,23 @@
PORTNAME= gedit
PORTVERSION= 0.9.7
+PORTREVISION= 1
CATEGORIES= editors gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gedit
MAINTAINER= gnome@FreeBSD.org
+BUILD_DEPENDS= msgfmt-old:${PORTSDIR}/devel/gettext-old
+
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LIBS="-L${LOCALBASE}/lib" \
+ MSGFMT="${LOCALBASE}/bin/msgfmt-old" \
+ XGETTEXT="${LOCALBASE}/bin/xgettext-old"
MAN1= gedit.1
diff --git a/editors/gedit2/Makefile b/editors/gedit2/Makefile
index ac2f8dc552aa..9ff2a61118f8 100644
--- a/editors/gedit2/Makefile
+++ b/editors/gedit2/Makefile
@@ -7,18 +7,23 @@
PORTNAME= gedit
PORTVERSION= 0.9.7
+PORTREVISION= 1
CATEGORIES= editors gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gedit
MAINTAINER= gnome@FreeBSD.org
+BUILD_DEPENDS= msgfmt-old:${PORTSDIR}/devel/gettext-old
+
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LIBS="-L${LOCALBASE}/lib" \
+ MSGFMT="${LOCALBASE}/bin/msgfmt-old" \
+ XGETTEXT="${LOCALBASE}/bin/xgettext-old"
MAN1= gedit.1
diff --git a/sysutils/gnome-system-monitor/Makefile b/sysutils/gnome-system-monitor/Makefile
index 3aecb438c0d6..e9d0d3b18523 100644
--- a/sysutils/gnome-system-monitor/Makefile
+++ b/sysutils/gnome-system-monitor/Makefile
@@ -7,19 +7,23 @@
PORTNAME= gtop
PORTVERSION= 1.0.13
+PORTREVISION= 1
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gtop
MAINTAINER= gnome@FreeBSD.org
+BUILD_DEPENDS= msgfmt-old:${PORTSDIR}/devel/gettext-old
LIB_DEPENDS= gtop.1:${PORTSDIR}/devel/libgtop
USE_X_PREFIX= yes
USE_GNOME= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LIBS="-L${LOCALBASE}/lib" \
+ MSGFMT="${LOCALBASE}/bin/msgfmt-old" \
+ XGETTEXT="${LOCALBASE}/bin/xgettext-old"
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
diff --git a/sysutils/gnomesystemmonitor/Makefile b/sysutils/gnomesystemmonitor/Makefile
index 3aecb438c0d6..e9d0d3b18523 100644
--- a/sysutils/gnomesystemmonitor/Makefile
+++ b/sysutils/gnomesystemmonitor/Makefile
@@ -7,19 +7,23 @@
PORTNAME= gtop
PORTVERSION= 1.0.13
+PORTREVISION= 1
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gtop
MAINTAINER= gnome@FreeBSD.org
+BUILD_DEPENDS= msgfmt-old:${PORTSDIR}/devel/gettext-old
LIB_DEPENDS= gtop.1:${PORTSDIR}/devel/libgtop
USE_X_PREFIX= yes
USE_GNOME= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LIBS="-L${LOCALBASE}/lib" \
+ MSGFMT="${LOCALBASE}/bin/msgfmt-old" \
+ XGETTEXT="${LOCALBASE}/bin/xgettext-old"
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
diff --git a/sysutils/gtop/Makefile b/sysutils/gtop/Makefile
index 3aecb438c0d6..e9d0d3b18523 100644
--- a/sysutils/gtop/Makefile
+++ b/sysutils/gtop/Makefile
@@ -7,19 +7,23 @@
PORTNAME= gtop
PORTVERSION= 1.0.13
+PORTREVISION= 1
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gtop
MAINTAINER= gnome@FreeBSD.org
+BUILD_DEPENDS= msgfmt-old:${PORTSDIR}/devel/gettext-old
LIB_DEPENDS= gtop.1:${PORTSDIR}/devel/libgtop
USE_X_PREFIX= yes
USE_GNOME= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LIBS="-L${LOCALBASE}/lib" \
+ MSGFMT="${LOCALBASE}/bin/msgfmt-old" \
+ XGETTEXT="${LOCALBASE}/bin/xgettext-old"
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \