aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.options.desc.mk7
-rw-r--r--mail/prayer/Makefile14
2 files changed, 14 insertions, 7 deletions
diff --git a/Mk/bsd.options.desc.mk b/Mk/bsd.options.desc.mk
index 1df82b3f8cf4..1108afc0c2bb 100644
--- a/Mk/bsd.options.desc.mk
+++ b/Mk/bsd.options.desc.mk
@@ -1,5 +1,12 @@
# $FreeBSD$
#
+# Please keep description ordered alphabetically ordered by variable name
+#
+
+Options_Desc_MAINTAINER= ports@FreeBSD.org
DOCS_DESC?= Build and install the documentation
+LDAP_DESC?= Enable LDAP support
NLS_DESC?= Build and install the localisation data
+SSL_DESC?= Enable SSL support
+TIDY_DESC?= Enable tidy html cleaner support
diff --git a/mail/prayer/Makefile b/mail/prayer/Makefile
index 4034730adc99..f36c30c7328e 100644
--- a/mail/prayer/Makefile
+++ b/mail/prayer/Makefile
@@ -31,10 +31,10 @@ PORTDOCS= ACCOUNTD CMD_LINE DESIGN DONE DONE-OLD FEATURES ICONLIST \
USE_RC_SUBR= prayer
-OPTIONS= SESSIONCACHE "Activate Session Cache" On \
- TIDY "Enable tidy support" On \
- SSL "Enable SSL support" On \
- LDAP "Enable LDAP support" On
+OPTIONS_DEFINE= SESSIONCACHE TIDY SSL LDAP
+OPTIONS_DEFAULT= SESSIONCACHE TIDY SSL LDAP
+
+SESSIONCACHE_DESC= Activate Session Cache
USERS= _prayer
GROUPS= prayer
@@ -44,15 +44,15 @@ MAN8= prayer-session.8 prayer-ssl-prune.8 prayer.8
.include <bsd.port.pre.mk>
-.if defined(WITH_SESSIONCACHE)
+.if ${PORT_OPTIONS:MSESSIONCACHE}
USE_BDB= yes
.endif
-.if !defined(WITHOUT_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
.endif
-.if !defined(WITHOUT_TIDY)
+.if ${PORT_OPTIONS:MTIDY}
LIB_DEPENDS+= tidy-0.99.0:${PORTSDIR}/www/tidy-lib
.endif