aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Time-timegm/Makefile20
-rw-r--r--devel/p5-Time-timegm/distinfo2
-rw-r--r--devel/p5-Time-timegm/pkg-descr10
-rw-r--r--devel/p5-Time-timegm/pkg-plist3
5 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 264c4140d21c..4f01a6860e83 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3142,6 +3142,7 @@
SUBDIR += p5-Time-Stopwatch
SUBDIR += p5-Time-Warp
SUBDIR += p5-Time-modules
+ SUBDIR += p5-Time-timegm
SUBDIR += p5-TimeDate
SUBDIR += p5-ToolSet
SUBDIR += p5-TraceFuncs
diff --git a/devel/p5-Time-timegm/Makefile b/devel/p5-Time-timegm/Makefile
new file mode 100644
index 000000000000..e24e0ef02ff5
--- /dev/null
+++ b/devel/p5-Time-timegm/Makefile
@@ -0,0 +1,20 @@
+# Created by: Geoffroy Desvernay <dgeo@centrale-marseille.fr>
+# $FreeBSD$
+
+PORTNAME= Time-timegm
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:PEVANS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Efficiently compute time from local and GMT time
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Time-timegm/distinfo b/devel/p5-Time-timegm/distinfo
new file mode 100644
index 000000000000..686e210e9878
--- /dev/null
+++ b/devel/p5-Time-timegm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Time-timegm-0.01.tar.gz) = e721cdfda183146b895e04cee712e10ab1bc73c8bad1bbc84c04b19ef1052c98
+SIZE (Time-timegm-0.01.tar.gz) = 13466
diff --git a/devel/p5-Time-timegm/pkg-descr b/devel/p5-Time-timegm/pkg-descr
new file mode 100644
index 000000000000..39669c498452
--- /dev/null
+++ b/devel/p5-Time-timegm/pkg-descr
@@ -0,0 +1,10 @@
+The POSIX standard provides three functions for converting between integer
+epoch values and 6-component "broken-down" time representations.
+localtime and gmtime convert an epoch into the 6 components of seconds,
+minutes, hours, day of month, month and year, in either local timezone or UTC.
+The mktime function converts a local broken-down time into an epoch value.
+However, POSIX does not provide a UTC version of this.
+
+This module provides a function timegm which has this ability.
+
+WWW: https://metacpan.org/pod/Time::timegm
diff --git a/devel/p5-Time-timegm/pkg-plist b/devel/p5-Time-timegm/pkg-plist
new file mode 100644
index 000000000000..27b9c7b920e4
--- /dev/null
+++ b/devel/p5-Time-timegm/pkg-plist
@@ -0,0 +1,3 @@
+%%PERL5_MAN3%%/Time::timegm.3.gz
+%%SITE_PERL%%/Time/timegm.pm
+%%SITE_PERL%%/Time/timegm.xs