aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/tcl-trf/Makefile3
-rw-r--r--devel/tcl-trf/files/patch-intsize33
2 files changed, 34 insertions, 2 deletions
diff --git a/devel/tcl-trf/Makefile b/devel/tcl-trf/Makefile
index f2250baec8cd..da03548c6b06 100644
--- a/devel/tcl-trf/Makefile
+++ b/devel/tcl-trf/Makefile
@@ -22,7 +22,6 @@ BUILD_DEPENDS= tclsh${TCL_VER}:${PORTSDIR}/lang/tcl${TCL_VER:S/.//} \
USE_BZIP2= yes
ALL_TARGET= all test
-#MAKE_ARGS+= -j2
TCL_VER?= 8.4
DDIR= ${PREFIX}/lib/tcl${TCL_VER}/Trf
@@ -83,7 +82,7 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64" || ${ARCH} == "amd64"
+.if ${ARCH} == "sparc64"
BROKEN= "Fails testsuite during build"
.endif
diff --git a/devel/tcl-trf/files/patch-intsize b/devel/tcl-trf/files/patch-intsize
new file mode 100644
index 000000000000..f95655d2aac7
--- /dev/null
+++ b/devel/tcl-trf/files/patch-intsize
@@ -0,0 +1,33 @@
+--- generic/haval.1996/haval.h Fri Jul 11 12:07:36 1997
++++ generic/haval.1996/haval.h Sun Jul 11 13:43:41 2004
+@@ -47,9 +47,6 @@
+ */
+
+-#ifdef __alpha /* aku, Sep 23, 1996 */
+-typedef unsigned int haval_word; /* a HAVAL word = 32 bits */
+-#else
+-typedef unsigned long int haval_word; /* a HAVAL word = 32 bits */
+-#endif
++#include <sys/types.h>
++typedef uint32_t haval_word; /* a HAVAL word = 32 bits */
+
+ typedef struct {
+--- generic/ripemd/rmd128.h Mon May 19 16:53:18 1997
++++ generic/ripemd/rmd128.h Sun Jul 11 13:48:54 2004
+@@ -33,12 +33,8 @@
+ /* adapt these, if necessary,
+ for your operating system and compiler */
++#include <sys/types.h>
+-typedef unsigned char byte; /* unsigned 8-bit type */
+-typedef unsigned short word; /* unsigned 16-bit type */
+-
+-#ifdef __alpha
+-typedef unsigned int dword; /* unsigned 32-bit integer (AXP) */
+-#else
+-typedef unsigned long dword; /* unsigned 32-bit type */
+-#endif
++typedef uint8_t byte; /* unsigned 8-bit type */
++typedef uint16_t word; /* unsigned 16-bit type */
++typedef uint32_t dword; /* unsigned 32-bit type */
+
+ /********************************************************************/