aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/ruby-sdl/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/ruby-sdl/Makefile b/devel/ruby-sdl/Makefile
index 4f2e88e9e13c..7952500d5fe6 100644
--- a/devel/ruby-sdl/Makefile
+++ b/devel/ruby-sdl/Makefile
@@ -25,8 +25,8 @@ USE_RUBY= yes
USE_RUBY_EXTCONF= yes
CONFIGURE_ARGS= --with-sdl-config="sdl11-config" \
- --with-cflags="-pthread" \
- --with-ldflags="-lc_r"
+ --with-cflags="${PTHREAD_CFLAGS}" \
+ --with-ldflags="${PTHREAD_LIBS}"
INSTALL_TARGET= site-install
.include <bsd.port.pre.mk>