aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--math/ceres-solver/files/patch-CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/math/ceres-solver/files/patch-CMakeLists.txt b/math/ceres-solver/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..d52e30ba0b39
--- /dev/null
+++ b/math/ceres-solver/files/patch-CMakeLists.txt
@@ -0,0 +1,13 @@
+https://github.com/ceres-solver/ceres-solver/issues/355
+
+--- CMakeLists.txt.orig 2018-03-22 04:00:14 UTC
++++ CMakeLists.txt
+@@ -435,7 +435,7 @@ if (CXX11 AND COMPILER_HAS_CXX11_FLAG)
+ # Update CMAKE_REQUIRED_FLAGS used by CheckCXXSourceCompiles to include
+ # -std=c++11 s/t we will detect the C++11 versions of unordered_map &
+ # shared_ptr if they exist.
+- set(CMAKE_REQUIRED_FLAGS "${CMAKE_REQUIRED_FLAGS} -std=c++11")
++ set(CMAKE_CXX_STANDARD 11)
+ endif (CXX11 AND COMPILER_HAS_CXX11_FLAG)
+
+ # Set the Ceres compile definitions for the unordered_map configuration.