aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/enblend/Makefile14
-rw-r--r--graphics/hugin/Makefile18
-rw-r--r--graphics/k3d/Makefile30
-rw-r--r--net/kdenetwork4/Makefile10
-rw-r--r--net/pktanon/Makefile4
-rw-r--r--net/xorp-devel/Makefile4
-rw-r--r--print/pdfcube/Makefile6
-rw-r--r--print/scribus-devel/Makefile28
-rw-r--r--print/scribus/Makefile26
-rw-r--r--science/avogadro/Makefile4
-rw-r--r--science/bddsolve/Makefile4
-rw-r--r--science/peekabot/Makefile6
-rw-r--r--sysutils/fusefs-encfs/Makefile4
-rw-r--r--textproc/libkolabxml/Makefile6
-rw-r--r--textproc/sigil/Makefile8
-rw-r--r--textproc/source-highlight/Makefile2
-rw-r--r--textproc/xmlwrapp/Makefile2
-rw-r--r--www/kdewebdev4/Makefile4
-rw-r--r--www/openvrml/Makefile16
-rw-r--r--x11-toolkits/gigi/Makefile6
-rw-r--r--x11/kde4-workspace/Makefile28
21 files changed, 115 insertions, 115 deletions
diff --git a/graphics/enblend/Makefile b/graphics/enblend/Makefile
index a315bd4822ae..98998d4c210c 100644
--- a/graphics/enblend/Makefile
+++ b/graphics/enblend/Makefile
@@ -13,13 +13,13 @@ COMMENT= Tool for image blending with multiresolution splines
BUILD_DEPENDS= ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo \
OpenEXR>=1.0:${PORTSDIR}/graphics/OpenEXR
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- lcms2:${PORTSDIR}/graphics/lcms2 \
- xmi:${PORTSDIR}/graphics/plotutils \
- tiff:${PORTSDIR}/graphics/tiff \
- boost_filesystem:${PORTSDIR}/devel/boost-libs \
- vigraimpex:${PORTSDIR}/graphics/vigra \
- gsl:${PORTSDIR}/math/gsl
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ liblcms2.so:${PORTSDIR}/graphics/lcms2 \
+ libxmi.so:${PORTSDIR}/graphics/plotutils \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libboost_filesystem.so:${PORTSDIR}/devel/boost-libs \
+ libvigraimpex.so:${PORTSDIR}/graphics/vigra \
+ libgsl.so:${PORTSDIR}/math/gsl
RUN_DEPENDS= OpenEXR>=1.0:${PORTSDIR}/graphics/OpenEXR
USE_AUTOTOOLS= automake:env autoconf:env
diff --git a/graphics/hugin/Makefile b/graphics/hugin/Makefile
index 67d768f31483..21c42cd5af4a 100644
--- a/graphics/hugin/Makefile
+++ b/graphics/hugin/Makefile
@@ -10,15 +10,15 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
MAINTAINER= vd@FreeBSD.org
COMMENT= A GUI for Panorama Tools, to stitch panoramic images
-LIB_DEPENDS= IlmImf:${PORTSDIR}/graphics/OpenEXR \
- Imath:${PORTSDIR}/graphics/ilmbase \
- boost_thread:${PORTSDIR}/devel/boost-libs \
- exiv2.12:${PORTSDIR}/graphics/exiv2 \
- jpeg:${PORTSDIR}/graphics/jpeg \
- lensfun:${PORTSDIR}/graphics/lensfun \
- pano13:${PORTSDIR}/graphics/libpano13 \
- png15:${PORTSDIR}/graphics/png \
- tiff:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
+ libImath.so:${PORTSDIR}/graphics/ilmbase \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libexiv2.so:${PORTSDIR}/graphics/exiv2 \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ liblensfun.so:${PORTSDIR}/graphics/lensfun \
+ libpano13.so:${PORTSDIR}/graphics/libpano13 \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff
BUILD_DEPENDS= swig2.0:${PORTSDIR}/devel/swig20 \
tclap>=1.2.1:${PORTSDIR}/devel/tclap
# gmake is really needed at _runtime_. Do not remove it from this list.
diff --git a/graphics/k3d/Makefile b/graphics/k3d/Makefile
index 7daff492ec15..c623bc6fb87a 100644
--- a/graphics/k3d/Makefile
+++ b/graphics/k3d/Makefile
@@ -16,15 +16,15 @@ LICENSE= GPLv2
BROKEN= Fails to configure
BUILD_DEPENDS= ${LOCALBASE}/include/gmm/gmm.h:${PORTSDIR}/math/gmm++
-LIB_DEPENDS= boost_python:${PORTSDIR}/devel/boost-python-libs \
- execinfo:${PORTSDIR}/devel/libexecinfo \
- jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- tiff:${PORTSDIR}/graphics/tiff \
- uuid:${PORTSDIR}/misc/e2fsprogs-libuuid \
- expat:${PORTSDIR}/textproc/expat2 \
- gtkglext-x11-1.0:${PORTSDIR}/x11-toolkits/gtkglext \
- gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24
+LIB_DEPENDS= libboost_python.so:${PORTSDIR}/devel/boost-python-libs \
+ libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid \
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext \
+ libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24
OPTIONS_DEFINE= 3DS COMPIZ GNOME PERFTOOLS GTS IMAGEMAGICK OPENEXR
3DS_DESC= 3ds_io plugin module
@@ -58,7 +58,7 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:M3DS}
-LIB_DEPENDS+= 3ds-1:${PORTSDIR}/graphics/lib3ds
+LIB_DEPENDS+= lib3ds-1.so:${PORTSDIR}/graphics/lib3ds
PLIST_SUB+= 3DS=""
.else
CMAKE_ARGS+= -DK3D_BUILD_3DS_IO_MODULE:BOOL=OFF
@@ -66,7 +66,7 @@ PLIST_SUB+= 3DS="@comment "
.endif
.if ${PORT_OPTIONS:MCOMPIZ}
-LIB_DEPENDS+= dbus-glib:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS+= libdbus-glib.so:${PORTSDIR}/devel/dbus-glib
PLIST_SUB+= COMPIZ=""
.else
CMAKE_ARGS+= -DK3D_BUILD_COMPIZ_MODULE:BOOL=OFF
@@ -82,7 +82,7 @@ PLIST_SUB+= GNOME="@comment "
.endif
.if ${PORT_OPTIONS:MPERFTOOLS}
-LIB_DEPENDS+= profiler:${PORTSDIR}/devel/google-perftools
+LIB_DEPENDS+= libprofiler.so:${PORTSDIR}/devel/google-perftools
PLIST_SUB+= PERFTOOLS=""
.else
CMAKE_ARGS+= -DK3D_BUILD_GOOGLE_PERFTOOLS_MODULE:BOOL=OFF
@@ -90,7 +90,7 @@ PLIST_SUB+= PERFTOOLS="@comment "
.endif
.if ${PORT_OPTIONS:MGTS}
-LIB_DEPENDS+= gts:${PORTSDIR}/graphics/gts
+LIB_DEPENDS+= libgts.so:${PORTSDIR}/graphics/gts
PLIST_SUB+= GTS=""
.else
CMAKE_ARGS+= -DK3D_BUILD_GTS_MODULE:BOOL=OFF
@@ -98,7 +98,7 @@ PLIST_SUB+= GTS="@comment "
.endif
.if ${PORT_OPTIONS:MIMAGEMAGICK}
-LIB_DEPENDS+= MagickCore:${PORTSDIR}/graphics/ImageMagick
+LIB_DEPENDS+= libMagickCore.so:${PORTSDIR}/graphics/ImageMagick
PLIST_SUB+= IMAGEMAGICK=""
.else
CMAKE_ARGS+= -DK3D_BUILD_IMAGEMAGICK_IO_MODULE:BOOL=OFF
@@ -106,7 +106,7 @@ PLIST_SUB+= IMAGEMAGICK="@comment "
.endif
.if ${PORT_OPTIONS:MOPENEXR}
-LIB_DEPENDS+= IlmImf:${PORTSDIR}/graphics/OpenEXR
+LIB_DEPENDS+= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR
PLIST_SUB+= OPENEXR=""
.else
CMAKE_ARGS+= -DK3D_BUILD_OPENEXR_IO_MODULE:BOOL=OFF
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index ae8a57dbad0b..6c1efa65aacd 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -12,11 +12,11 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE Network applications
-LIB_DEPENDS= qca.2:${PORTSDIR}/devel/qca \
- ktorrent:${PORTSDIR}/net-p2p/libktorrent \
- boost_thread:${PORTSDIR}/devel/boost-libs \
- mms.0:${PORTSDIR}/net/libmms \
- jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libqca.so:${PORTSDIR}/devel/qca \
+ libktorrent.so:${PORTSDIR}/net-p2p/libktorrent \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libmms.so:${PORTSDIR}/net/libmms \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg
RUN_DEPENDS= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl
LATEST_LINK= ${PORTNAME}4
diff --git a/net/pktanon/Makefile b/net/pktanon/Makefile
index 01bbf0a4f77f..83a61bbe687a 100644
--- a/net/pktanon/Makefile
+++ b/net/pktanon/Makefile
@@ -9,8 +9,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-dev
MAINTAINER= wxs@FreeBSD.org
COMMENT= Network trace anonymizer
-LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost-libs \
- xerces-c.3:${PORTSDIR}/textproc/xerces-c3
+LIB_DEPENDS= libboost_regex.so:${PORTSDIR}/devel/boost-libs \
+ libxerces-c.so.3:${PORTSDIR}/textproc/xerces-c3
USE_DOS2UNIX= yes
GNU_CONFIGURE= yes
diff --git a/net/xorp-devel/Makefile b/net/xorp-devel/Makefile
index 73650502c7f5..89b890ca9b8a 100644
--- a/net/xorp-devel/Makefile
+++ b/net/xorp-devel/Makefile
@@ -13,8 +13,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Open source network routing platform, development branch
# Uses libcurses, libcrypto, librt from base system.
-LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost-libs \
- pcap:${PORTSDIR}/net/libpcap
+LIB_DEPENDS= libboost_regex.so:${PORTSDIR}/devel/boost-libs \
+ libpcap.so:${PORTSDIR}/net/libpcap
CONFLICTS= xorp-1*
diff --git a/print/pdfcube/Makefile b/print/pdfcube/Makefile
index a00043ebab4b..124b6a27cc26 100644
--- a/print/pdfcube/Makefile
+++ b/print/pdfcube/Makefile
@@ -9,9 +9,9 @@ MASTER_SITES= http://code.100allora.it/releases/pdfcube/
MAINTAINER= lwhsu@FreeBSD.org
COMMENT= An OpenGL presentation viewer on a spinning cube
-LIB_DEPENDS= gtkglext:${PORTSDIR}/x11-toolkits/gtkglext \
- poppler-glib:${PORTSDIR}/graphics/poppler-glib \
- boost_program_options:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libgtkglext.so:${PORTSDIR}/x11-toolkits/gtkglext \
+ libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib \
+ libboost_program_options.so:${PORTSDIR}/devel/boost-libs
USES= pkgconfig
USE_GL= glut
diff --git a/print/scribus-devel/Makefile b/print/scribus-devel/Makefile
index 618dbddef430..7495a03e28a2 100644
--- a/print/scribus-devel/Makefile
+++ b/print/scribus-devel/Makefile
@@ -13,20 +13,20 @@ PKGNAMESUFFIX= -devel
MAINTAINER= coder@tuxfamily.org
COMMENT= Comprehensive desktop publishing program
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- lcms:${PORTSDIR}/graphics/lcms \
- png15:${PORTSDIR}/graphics/png \
- tiff:${PORTSDIR}/graphics/tiff \
- cups:${PORTSDIR}/print/cups-base \
- freetype:${PORTSDIR}/print/freetype2 \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- podofo:${PORTSDIR}/graphics/podofo \
- boost_thread:${PORTSDIR}/devel/boost-libs \
- aspell:${PORTSDIR}/textproc/aspell \
- cairo:${PORTSDIR}/graphics/cairo \
- execinfo:${PORTSDIR}/devel/libexecinfo \
- poppler:${PORTSDIR}/graphics/poppler \
- osg:${PORTSDIR}/graphics/osg
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ liblcms.so:${PORTSDIR}/graphics/lcms \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libcups.so:${PORTSDIR}/print/cups-base \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
+ libpodofo.so:${PORTSDIR}/graphics/podofo \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libaspell.so:${PORTSDIR}/textproc/aspell \
+ libcairo.so:${PORTSDIR}/graphics/cairo \
+ libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
+ libpoppler.so:${PORTSDIR}/graphics/poppler \
+ libosg.so:${PORTSDIR}/graphics/osg
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter \
${PYTHON_SITELIBDIR}/PIL/_imaging.so:${PORTSDIR}/graphics/py-imaging \
update-mime-database:${PORTSDIR}/misc/shared-mime-info
diff --git a/print/scribus/Makefile b/print/scribus/Makefile
index f6dce62e0692..dea4ed9bf9cf 100644
--- a/print/scribus/Makefile
+++ b/print/scribus/Makefile
@@ -10,19 +10,19 @@ MASTER_SITES= SF \
MAINTAINER= bsam@FreeBSD.org
COMMENT= Comprehensive desktop publishing program
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- lcms:${PORTSDIR}/graphics/lcms \
- png15:${PORTSDIR}/graphics/png \
- tiff:${PORTSDIR}/graphics/tiff \
- cups:${PORTSDIR}/print/cups-client \
- freetype:${PORTSDIR}/print/freetype2 \
- podofo:${PORTSDIR}/graphics/podofo \
- boost_thread:${PORTSDIR}/devel/boost-libs \
- hunspell:${PORTSDIR}/textproc/hunspell \
- cairo:${PORTSDIR}/graphics/cairo \
- hyphen:${PORTSDIR}/textproc/hyphen \
- execinfo:${PORTSDIR}/devel/libexecinfo \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ liblcms.so:${PORTSDIR}/graphics/lcms \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libcups.so:${PORTSDIR}/print/cups-client \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libpodofo.so:${PORTSDIR}/graphics/podofo \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libhunspell.so:${PORTSDIR}/textproc/hunspell \
+ libcairo.so:${PORTSDIR}/graphics/cairo \
+ libhyphen.so:${PORTSDIR}/textproc/hyphen \
+ libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter \
${PYTHON_SITELIBDIR}/PIL/_imaging.so:${PORTSDIR}/graphics/py-imaging
diff --git a/science/avogadro/Makefile b/science/avogadro/Makefile
index 25a034313c5a..89a007eaf224 100644
--- a/science/avogadro/Makefile
+++ b/science/avogadro/Makefile
@@ -13,7 +13,7 @@ COMMENT= Advanced molecular editor and viewer
LICENSE= GPLv2 # (or later)
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2
-LIB_DEPENDS= openbabel:${PORTSDIR}/science/openbabel
+LIB_DEPENDS= libopenbabel.so:${PORTSDIR}/science/openbabel
OPTIONS_DEFINE= PYTHON
OPTIONS_DEFAULT=PYTHON
@@ -40,7 +40,7 @@ CMAKE_ARGS+= -DENABLE_PYTHON=ON
USE_PYTHON= -2.7
BUILD_DEPENDS+= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}sip>0:${PORTSDIR}/devel/py-sip
-LIB_DEPENDS+= boost_python:${PORTSDIR}/devel/boost-python-libs
+LIB_DEPENDS+= libboost_python.so:${PORTSDIR}/devel/boost-python-libs
RUN_DEPENDS+= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}sip>0:${PORTSDIR}/devel/py-sip
PLIST_SUB+= PYTHON=""
diff --git a/science/bddsolve/Makefile b/science/bddsolve/Makefile
index f011c4f65661..0d8724045fcc 100644
--- a/science/bddsolve/Makefile
+++ b/science/bddsolve/Makefile
@@ -10,8 +10,8 @@ DISTNAME= ${PORTNAME}-source-${PORTVERSION}
MAINTAINER= ed@FreeBSD.org
COMMENT= BDD-based satisfiability and reachability solver
-LIB_DEPENDS+= bdd:${PORTSDIR}/science/buddy \
- boost_program_options:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS+= libbdd.so:${PORTSDIR}/science/buddy \
+ libboost_program_options.so:${PORTSDIR}/devel/boost-libs
USE_ZIP= yes
NO_WRKSUBDIR= yes
diff --git a/science/peekabot/Makefile b/science/peekabot/Makefile
index 1321a139e025..625af659ae07 100644
--- a/science/peekabot/Makefile
+++ b/science/peekabot/Makefile
@@ -15,9 +15,9 @@ LICENSE_COMB= multi
BROKEN= Does not build
-LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost-libs \
- xerces-c.3:${PORTSDIR}/textproc/xerces-c3 \
- gtkglextmm-x11-1.2:${PORTSDIR}/x11-toolkits/gtkglextmm
+LIB_DEPENDS= libboost_regex.so:${PORTSDIR}/devel/boost-libs \
+ libxerces-c.so.3:${PORTSDIR}/textproc/xerces-c3 \
+ libgtkglextmm-x11-1.2.so:${PORTSDIR}/x11-toolkits/gtkglextmm
USE_BZIP2= yes
USES= pathfix gmake
diff --git a/sysutils/fusefs-encfs/Makefile b/sysutils/fusefs-encfs/Makefile
index e6e173b371f8..6b4611adbd1f 100644
--- a/sysutils/fusefs-encfs/Makefile
+++ b/sysutils/fusefs-encfs/Makefile
@@ -12,8 +12,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= An encrypted pass-through FUSE filesystem
-LIB_DEPENDS= rlog.5:${PORTSDIR}/devel/rlog \
- boost_serialization:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= librlog.so:${PORTSDIR}/devel/rlog \
+ libboost_serialization.so:${PORTSDIR}/devel/boost-libs
WRKSRC= ${WRKDIR}/encfs-${PORTVERSION}
diff --git a/textproc/libkolabxml/Makefile b/textproc/libkolabxml/Makefile
index cea1ddd87391..43d2fc942404 100644
--- a/textproc/libkolabxml/Makefile
+++ b/textproc/libkolabxml/Makefile
@@ -15,9 +15,9 @@ COMMENT= Kolab XML Format Schema Definitions Library
LICENSE= LGPL3
BUILD_DEPENDS= xsdcxx:${PORTSDIR}/devel/xsd
-LIB_DEPENDS= boost_system:${PORTSDIR}/devel/boost-libs \
- curl:${PORTSDIR}/ftp/curl \
- xerces-c.3:${PORTSDIR}/textproc/xerces-c3
+LIB_DEPENDS= libboost_system.so:${PORTSDIR}/devel/boost-libs \
+ libcurl.so:${PORTSDIR}/ftp/curl \
+ libxerces-c.so.3:${PORTSDIR}/textproc/xerces-c3
# TODO: Conditionally enable the bindings based on OPTIONs.
CMAKE_ARGS= -DBUILD_TESTS:BOOL=OFF \
diff --git a/textproc/sigil/Makefile b/textproc/sigil/Makefile
index 945676ffc3d5..921b18cfd3a2 100644
--- a/textproc/sigil/Makefile
+++ b/textproc/sigil/Makefile
@@ -11,10 +11,10 @@ DISTNAME= Sigil-${PORTVERSION}-Code
MAINTAINER= jonc@chen.org.nz
COMMENT= WYSIWYG ePub editor
-LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs \
- xerces-c:${PORTSDIR}/textproc/xerces-c3 \
- hunspell-1.3:${PORTSDIR}/textproc/hunspell \
- pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libxerces-c.so:${PORTSDIR}/textproc/xerces-c3 \
+ libhunspell-1.so:${PORTSDIR}/textproc/hunspell \
+ libpcre.so:${PORTSDIR}/devel/pcre
LICENSE= GPLv3
diff --git a/textproc/source-highlight/Makefile b/textproc/source-highlight/Makefile
index 3d59b2faa6cc..6ef7e08d0761 100644
--- a/textproc/source-highlight/Makefile
+++ b/textproc/source-highlight/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= kevlo@FreeBSD.org
COMMENT= C/C++ and Java sources to HTML converter
BUILD_DEPENDS= exctags:${PORTSDIR}/devel/ctags
-LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libboost_regex.so:${PORTSDIR}/devel/boost-libs
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/textproc/xmlwrapp/Makefile b/textproc/xmlwrapp/Makefile
index da7cb8da1778..dd839c0dde33 100644
--- a/textproc/xmlwrapp/Makefile
+++ b/textproc/xmlwrapp/Makefile
@@ -12,7 +12,7 @@ COMMENT= A modern style C++ library for working with XML data
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= boost_iostreams:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libboost_iostreams.so:${PORTSDIR}/devel/boost-libs
OPTIONS_DEFINE= XSLT
XSLT_DESC= Build libxsltwrap library (requires libxslt)
diff --git a/www/kdewebdev4/Makefile b/www/kdewebdev4/Makefile
index b2105351eda9..2711e53be59b 100644
--- a/www/kdewebdev4/Makefile
+++ b/www/kdewebdev4/Makefile
@@ -11,8 +11,8 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Comprehensive html/website development environment
-LIB_DEPENDS= tidy-0.99.0:${PORTSDIR}/www/tidy-lib \
- boost_thread:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libtidy-0.99.so:${PORTSDIR}/www/tidy-lib \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs
LATEST_LINK= ${PORTNAME}4
diff --git a/www/openvrml/Makefile b/www/openvrml/Makefile
index 4f73bf61d734..70099225c99e 100644
--- a/www/openvrml/Makefile
+++ b/www/openvrml/Makefile
@@ -13,12 +13,12 @@ COMMENT= VRML97 runtime and browser
BROKEN= does not build
BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone
-LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
- js.1:${PORTSDIR}/lang/spidermonkey17 \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- curl:${PORTSDIR}/ftp/curl \
- gtkglext-x11-1.0:${PORTSDIR}/x11-toolkits/gtkglext
+LIB_DEPENDS= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
+ libjs.so:${PORTSDIR}/lang/spidermonkey17 \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libcurl.so:${PORTSDIR}/ftp/curl \
+ libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext
USE_GL= yes
USES= pathfix pkgconfig
@@ -54,8 +54,8 @@ NO_STAGE= yes
BROKEN= Gets internal gcc error on ${ARCH}
.endif
-LIB_DEPENDS+= boost_regex:${PORTSDIR}/devel/boost-libs
-LIB_DEPENDS+= boost_python:${PORTSDIR}/devel/boost-python-libs
+LIB_DEPENDS+= libboost_regex.so:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS+= libboost_python.so:${PORTSDIR}/devel/boost-python-libs
pre-everything::
@${ECHO_MSG}
diff --git a/x11-toolkits/gigi/Makefile b/x11-toolkits/gigi/Makefile
index 27abe04f423b..f7993601c176 100644
--- a/x11-toolkits/gigi/Makefile
+++ b/x11-toolkits/gigi/Makefile
@@ -12,9 +12,9 @@ MASTER_SITE_SUBDIR= oliver
MAINTAINER= oliver@FreeBSD.org
COMMENT= OpenGL Graphic User Interface Library
-LIB_DEPENDS= IL.2:${PORTSDIR}/graphics/devil \
- boost_python:${PORTSDIR}/devel/boost-python-libs \
- freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= libIL.so:${PORTSDIR}/graphics/devil \
+ libboost_python.so:${PORTSDIR}/devel/boost-python-libs \
+ libfreetype.so:${PORTSDIR}/print/freetype2
USE_GCC= yes
USES= cmake
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 808a2df6c2d1..13926795aaf8 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -11,20 +11,20 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE Plasma Desktop
-LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus \
- ck-connector:${PORTSDIR}/sysutils/consolekit \
- pci:${PORTSDIR}/devel/libpci \
- hal:${PORTSDIR}/sysutils/hal \
- qalculate:${PORTSDIR}/math/libqalculate \
- prison:${PORTSDIR}/graphics/prison \
- boost_thread:${PORTSDIR}/devel/boost-libs \
- dbusmenu-qt:${PORTSDIR}/devel/libdbusmenu-qt \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- freetype:${PORTSDIR}/print/freetype2 \
- png15:${PORTSDIR}/graphics/png \
- jpeg:${PORTSDIR}/graphics/jpeg \
- xcb-render-util:${PORTSDIR}/x11/xcb-util-renderutil \
- xcb-image:${PORTSDIR}/x11/xcb-util-image
+LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
+ libck-connector.so:${PORTSDIR}/sysutils/consolekit \
+ libpci.so:${PORTSDIR}/devel/libpci \
+ libhal.so:${PORTSDIR}/sysutils/hal \
+ libqalculate.so:${PORTSDIR}/math/libqalculate \
+ libprison.so:${PORTSDIR}/graphics/prison \
+ libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libdbusmenu-qt.so:${PORTSDIR}/devel/libdbusmenu-qt \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
+ libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libxcb-render-util.so:${PORTSDIR}/x11/xcb-util-renderutil \
+ libxcb-image.so:${PORTSDIR}/x11/xcb-util-image
BUILD_DEPENDS= xrdb:${PORTSDIR}/x11/xrdb
RUN_DEPENDS= ${KDE4_PREFIX}/env/xdg-env.sh:${PORTSDIR}/misc/kde4-xdg-env \
${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme \