aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/dovecot-devel/Makefile10
-rw-r--r--mail/dovecot-devel/distinfo6
-rw-r--r--mail/dovecot-devel/files/patch-dovecot-example.conf113
-rw-r--r--mail/dovecot-devel/pkg-plist25
4 files changed, 104 insertions, 50 deletions
diff --git a/mail/dovecot-devel/Makefile b/mail/dovecot-devel/Makefile
index 726594aebcf2..6d68debc500f 100644
--- a/mail/dovecot-devel/Makefile
+++ b/mail/dovecot-devel/Makefile
@@ -7,10 +7,12 @@
#
PORTNAME= dovecot
-DISTVERSION= 1.0.13
-PORTREVISION= 2
+DISTVERSION= 1.1.rc4
+PORTREVISION= 0
CATEGORIES= mail ipv6
-MASTER_SITES= http://www.dovecot.org/releases/1.0/
+MASTER_SITES= http://www.dovecot.org/releases/1.1/rc/ \
+ ${MASTER_SITE_GENTOO}
+MASTER_SITE_SUBDIR= distfiles
MAINTAINER= robin@isometry.net
COMMENT= Secure and compact IMAP and POP3 servers
@@ -18,6 +20,8 @@ COMMENT= Secure and compact IMAP and POP3 servers
USE_ICONV= yes
USE_RC_SUBR= dovecot.sh
+CONFLICTS?= ${PORTNAME}-1.[02-9].*
+
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --without-shadow --localstatedir=/var
diff --git a/mail/dovecot-devel/distinfo b/mail/dovecot-devel/distinfo
index 1c66e8089c50..e480fcbf8ed8 100644
--- a/mail/dovecot-devel/distinfo
+++ b/mail/dovecot-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (dovecot-1.0.13.tar.gz) = 281bd9dee8d6c1674977257acc80ce64
-SHA256 (dovecot-1.0.13.tar.gz) = 16da29b2bc08d0178a09323bf0787a2a0e953075655566a7b4b6b148c87ac25f
-SIZE (dovecot-1.0.13.tar.gz) = 1774025
+MD5 (dovecot-1.1.rc4.tar.gz) = 56b4867eccd3ef8978d1f97a6df48bd8
+SHA256 (dovecot-1.1.rc4.tar.gz) = 3ea99c61b8d71a2139562f9a4733fb38cfb431927f4ad98a8e36c21c23f2e69e
+SIZE (dovecot-1.1.rc4.tar.gz) = 2221964
diff --git a/mail/dovecot-devel/files/patch-dovecot-example.conf b/mail/dovecot-devel/files/patch-dovecot-example.conf
index b534647dd4a4..3e1fdd2f4978 100644
--- a/mail/dovecot-devel/files/patch-dovecot-example.conf
+++ b/mail/dovecot-devel/files/patch-dovecot-example.conf
@@ -1,5 +1,5 @@
---- dovecot-example.conf.orig 2008-03-04 05:48:12.000000000 +0000
-+++ dovecot-example.conf 2008-03-05 22:49:08.554336095 +0000
+--- ./dovecot-example.conf.orig 2008-03-14 20:01:35.000000000 -0700
++++ ./dovecot-example.conf 2008-04-30 14:18:20.161269186 -0700
@@ -12,7 +12,7 @@
# Default values are shown for each setting, it's not required to uncomment
# any of the lines. Exception to this are paths, they're just examples with
@@ -15,9 +15,9 @@
#protocols = imap imaps
+protocols = %%PROTOCOLS%%
- # IP or host address where to listen in for connections. It's not currently
- # possible to specify multiple addresses. "*" listens in all IPv4 interfaces.
-@@ -210,6 +212,7 @@
+ # A space separated list of IP or host addresses where to listen in for
+ # connections. "*" listens in all IPv4 interfaces. "[::]" listens in all IPv6
+@@ -213,6 +214,7 @@
# <doc/wiki/MailLocation.txt>
#
#mail_location =
@@ -25,7 +25,7 @@
# If you need to set multiple mailbox locations or want to change default
# namespace settings, you can do it by defining namespace sections.
-@@ -256,6 +259,7 @@
+@@ -273,6 +275,7 @@
# used only for creating mbox dotlock files when creation fails for INBOX.
# Typically this is set to "mail" to give access to /var/mail.
#mail_privileged_group =
@@ -33,7 +33,7 @@
# Grant access to these supplementary groups for mail processes. Typically
# these are used to set up access to shared mailboxes. Note that it may be
-@@ -320,6 +324,7 @@
+@@ -340,6 +343,7 @@
# IP address. Useful for seeing who are actually using the IMAP processes
# (eg. shared mailboxes or if same uid is used for multiple accounts).
#verbose_proctitle = no
@@ -41,15 +41,7 @@
# Valid UID range for users, defaults to 500 and above. This is mostly
# to make sure that users can't log in as daemons or other system users.
-@@ -333,6 +338,7 @@
- # belongs to supplementary groups with non-valid GIDs, those groups are
- # not set.
- #first_valid_gid = 1
-+first_valid_gid = 0
- #last_valid_gid = 0
-
- # Maximum number of running mail processes. When this limit is reached,
-@@ -506,19 +512,19 @@
+@@ -502,19 +506,19 @@
protocol imap {
# Login executable location.
@@ -73,7 +65,7 @@
# Maximum IMAP command line length in bytes. Some clients generate very long
# command lines with huge mailboxes, so you may need to raise this if you get
-@@ -528,7 +534,7 @@
+@@ -528,7 +532,7 @@
# Support for dynamically loadable plugins. mail_plugins is a space separated
# list of plugins to load.
#mail_plugins =
@@ -82,15 +74,15 @@
# Send IMAP capabilities in greeting message. This makes it unnecessary for
# clients to request it with CAPABILITY command, so it saves one round-trip.
-@@ -563,6 +569,7 @@
+@@ -563,6 +567,7 @@
# accept '/' suffix in mailbox names in subscriptions list.
# The list is space-separated.
- #imap_client_workarounds = outlook-idle
-+ imap_client_workarounds = delay-newmail outlook-idle netscape-eoh tb-extra-mailbox-sep
+ #imap_client_workarounds =
++ imap_client_workarounds = delay-newmail netscape-eoh tb-extra-mailbox-sep
}
##
-@@ -571,11 +578,11 @@
+@@ -571,11 +576,11 @@
protocol pop3 {
# Login executable location.
@@ -104,15 +96,15 @@
# Don't try to set mails non-recent or seen with POP3 sessions. This is
# mostly intended to reduce disk I/O. With maildir it doesn't move files
-@@ -621,6 +628,7 @@
- # installations.
+@@ -615,6 +620,7 @@
+ # idea to change this. %08Xu%08Xv should be pretty fail-safe.
#
- #pop3_uidl_format =
+ #pop3_uidl_format = %08Xu%08Xv
+ pop3_uidl_format = %08Xu%08Xv
# POP3 logout format string:
- # %t - number of TOP commands
-@@ -635,7 +643,7 @@
+ # %i - total number of bytes read from client
+@@ -635,7 +641,7 @@
# Support for dynamically loadable plugins. mail_plugins is a space separated
# list of plugins to load.
#mail_plugins =
@@ -121,7 +113,7 @@
# Workarounds for various client bugs:
# outlook-no-nuls:
-@@ -646,6 +654,7 @@
+@@ -646,6 +652,7 @@
# missing. This option simply sends it if it's missing.
# The list is space-separated.
#pop3_client_workarounds =
@@ -129,20 +121,25 @@
}
##
-@@ -663,10 +672,11 @@
+@@ -663,7 +670,7 @@
# Support for dynamically loadable plugins. mail_plugins is a space separated
# list of plugins to load.
#mail_plugins =
- #mail_plugin_dir = /usr/lib/dovecot/lda
+ #mail_plugin_dir = %%PREFIX%%/lib/dovecot/lda
+ # If user is over quota, return with temporary failure instead of
+ # bouncing the mail.
+@@ -677,7 +684,7 @@
+ #deliver_log_format = msgid=%m: %$
+
# Binary to use for sending mails.
- #sendmail_path = /usr/lib/sendmail
-+ sendmail_path = /usr/sbin/sendmail
+- #sendmail_path = /usr/lib/sendmail
++ #sendmail_path = /usr/sbin/sendmail
- # UNIX socket path to master authentication server to find users.
- #auth_socket_path = /var/run/dovecot/auth-master
-@@ -677,7 +687,7 @@
+ # Human readable error message for rejection mails. Use can use variables:
+ # %n = CRLF, %r = reason, %s = subject, %t = recipient
+@@ -692,7 +699,7 @@
##
# Executable location
@@ -151,7 +148,16 @@
# Set max. process size in megabytes.
#auth_process_size = 256
-@@ -783,7 +793,7 @@
+@@ -782,7 +789,7 @@
+ #auth_ntlm_use_winbind = no
+
+ # Path for Samba's ntlm_auth helper binary.
+-#auth_winbind_helper_path = /usr/bin/ntlm_auth
++#auth_winbind_helper_path = %%PREFIX%%/bin/ntlm_auth
+
+ # Number of seconds to delay before replying to failed authentications.
+ #auth_failure_delay = 2
+@@ -815,7 +822,7 @@
#passdb passwd-file {
# File contains a list of usernames, one per line
@@ -160,7 +166,7 @@
#deny = yes
#}
-@@ -1021,7 +1031,7 @@
+@@ -1052,7 +1059,7 @@
# referenced using URIs in format "proxy:<name>".
dict {
@@ -169,21 +175,40 @@
}
##
-@@ -1045,7 +1055,7 @@
- # directory. You can also optionally give a global ACL directory path where
- # ACLs are applied to all users' mailboxes. The global ACL directory contains
- # one file for each mailbox, eg. INBOX or sub.mailbox.
-- #acl = vfile:/etc/dovecot-acls
-+ #acl = vfile:%%PREFIX%%/etc/dovecot-acls
+@@ -1090,8 +1097,8 @@
+ # Each quota root has separate limits. Only the command for the first
+ # exceeded limit is excecuted, so put the highest limit first.
+ # Note that % needs to be escaped as %%, otherwise "% " expands to empty.
+- # quota_warning = storage=95%% /usr/local/bin/quota-warning.sh 95
+- # quota_warning2 = storage=80%% /usr/local/bin/quota-warning.sh 80
++ # quota_warning = storage=95%% %%PREFIX%%/bin/quota-warning.sh 95
++ # quota_warning2 = storage=80%% %%PREFIX%%/bin/quota-warning.sh 80
+ #quota = maildir
+
+ # ACL plugin. vfile backend reads ACLs from "dovecot-acl" file from maildir
+@@ -1100,7 +1107,7 @@
+ # one file for each mailbox, eg. INBOX or sub.mailbox. cache_secs parameter
+ # specifies how many seconds to wait between stat()ing dovecot-acl file
+ # to see if it changed.
+- #acl = vfile:/etc/dovecot-acls:cache_secs=300
++ #acl = vfile:%%PREFIX%%/etc/dovecot-acls:cache_secs=300
# Convert plugin. If set, specifies the source storage path which is
# converted to destination storage (mail_location) when the user logs in.
-@@ -1059,7 +1069,7 @@
+@@ -1119,14 +1126,14 @@
# until the message can be saved within quota limits. The configuration file
# is a text file where each line is in format: <priority> <mailbox name>
# Mails are first deleted in lowest -> highest priority number order
- #trash = /etc/dovecot-trash.conf
+ #trash = %%PREFIX%%/etc/dovecot-trash.conf
- # Lazy expunge plugin. Currently works only with maildirs. When a user
- # expunges mails, the mails are moved to a mailbox in another namespace
+ # Expire plugin. Mails are expunged from mailboxes after being there the
+ # configurable time. The first expiration date for each mailbox is stored in
+ # a dictionary so it can be quickly determined which mailboxes contain
+ # expired mails. The actual expunging is done in a nightly cronjob, which
+ # you must set up:
+- # dovecot --exec-mail ext /usr/libexec/dovecot/expire-tool
++ # dovecot --exec-mail ext %%PREFIX%%/libexec/dovecot/expire-tool
+ #expire = Trash 7 Spam 30
+ #expire_dict = db:/var/lib/dovecot/expire.db
+
diff --git a/mail/dovecot-devel/pkg-plist b/mail/dovecot-devel/pkg-plist
index 849943c7f720..ca4ada8531eb 100644
--- a/mail/dovecot-devel/pkg-plist
+++ b/mail/dovecot-devel/pkg-plist
@@ -5,6 +5,7 @@ etc/dovecot-example.conf
%%PORTDOCS%%etc/dovecot-ldap-example.conf
%%PORTDOCS%%etc/dovecot-sql-example.conf
@dirrmtry include/dovecot
+@dirrm lib/dovecot/auth
lib/dovecot/imap/lib01_acl_plugin.so
lib/dovecot/imap/lib02_lazy_expunge_plugin.so
lib/dovecot/imap/lib10_quota_plugin.so
@@ -13,21 +14,30 @@ lib/dovecot/imap/lib11_imap_quota_plugin.la
lib/dovecot/imap/lib11_imap_quota_plugin.so
lib/dovecot/imap/lib11_trash_plugin.so
lib/dovecot/imap/lib20_convert_plugin.so
+lib/dovecot/imap/lib20_fts_plugin.so
+lib/dovecot/imap/lib20_expire_plugin.so
lib/dovecot/imap/lib20_mail_log_plugin.so
+lib/dovecot/imap/lib20_mbox_snarf_plugin.so
lib/dovecot/imap/lib20_zlib_plugin.a
lib/dovecot/imap/lib20_zlib_plugin.la
lib/dovecot/imap/lib20_zlib_plugin.so
+lib/dovecot/imap/lib21_fts_squat_plugin.so
@dirrm lib/dovecot/imap
lib/dovecot/lda/lib01_acl_plugin.so
lib/dovecot/lda/lib10_quota_plugin.so
lib/dovecot/lda/lib11_trash_plugin.so
lib/dovecot/lda/lib20_convert_plugin.so
+lib/dovecot/lda/lib20_expire_plugin.so
+lib/dovecot/lda/lib20_fts_plugin.so
lib/dovecot/lda/lib20_mail_log_plugin.so
+lib/dovecot/lda/lib21_fts_squat_plugin.so
@dirrm lib/dovecot/lda
lib/dovecot/pop3/lib02_lazy_expunge_plugin.so
lib/dovecot/pop3/lib10_quota_plugin.so
lib/dovecot/pop3/lib20_convert_plugin.so
+lib/dovecot/pop3/lib20_expire_plugin.so
lib/dovecot/pop3/lib20_mail_log_plugin.so
+lib/dovecot/pop3/lib20_mbox_snarf_plugin.so
@dirrm lib/dovecot/pop3
lib/dovecot/lib01_acl_plugin.a
lib/dovecot/lib01_acl_plugin.la
@@ -44,18 +54,33 @@ lib/dovecot/lib11_trash_plugin.so
lib/dovecot/lib20_convert_plugin.a
lib/dovecot/lib20_convert_plugin.la
lib/dovecot/lib20_convert_plugin.so
+lib/dovecot/lib20_expire_plugin.a
+lib/dovecot/lib20_expire_plugin.so
+lib/dovecot/lib20_expire_plugin.la
+lib/dovecot/lib20_fts_plugin.a
+lib/dovecot/lib20_fts_plugin.so
+lib/dovecot/lib20_fts_plugin.la
lib/dovecot/lib20_mail_log_plugin.a
lib/dovecot/lib20_mail_log_plugin.la
lib/dovecot/lib20_mail_log_plugin.so
+lib/dovecot/lib20_mbox_snarf_plugin.a
+lib/dovecot/lib20_mbox_snarf_plugin.la
+lib/dovecot/lib20_mbox_snarf_plugin.so
+lib/dovecot/lib21_fts_squat_plugin.a
+lib/dovecot/lib21_fts_squat_plugin.so
+lib/dovecot/lib21_fts_squat_plugin.la
@dirrm lib/dovecot
libexec/dovecot/checkpassword-reply
%%LDA%%libexec/dovecot/deliver
+libexec/dovecot/convert-tool
libexec/dovecot/dict
libexec/dovecot/dovecot-auth
+libexec/dovecot/expire-tool
libexec/dovecot/gdbhelper
libexec/dovecot/idxview
libexec/dovecot/imap
libexec/dovecot/imap-login
+libexec/dovecot/listview
libexec/dovecot/logview
%%POP3%%libexec/dovecot/pop3
%%POP3%%libexec/dovecot/pop3-login