aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/polyml/Makefile2
-rw-r--r--lang/polyml/distinfo6
-rw-r--r--lang/polyml/files/patch-libpolyml-sighandler.cpp20
3 files changed, 4 insertions, 24 deletions
diff --git a/lang/polyml/Makefile b/lang/polyml/Makefile
index 68d110136c8e..816e877fcc80 100644
--- a/lang/polyml/Makefile
+++ b/lang/polyml/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= polyml
-PORTVERSION= 5.2
+PORTVERSION= 5.2.1
CATEGORIES= lang
MASTER_SITES= SF
DISTNAME= ${PORTNAME}.${PORTVERSION}
diff --git a/lang/polyml/distinfo b/lang/polyml/distinfo
index 1fec9db9ca45..c6da0ef9dca1 100644
--- a/lang/polyml/distinfo
+++ b/lang/polyml/distinfo
@@ -1,3 +1,3 @@
-MD5 (polyml/polyml.5.2.tar.gz) = 5c0a291990f6dbce6baed857068cda06
-SHA256 (polyml/polyml.5.2.tar.gz) = bffdbe469406a746929965474fdcfff6cea1aa72e189fef1f97bfa32f862546f
-SIZE (polyml/polyml.5.2.tar.gz) = 4116253
+MD5 (polyml/polyml.5.2.1.tar.gz) = 303ba7d26c262999685ddd54b36dd16b
+SHA256 (polyml/polyml.5.2.1.tar.gz) = c84148ae9a28e782f48208bcb8c5b82ee7bfdc178784fe81694cf1f0789ae62e
+SIZE (polyml/polyml.5.2.1.tar.gz) = 4114551
diff --git a/lang/polyml/files/patch-libpolyml-sighandler.cpp b/lang/polyml/files/patch-libpolyml-sighandler.cpp
deleted file mode 100644
index 93b330966666..000000000000
--- a/lang/polyml/files/patch-libpolyml-sighandler.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- libpolyml/sighandler.cpp.orig 2008-02-28 00:20:51.000000000 +1100
-+++ libpolyml/sighandler.cpp 2008-07-27 21:26:41.000000000 +1000
-@@ -357,7 +357,7 @@
- struct sigaltstack ex_stack;
- #endif
- memset(&ex_stack, 0, sizeof(ex_stack));
-- ex_stack.ss_sp = taskData->signalStack;
-+ ex_stack.ss_sp = (char *)taskData->signalStack;
- ex_stack.ss_size = SIGSTKSZ;
- ex_stack.ss_flags = 0; /* not SS_DISABLE */
- int sigaltstack_result = sigaltstack(&ex_stack, NULL);
-@@ -526,7 +526,7 @@
- pthread_attr_init(&attrs);
- pthread_attr_setdetachstate(&attrs, PTHREAD_CREATE_DETACHED);
- #ifdef PTHREAD_STACK_MIN
-- pthread_attr_setstacksize(&attrs, PTHREAD_STACK_MIN); // Only small stack.
-+ pthread_attr_setstacksize(&attrs, PTHREAD_STACK_MIN + 100); // Only small stack.
- #endif
- pthread_create(&detectionThreadId, &attrs, SignalDetectionThread, 0);
- pthread_attr_destroy(&attrs);