aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/madedit/Makefile2
-rw-r--r--editors/madedit/files/patch-src__MadEditFrame.cpp11
2 files changed, 12 insertions, 1 deletions
diff --git a/editors/madedit/Makefile b/editors/madedit/Makefile
index e0a28ab87ab7..10a7f6f85088 100644
--- a/editors/madedit/Makefile
+++ b/editors/madedit/Makefile
@@ -7,7 +7,7 @@
PORTNAME= madedit
PORTVERSION= 0.2.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors
MASTER_SITES= SF
diff --git a/editors/madedit/files/patch-src__MadEditFrame.cpp b/editors/madedit/files/patch-src__MadEditFrame.cpp
new file mode 100644
index 000000000000..93948d87f5aa
--- /dev/null
+++ b/editors/madedit/files/patch-src__MadEditFrame.cpp
@@ -0,0 +1,11 @@
+--- ./src/MadEditFrame.cpp.orig 2007-10-08 02:37:26.000000000 -0700
++++ ./src/MadEditFrame.cpp 2009-02-12 17:39:21.810385103 -0800
+@@ -2158,7 +2158,7 @@
+ #ifndef __WXMSW__
+ // it will crash randomly under linux.
+ // so we must call exit() to quit the app.
+- exit(0);
++ _Exit(0);
+ #else
+ extern HANDLE g_Mutex;
+ if(g_Mutex)