aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/libassuan/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/security/libassuan/Makefile b/security/libassuan/Makefile
index 24952f390234..eb144eeba20f 100644
--- a/security/libassuan/Makefile
+++ b/security/libassuan/Makefile
@@ -10,8 +10,10 @@ PORTVERSION= 1.0.5
CATEGORIES= security devel
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR=${PORTNAME}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dougb@FreeBSD.org
COMMENT= IPC library used by GnuPG and gpgme
LIB_DEPENDS+= pth.20:${PORTSDIR}/devel/pth
@@ -28,4 +30,7 @@ CFLAGS+= -I${LOCALBASE}/include/pth
CFLAGS+= -fPIC
.endif
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.sig
+
.include <bsd.port.post.mk>