aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--misc/Makefile1
-rw-r--r--misc/mtail/Makefile37
-rw-r--r--misc/mtail/distinfo3
-rw-r--r--misc/mtail/pkg-descr16
4 files changed, 57 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 9d5634445d0f..d56f3d2c6653 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -322,6 +322,7 @@
SUBDIR += misterproper
SUBDIR += mmv
SUBDIR += mshell
+ SUBDIR += mtail
SUBDIR += mtx
SUBDIR += nagios-base-logos
SUBDIR += najitool
diff --git a/misc/mtail/Makefile b/misc/mtail/Makefile
new file mode 100644
index 000000000000..b11a8f45cc87
--- /dev/null
+++ b/misc/mtail/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mtail
+# Date created: 9 August 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mtail
+PORTVERSION= 1.1.1
+CATEGORIES= misc
+MASTER_SITES= http://matt.immute.net/src/mtail/ CENKES
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Small tail workalike that performs output coloring
+
+NO_BUILD= yes
+USE_PYTHON_RUN= yes
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= CHANGES LICENSE README
+PORTEXAMPLES= mtailrc
+
+post-patch:
+ @${REINPLACE_CMD} -e '1s|/.*|${PYTHON_CMD}|' ${WRKSRC}/${PORTNAME}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+.endif
+.ifndef NOPORTEXAMPLES
+ @${INSTALL} -d ${EXAMPLESDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/mtailrc.sample ${EXAMPLESDIR}/mtailrc
+.endif
+
+.include <bsd.port.mk>
diff --git a/misc/mtail/distinfo b/misc/mtail/distinfo
new file mode 100644
index 000000000000..500bdd5d9f89
--- /dev/null
+++ b/misc/mtail/distinfo
@@ -0,0 +1,3 @@
+MD5 (mtail-1.1.1.tgz) = 166ccd3bfea04fdc81940b256d7d6f18
+SHA256 (mtail-1.1.1.tgz) = 1c82feb4ced3dc861497d4adc27a4d62d7002112bcfa24d1655348dda79bf3ab
+SIZE (mtail-1.1.1.tgz) = 9124
diff --git a/misc/mtail/pkg-descr b/misc/mtail/pkg-descr
new file mode 100644
index 000000000000..90855c6f2db7
--- /dev/null
+++ b/misc/mtail/pkg-descr
@@ -0,0 +1,16 @@
+mtail is a small tail workalike that performs output coloring using ansi
+escape sequences (although the sequences are overridable, so you could cause
+it to output something else, e.g. html font tags, if you really wanted to).
+mtail is written in python, is fairly small, and should be relatively
+platform-independent.
+
+It has a config file that can contain an arbitrary number of entries, each
+of which has a series of regular expressions to indicate which files to color
+according to which entry. for each entry, the config file specifies a coloring
+scheme using regular expressions and, optionally, filters to apply to each
+line before coloring (for example, to strip out extra info, etc.). the config
+file also may override the predefined colors and the escape sequences (or
+whatever) actually used to perform the coloring.
+
+WWW: http://matt.immute.net/src/mtail/
+Author: Matt Hellige <matt@immute.net>