aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/crafty-open-large/Makefile2
-rw-r--r--math/coq/Makefile2
-rw-r--r--net/p5-AddressBook/Makefile3
-rw-r--r--shells/scponly/Makefile2
-rw-r--r--www/p5-HTML-Summary/Makefile3
5 files changed, 7 insertions, 5 deletions
diff --git a/games/crafty-open-large/Makefile b/games/crafty-open-large/Makefile
index fa73d854a207..63b708251077 100644
--- a/games/crafty-open-large/Makefile
+++ b/games/crafty-open-large/Makefile
@@ -13,7 +13,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= The large opening book for crafty
BUILD_DEPENDS= crafty:${PORTSDIR}/games/crafty
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= crafty:${PORTSDIR}/games/crafty
DIST_SUBDIR= crafty
USES= zip
diff --git a/math/coq/Makefile b/math/coq/Makefile
index 87f8f8c8b886..cf6a36a15413 100644
--- a/math/coq/Makefile
+++ b/math/coq/Makefile
@@ -32,7 +32,7 @@ OPTIONS_DEFAULT= DOCS IDE
OPTIONS_SUB= yes
IDE_DESC= Include desktop environment (coqide)
IDE_BUILD_DEPENDS= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
-IDE_RUN_DEPENDS= ${IDE_BUILD_DEPENDS
+IDE_RUN_DEPENDS:= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
IDE_CONFIGURE_OFF= --coqide no
DOCS_USE= TEX=latex:build,dvipsk:build
DOCS_BUILD_DEPENDS= hevea:${PORTSDIR}/textproc/hevea \
diff --git a/net/p5-AddressBook/Makefile b/net/p5-AddressBook/Makefile
index e4a46cbd3355..f11192654493 100644
--- a/net/p5-AddressBook/Makefile
+++ b/net/p5-AddressBook/Makefile
@@ -14,7 +14,8 @@ COMMENT= Perl5 module providing an LDAP addressbook interface
BUILD_DEPENDS= p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
p5-XML-DOM>=0:${PORTSDIR}/textproc/p5-XML-DOM
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
+ p5-XML-DOM>=0:${PORTSDIR}/textproc/p5-XML-DOM
USES= perl5
USE_PERL5= configure
diff --git a/shells/scponly/Makefile b/shells/scponly/Makefile
index c976656a1712..bb1f6e0bb091 100644
--- a/shells/scponly/Makefile
+++ b/shells/scponly/Makefile
@@ -49,7 +49,7 @@ UNISON_BUILD_DEPENDS= unison:${PORTSDIR}/net/unison
UNISON_CONFIGURE_ENABLE= unison-compat
WINSCP_CONFIGURE_ENABLE= winscp-compat
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS:= ${BUILD_DEPENDS}
post-patch:
@${ECHO_MSG} "In addition to knobs available from the OPTIONS dialog,"
diff --git a/www/p5-HTML-Summary/Makefile b/www/p5-HTML-Summary/Makefile
index f7b1ad5c5290..7ee51c9adf33 100644
--- a/www/p5-HTML-Summary/Makefile
+++ b/www/p5-HTML-Summary/Makefile
@@ -12,7 +12,8 @@ COMMENT= Produces summaries from the textual content of web pages
BUILD_DEPENDS= p5-HTML-Tree>=0:${PORTSDIR}/www/p5-HTML-Tree \
ja-p5-Jcode>=2.06:${PORTSDIR}/japanese/p5-Jcode
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-HTML-Tree>=0:${PORTSDIR}/www/p5-HTML-Tree \
+ ja-p5-Jcode>=2.06:${PORTSDIR}/japanese/p5-Jcode
USES= perl5
USE_PERL5= configure