aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-thrift/Makefile26
-rw-r--r--devel/ruby-thrift/pkg-descr3
-rw-r--r--devel/ruby-thrift/pkg-plist10
-rw-r--r--devel/rubygem-thrift/Makefile26
-rw-r--r--devel/rubygem-thrift/pkg-descr3
-rw-r--r--devel/rubygem-thrift/pkg-plist10
7 files changed, 79 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c062c7e84ff6..78aeee0c1add 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2117,6 +2117,7 @@
SUBDIR += ruby-sysvipc
SUBDIR += ruby-term-ansicolor
SUBDIR += ruby-textbuf
+ SUBDIR += ruby-thrift
SUBDIR += ruby-tzfile
SUBDIR += ruby-wirble
SUBDIR += ruby-zoom
diff --git a/devel/ruby-thrift/Makefile b/devel/ruby-thrift/Makefile
new file mode 100644
index 000000000000..f8454968e045
--- /dev/null
+++ b/devel/ruby-thrift/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: thrift
+# Date created: 27 September 2007
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= thrift
+PORTVERSION= 20070917
+CATEGORIES= devel
+PKGNAMEPREFIX= ruby-
+DISTFILES=
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Ruby interface to thrift
+
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/thrift:extract
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+
+post-extract:
+ @${LN} -sfh \
+ `cd ${PORTSDIR}/devel/thrift && ${MAKE} -V WRKSRC`/lib/rb ${WRKSRC}
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-thrift/pkg-descr b/devel/ruby-thrift/pkg-descr
new file mode 100644
index 000000000000..634be3a51ada
--- /dev/null
+++ b/devel/ruby-thrift/pkg-descr
@@ -0,0 +1,3 @@
+Ruby interface to Thrift.
+
+WWW: http://developers.facebook.com/thrift/
diff --git a/devel/ruby-thrift/pkg-plist b/devel/ruby-thrift/pkg-plist
new file mode 100644
index 000000000000..17eb6129084a
--- /dev/null
+++ b/devel/ruby-thrift/pkg-plist
@@ -0,0 +1,10 @@
+%%RUBY_SITELIBDIR%%/thrift/thrift.rb
+%%RUBY_SITELIBDIR%%/thrift/protocol/tbinaryprotocol.rb
+%%RUBY_SITELIBDIR%%/thrift/protocol/tprotocol.rb
+%%RUBY_SITELIBDIR%%/thrift/server/tserver.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/tsocket.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/ttransport.rb
+@dirrm %%RUBY_SITELIBDIR%%/thrift/transport
+@dirrm %%RUBY_SITELIBDIR%%/thrift/server
+@dirrm %%RUBY_SITELIBDIR%%/thrift/protocol
+@dirrm %%RUBY_SITELIBDIR%%/thrift
diff --git a/devel/rubygem-thrift/Makefile b/devel/rubygem-thrift/Makefile
new file mode 100644
index 000000000000..f8454968e045
--- /dev/null
+++ b/devel/rubygem-thrift/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: thrift
+# Date created: 27 September 2007
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= thrift
+PORTVERSION= 20070917
+CATEGORIES= devel
+PKGNAMEPREFIX= ruby-
+DISTFILES=
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Ruby interface to thrift
+
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/thrift:extract
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+
+post-extract:
+ @${LN} -sfh \
+ `cd ${PORTSDIR}/devel/thrift && ${MAKE} -V WRKSRC`/lib/rb ${WRKSRC}
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-thrift/pkg-descr b/devel/rubygem-thrift/pkg-descr
new file mode 100644
index 000000000000..634be3a51ada
--- /dev/null
+++ b/devel/rubygem-thrift/pkg-descr
@@ -0,0 +1,3 @@
+Ruby interface to Thrift.
+
+WWW: http://developers.facebook.com/thrift/
diff --git a/devel/rubygem-thrift/pkg-plist b/devel/rubygem-thrift/pkg-plist
new file mode 100644
index 000000000000..17eb6129084a
--- /dev/null
+++ b/devel/rubygem-thrift/pkg-plist
@@ -0,0 +1,10 @@
+%%RUBY_SITELIBDIR%%/thrift/thrift.rb
+%%RUBY_SITELIBDIR%%/thrift/protocol/tbinaryprotocol.rb
+%%RUBY_SITELIBDIR%%/thrift/protocol/tprotocol.rb
+%%RUBY_SITELIBDIR%%/thrift/server/tserver.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/tsocket.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/ttransport.rb
+@dirrm %%RUBY_SITELIBDIR%%/thrift/transport
+@dirrm %%RUBY_SITELIBDIR%%/thrift/server
+@dirrm %%RUBY_SITELIBDIR%%/thrift/protocol
+@dirrm %%RUBY_SITELIBDIR%%/thrift