aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.qt.mk5
-rw-r--r--devel/Makefile1
-rw-r--r--devel/qt4-qmlviewer/Makefile54
-rw-r--r--devel/qt4-qmlviewer/pkg-descr12
-rw-r--r--devel/qt4-qmlviewer/pkg-plist2
5 files changed, 73 insertions, 1 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index 63566e8344cd..f1cfc0e09e60 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -155,7 +155,7 @@ _USE_QT4_ALL= accessible assistant assistant-adp assistantclient \
iconengines imageformats inputmethods \
linguist l10n makeqpf moc multimedia network opengl \
pixeltool porting phonon phonon-gst \
- qdbusviewer qdoc3 qmake qt3support qtconfig qtestlib \
+ qdbusviewer qmlviewer qdoc3 qmake qt3support qtconfig qtestlib \
qvfb rcc script scripttools sql sql-ibase sql-mysql \
sql-odbc sql-pgsql sql-sqlite2 sql-sqlite3 svg uic uic3 \
webkit xml xmlpatterns xmlpatterns-tool
@@ -270,6 +270,9 @@ porting_DEPENDS= ${QT_PREFIX}/bin/qt3to4
qdbusviewer_PORT= devel/qt4-qdbusviewer
qdbusviewer_DEPENDS= ${QT_PREFIX}/bin/qdbusviewer
+qmlviewer_PORT= devel/qt4-qmlviewer
+qmlviewer_DEPENDS= ${QT_PREFIX}/bin/qmlviewer
+
qdoc3_PORT= devel/qt4-qdoc3
qdoc3_DEPENDS= ${QT_PREFIX}/bin/qdoc3
diff --git a/devel/Makefile b/devel/Makefile
index 7bddfc872bf3..c33896804f69 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3581,6 +3581,7 @@
SUBDIR += qt4-moc
SUBDIR += qt4-porting
SUBDIR += qt4-qdbusviewer
+ SUBDIR += qt4-qmlviewer
SUBDIR += qt4-qdoc3
SUBDIR += qt4-qt3support
SUBDIR += qt4-qtestlib
diff --git a/devel/qt4-qmlviewer/Makefile b/devel/qt4-qmlviewer/Makefile
new file mode 100644
index 000000000000..9a623cd1d787
--- /dev/null
+++ b/devel/qt4-qmlviewer/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: qt4-qmlviewer
+# Date created: 13 June 2012
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= qmlviewer
+DISTVERSION= ${QT4_VERSION}
+CATEGORIES?= devel
+PKGNAMEPREFIX= qt4-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt4 QML viewer
+
+USE_QT4= qmake_build moc_build rcc_build uic_build declarative script \
+ svg xmlpatterns sql opengl network corelib
+QT_NONSTANDARD= yes
+QT_DIST= yes
+MAKE_JOBS_SAFE= yes
+
+HAS_CONFIGURE= yes
+
+ALL_TARGET= first
+CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib:$$LD_LIBRARY_PATH \
+ PATH=${WRKSRC}/bin:$$PATH
+
+DO_NOT_EXTRACT= demos doc examples mkspecs qmake translations \
+ src/activeqt src/multimedia src/openvg \
+ src/phonon src/qt3support src/s60installs src/s60main \
+ src/scripttools src/sql src/svg src/testlib \
+ src/winmain src/xmlpatterns src/3rdparty/clucene \
+ src/3rdparty/freetype src/3rdparty/libjpeg src/3rdparty/libmng \
+ src/3rdparty/libpng src/3rdparty/libtiff src/3rdparty/phonon \
+ src/3rdparty/webkit
+EXTRACT_AFTER_ARGS= | ${TAR} -xf -
+.for dne in ${DO_NOT_EXTRACT}
+EXTRACT_AFTER_ARGS+= --exclude '${DISTNAME}/${dne}'
+.endfor
+
+BUILD_WRKSRC= ${WRKSRC}/tools/qml/
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
+
+post-patch:
+ ${MKDIR} ${WRKSRC}/mkspecs
+ ${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
+ ${LN} -sf ${LOCALBASE}/bin/moc-qt4 ${WRKSRC}/bin/moc
+ ${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/bin/rcc
+ ${LN} -sf ${LOCALBASE}/bin/uic-qt4 ${WRKSRC}/bin/uic
+
+.include <bsd.port.mk>
diff --git a/devel/qt4-qmlviewer/pkg-descr b/devel/qt4-qmlviewer/pkg-descr
new file mode 100644
index 000000000000..36bc69717e98
--- /dev/null
+++ b/devel/qt4-qmlviewer/pkg-descr
@@ -0,0 +1,12 @@
+Qt is a C++ toolkit for application development. It lets application
+developers target all major operating systems with a single application
+source code.
+
+Qt provides a platform-independent API to all central platform functionality:
+GUI, database access, networking, file handling, etc. The Qt library
+encapsulates the different APIs of different operating systems, providing
+the application programmer with a single, common API for all operating systems.
+The native C APIs are encapsulated in a set of well-designed, fully
+object-oriented C++ classes.
+
+WWW: http://qt.nokia.com/products/qt/index.html
diff --git a/devel/qt4-qmlviewer/pkg-plist b/devel/qt4-qmlviewer/pkg-plist
new file mode 100644
index 000000000000..5febc4501427
--- /dev/null
+++ b/devel/qt4-qmlviewer/pkg-plist
@@ -0,0 +1,2 @@
+bin/qmlviewer
+%%DEBUG%%bin/qmlviewer.debug