aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/mcollective-shell-client/Makefile37
-rw-r--r--sysutils/mcollective-shell-client/distinfo2
-rw-r--r--sysutils/mcollective-shell-client/pkg-descr9
4 files changed, 49 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index dbd8666fe0c8..f1395b751dfe 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -505,6 +505,7 @@
SUBDIR += mcollective-nrpe-agent
SUBDIR += mcollective-puppet-agent
SUBDIR += mcollective-shell-agent
+ SUBDIR += mcollective-shell-client
SUBDIR += mcron
SUBDIR += mcweject
SUBDIR += mdcp
diff --git a/sysutils/mcollective-shell-client/Makefile b/sysutils/mcollective-shell-client/Makefile
new file mode 100644
index 000000000000..c795d50957e6
--- /dev/null
+++ b/sysutils/mcollective-shell-client/Makefile
@@ -0,0 +1,37 @@
+# Created by: Bartek Rutkowski <robak@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mcollective-shell-client
+PORTVERSION= 0.0.1
+CATEGORIES= sysutils
+DISTNAME= mcollective-shell-agent-${PORTVERSION}
+
+MAINTAINER= robak@FreeBSD.org
+COMMENT= MCollective shell client plugin
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= mcollective>=2.2.4:${PORTSDIR}/sysutils/mcollective
+
+WRKSRC= ${WRKDIR}/${GH_ACCOUNT}-mcollective-shell-agent-${GH_COMMIT}
+
+USE_GITHUB= yes
+GH_ACCOUNT= puppetlabs
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 9fb27d5
+
+PLIST_FILES= share/mcollective/application/shell/watcher.rb \
+ share/mcollective/application/shell/prefix_stream_buf.rb \
+ share/mcollective/application/shell.rb
+PLIST_DIRSTRY= share/mcollective/application/shell
+
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${PLIST_DIRSTRY}
+ ${INSTALL_DATA} ${WRKSRC}/lib/mcollective/application/shell/watcher.rb ${STAGEDIR}${PREFIX}/share/mcollective/application/shell/
+ ${INSTALL_DATA} ${WRKSRC}/lib/mcollective/application/shell/prefix_stream_buf.rb ${STAGEDIR}${PREFIX}/share/mcollective/application/shell/
+ ${INSTALL_DATA} ${WRKSRC}/lib/mcollective/application/shell.rb ${STAGEDIR}${PREFIX}/share/mcollective/application/
+
+.include <bsd.port.mk>
diff --git a/sysutils/mcollective-shell-client/distinfo b/sysutils/mcollective-shell-client/distinfo
new file mode 100644
index 000000000000..f00b7e79917e
--- /dev/null
+++ b/sysutils/mcollective-shell-client/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mcollective-shell-agent-0.0.1.tar.gz) = c3e899ecf21508587091828f9e18ed232ca615f9f8a899d524f0b96340738d74
+SIZE (mcollective-shell-agent-0.0.1.tar.gz) = 17900
diff --git a/sysutils/mcollective-shell-client/pkg-descr b/sysutils/mcollective-shell-client/pkg-descr
new file mode 100644
index 000000000000..1f74a3645d90
--- /dev/null
+++ b/sysutils/mcollective-shell-client/pkg-descr
@@ -0,0 +1,9 @@
+The shell client allows you to get commands executed via MCollective's
+mcollective-shell-agent plugin.
+
+It allows the running of long-running processes with a mechanism to check in
+on the output from these long-running processes, which is independent of the
+mcollective daemon process (the daemon can be restarted without interrupting
+the processes)
+
+WWW: https://github.com/puppetlabs/mcollective-shell-agent