aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/kbilliards/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/games/kbilliards/Makefile b/games/kbilliards/Makefile
index 118b5d909d96..b769dfbaeb0d 100644
--- a/games/kbilliards/Makefile
+++ b/games/kbilliards/Makefile
@@ -12,22 +12,20 @@ MASTER_SITES= http://www.hostnotfound.it/kbilliards/
MAINTAINER= ports@FreeBSD.org
COMMENT= Funny billiards simulator game for KDE
+EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
+
USE_BZIP2= yes
USE_REINPLACE= yes
USE_KDELIBS_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
-EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
+CFLAGS+= -Dsqrtl=sqrt
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 501000
-BROKEN= "does not compile"
+.if ${OSVERSION} < 502114
+CFLAGS+= -Dround=rint
.endif
-
-post-patch:
- ${REINPLACE_CMD} -e 's|sqrtl|sqrt|' \
- ${WRKSRC}/src/ball.cpp ${WRKSRC}/src/aiplayer.cpp
.include <bsd.port.post.mk>