aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/ruby18/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index c7dc77799572..e9ce8e6029bc 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -39,7 +39,8 @@ USE_REINPLACE= yes
GNU_CONFIGURE= yes
WRKSRC= ${RUBY_WRKSRC}
CONFIGURE_ARGS= ${RUBY_CONFIGURE_ARGS} \
- --enable-shared --enable-pthread
+ --enable-shared --enable-pthread \
+ --with-openssl-include=${OPENSSLBASE}/include
.if defined(DEBUG)
CFLAGS+= -g
@@ -51,10 +52,6 @@ MAN1= ${RUBY_NAME}.1
.include <bsd.port.pre.mk>
-.if !defined(WITH_OPENSSL_BASE)
-CONFIGURE_ARGS+=--with-openssl-include=${LOCALBASE}/include
-.endif
-
.if ${OSVERSION} < 502102
EXTRA_PATCHES= ${PATCHDIR}/extrapatch-eval.c
.endif