aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/flink/Makefile37
-rw-r--r--mail/flink/distinfo1
-rw-r--r--mail/flink/files/patch-src_imaplib.c12
-rw-r--r--mail/flink/files/patch-src_main.c10
-rw-r--r--mail/flink/files/patch-src_poplib.c12
-rw-r--r--mail/flink/pkg-comment1
-rw-r--r--mail/flink/pkg-descr12
-rw-r--r--mail/flink/pkg-plist19
9 files changed, 105 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 66f201a1d2a8..98fa2b0123d6 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -56,6 +56,7 @@
SUBDIR += ezmlm-web
SUBDIR += faces
SUBDIR += fetchmail
+ SUBDIR += flink
SUBDIR += ftrack
SUBDIR += gbiff
SUBDIR += gbuffy
diff --git a/mail/flink/Makefile b/mail/flink/Makefile
new file mode 100644
index 000000000000..54ad707ae051
--- /dev/null
+++ b/mail/flink/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: flink
+# Date created: 27 Aug 2002
+# Whom: Juan Salaverria <rael@vectorstar.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flink
+PORTVERSION= 0.3.2
+CATEGORIES= mail gnome
+MASTER_SITES= http://flink.leyman.nu/
+
+MAINTAINER= rael@vectorstar.net
+
+GNU_CONFIGURE= yes
+USE_X_PREFIX= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack libpanel
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+MAN1= flink.1
+
+DOCS= AUTHORS COPYING INSTALL NEWS README ChangeLog
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ;' ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/flink/distinfo b/mail/flink/distinfo
new file mode 100644
index 000000000000..b45ec9a79ab5
--- /dev/null
+++ b/mail/flink/distinfo
@@ -0,0 +1 @@
+MD5 (flink-0.3.2.tar.gz) = 735a4a1565c62c750a63ad2eb30ef533
diff --git a/mail/flink/files/patch-src_imaplib.c b/mail/flink/files/patch-src_imaplib.c
new file mode 100644
index 000000000000..2ed1c0515338
--- /dev/null
+++ b/mail/flink/files/patch-src_imaplib.c
@@ -0,0 +1,12 @@
+--- src/imaplib.c.ori Tue Aug 27 00:48:15 2002
++++ src/imaplib.c Tue Aug 27 00:48:26 2002
+@@ -15,8 +15,8 @@
+ *
+ **************************************************************************/
+
+-#include <sys/socket.h>
+ #include <sys/types.h>
++#include <sys/socket.h>
+ #include <string.h>
+ #include <unistd.h>
+ #include <netdb.h>
diff --git a/mail/flink/files/patch-src_main.c b/mail/flink/files/patch-src_main.c
new file mode 100644
index 000000000000..eaebf3f62cf8
--- /dev/null
+++ b/mail/flink/files/patch-src_main.c
@@ -0,0 +1,10 @@
+--- src/main.c.ori Tue Aug 27 00:40:53 2002
++++ src/main.c Tue Aug 27 00:41:04 2002
+@@ -26,6 +26,7 @@
+ #include <stdio.h>
+ #include <netdb.h>
+ #include <unistd.h>
++#include <sys/time.h>
+ #include <sys/resource.h>
+ #include <sys/types.h>
+ #include <pthread.h>
diff --git a/mail/flink/files/patch-src_poplib.c b/mail/flink/files/patch-src_poplib.c
new file mode 100644
index 000000000000..d9e8a9071c0d
--- /dev/null
+++ b/mail/flink/files/patch-src_poplib.c
@@ -0,0 +1,12 @@
+--- src/poplib.c.ori Tue Aug 27 00:46:06 2002
++++ src/poplib.c Tue Aug 27 00:46:17 2002
+@@ -20,8 +20,8 @@
+ *
+ ***************************************************************************/
+
+-#include <sys/socket.h>
+ #include <sys/types.h>
++#include <sys/socket.h>
+ #include <string.h>
+ #include <unistd.h>
+ #include <netdb.h>
diff --git a/mail/flink/pkg-comment b/mail/flink/pkg-comment
new file mode 100644
index 000000000000..86d1ef69b2ed
--- /dev/null
+++ b/mail/flink/pkg-comment
@@ -0,0 +1 @@
+The Flink mailchecker is a small panelapplet for the GNOME panel
diff --git a/mail/flink/pkg-descr b/mail/flink/pkg-descr
new file mode 100644
index 000000000000..332aca021e3b
--- /dev/null
+++ b/mail/flink/pkg-descr
@@ -0,0 +1,12 @@
+The Flink mailchecker is a small panelapplet that supports multiple
+accounts, so that you will not need to have several applets for
+checking different accounts, Flink is capable to have (almost) an
+infinite amount of accounts configured.
+Flink supports POP3, IMAPv4 and mbox right now. Support for other
+types of mailaccounts will be added in time, or if you bug me
+enough about it.
+Flink is released under the GPL license.
+
+WWW: http://flink.leyman.nu/
+
+marcus@leyman.nu
diff --git a/mail/flink/pkg-plist b/mail/flink/pkg-plist
new file mode 100644
index 000000000000..ef18770ee3b5
--- /dev/null
+++ b/mail/flink/pkg-plist
@@ -0,0 +1,19 @@
+bin/flink
+etc/CORBA/servers/flink.gnorba
+%%PORTDOCS%%share/doc/flink/README
+%%PORTDOCS%%share/doc/flink/NEWS
+%%PORTDOCS%%share/doc/flink/INSTALL
+%%PORTDOCS%%share/doc/flink/ChangeLog
+%%PORTDOCS%%share/doc/flink/COPYING
+%%PORTDOCS%%share/doc/flink/AUTHORS
+share/gnome/applets/Network/flink.desktop
+share/gnome/pixmaps/flink/mail_yes2.xpm
+share/gnome/pixmaps/flink/mail_yes.xpm
+share/gnome/pixmaps/flink/mail_no2.xpm
+share/gnome/pixmaps/flink/mail_no.xpm
+share/gnome/pixmaps/flink/logo_big.xpm
+share/gnome/pixmaps/flink/logo64.xpm
+share/gnome/pixmaps/flink/flink.xpm
+share/gnome/pixmaps/flink/flink.png
+share/locale/sv/LC_MESSAGES/flink.mo
+%%PORTDOCS%%@dirrm share/doc/flink