aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/fusefs-encfs/Makefile34
-rw-r--r--sysutils/fusefs-encfs/distinfo3
-rw-r--r--sysutils/fusefs-encfs/pkg-descr7
-rw-r--r--sysutils/fusefs-encfs/pkg-plist47
5 files changed, 92 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index bdd784296796..2a1ee00f2f42 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -207,6 +207,7 @@
SUBDIR += fsbackup
SUBDIR += ftrace
SUBDIR += fusefs-curlftpfs
+ SUBDIR += fusefs-encfs
SUBDIR += fusefs-funionfs
SUBDIR += fusefs-gnome-vfs
SUBDIR += fusefs-httpfs
diff --git a/sysutils/fusefs-encfs/Makefile b/sysutils/fusefs-encfs/Makefile
new file mode 100644
index 000000000000..0273878d2cb3
--- /dev/null
+++ b/sysutils/fusefs-encfs/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: fusefs-encfs
+# Date created: 2007-01-05
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= encfs
+PORTVERSION= 1.3.1
+CATEGORIES= sysutils
+MASTER_SITES= http://arg0.net/users/vgough/download/
+PKGNAMEPREFIX= fusefs-
+DISTNAME= encfs-${PORTVERSION}-1
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= An encrypted pass-through FUSE filesystem
+
+LIB_DEPENDS= rlog:${PORTSDIR}/devel/rlog
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+BUILD_DEPENDS= ${LOCALBASE}/include/fuse.h:${PORTSDIR}/sysutils/fusefs-libs
+
+WRKSRC= ${WRKDIR}/encfs-${PORTVERSION}
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS=-L${LOCALBASE}/lib
+CFLAGS+= -pthread
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_LDCONFIG= yes
+
+MAN1= encfs.1 encfsctl.1
+
+.include <bsd.port.mk>
diff --git a/sysutils/fusefs-encfs/distinfo b/sysutils/fusefs-encfs/distinfo
new file mode 100644
index 000000000000..6a81a4d72df3
--- /dev/null
+++ b/sysutils/fusefs-encfs/distinfo
@@ -0,0 +1,3 @@
+MD5 (encfs-1.3.1-1.tgz) = c93d6a22aa858db4eb3803170a82274a
+SHA256 (encfs-1.3.1-1.tgz) = d9070c859c64a697573353c03bfe99c2910e05aa6d660f5a6cd9ca645f486369
+SIZE (encfs-1.3.1-1.tgz) = 702028
diff --git a/sysutils/fusefs-encfs/pkg-descr b/sysutils/fusefs-encfs/pkg-descr
new file mode 100644
index 000000000000..e0cfe61db235
--- /dev/null
+++ b/sysutils/fusefs-encfs/pkg-descr
@@ -0,0 +1,7 @@
+EncFS is an encrypted pass-through filesystem which runs in userspace,
+using the FUSE kernel module. Similar in design to CFS and other
+pass-through filesystems, all data is encrypted and stored in the
+underlying filesystem. Unlike loopback filesystems, there is no
+predetermined or pre-allocated filesystem size.
+
+WWW: http://freshmeat.net/projects/encfs/
diff --git a/sysutils/fusefs-encfs/pkg-plist b/sysutils/fusefs-encfs/pkg-plist
new file mode 100644
index 000000000000..7f81a55b8c03
--- /dev/null
+++ b/sysutils/fusefs-encfs/pkg-plist
@@ -0,0 +1,47 @@
+bin/encfs
+bin/encfsctl
+bin/encfssh
+lib/libencfs.so.2
+lib/libencfs.so
+lib/libencfs.la
+share/locale/bg/LC_MESSAGES/encfs.mo
+share/locale/da/LC_MESSAGES/encfs.mo
+share/locale/de/LC_MESSAGES/encfs.mo
+share/locale/es/LC_MESSAGES/encfs.mo
+share/locale/es_ES/LC_MESSAGES/encfs.mo
+share/locale/fr/LC_MESSAGES/encfs.mo
+share/locale/he/LC_MESSAGES/encfs.mo
+share/locale/hr/LC_MESSAGES/encfs.mo
+share/locale/hu/LC_MESSAGES/encfs.mo
+share/locale/id/LC_MESSAGES/encfs.mo
+share/locale/it/LC_MESSAGES/encfs.mo
+share/locale/ja/LC_MESSAGES/encfs.mo
+share/locale/nb/LC_MESSAGES/encfs.mo
+share/locale/nl/LC_MESSAGES/encfs.mo
+share/locale/pt_BR/LC_MESSAGES/encfs.mo
+share/locale/pt_PT/LC_MESSAGES/encfs.mo
+share/locale/ru/LC_MESSAGES/encfs.mo
+share/locale/sv/LC_MESSAGES/encfs.mo
+share/locale/tr/LC_MESSAGES/encfs.mo
+share/locale/ca/LC_MESSAGES/encfs.mo
+share/locale/cs/LC_MESSAGES/encfs.mo
+share/locale/de_CH/LC_MESSAGES/encfs.mo
+share/locale/de_DE/LC_MESSAGES/encfs.mo
+share/locale/fi/LC_MESSAGES/encfs.mo
+share/locale/fr_FR/LC_MESSAGES/encfs.mo
+share/locale/hu_HU/LC_MESSAGES/encfs.mo
+share/locale/ko/LC_MESSAGES/encfs.mo
+share/locale/pl/LC_MESSAGES/encfs.mo
+share/locale/pt/LC_MESSAGES/encfs.mo
+share/locale/ro/LC_MESSAGES/encfs.mo
+share/locale/te/LC_MESSAGES/encfs.mo
+@dirrmtry share/locale/hu_HU/LC_MESSAGES
+@dirrmtry share/locale/hu_HU
+@dirrmtry share/locale/de_CH/LC_MESSAGES
+@dirrmtry share/locale/de_CH
+@dirrmtry share/locale/de_DE/LC_MESSAGES
+@dirrmtry share/locale/de_DE
+@dirrmtry share/locale/fr_FR/LC_MESSAGES
+@dirrmtry share/locale/fr_FR
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te