aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/libexecinfo/Makefile1
-rw-r--r--devel/libexecinfo/files/patch-execinfo.h22
2 files changed, 23 insertions, 0 deletions
diff --git a/devel/libexecinfo/Makefile b/devel/libexecinfo/Makefile
index 6b2b2df0b281..92496dace646 100644
--- a/devel/libexecinfo/Makefile
+++ b/devel/libexecinfo/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libexecinfo
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= https://demo.portaone.com/~sobomax/freestuff/
diff --git a/devel/libexecinfo/files/patch-execinfo.h b/devel/libexecinfo/files/patch-execinfo.h
new file mode 100644
index 000000000000..8ac54b9c108d
--- /dev/null
+++ b/devel/libexecinfo/files/patch-execinfo.h
@@ -0,0 +1,22 @@
+
+$FreeBSD$
+
+--- execinfo.h 2003/08/10 05:43:54 1.1
++++ execinfo.h 2003/08/10 05:44:11
+@@ -29,8 +29,16 @@
+ #ifndef _EXECINFO_H_
+ #define _EXECINFO_H_
+
++#ifdef __cplusplus
++extern "C" {
++#endif
++
+ int backtrace(void **, int);
+ char ** backtrace_symbols(void *const *, int);
+ void backtrace_symbols_fd(void *const *, int, int);
++
++#ifdef __cplusplus
++}
++#endif
+
+ #endif /* _EXECINFO_H_ */