aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/bsnmp-regex/Makefile26
-rw-r--r--net-mgmt/bsnmp-regex/distinfo3
-rw-r--r--net-mgmt/bsnmp-regex/pkg-descr4
4 files changed, 34 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index f4bcb771204e..49ea245f7bcd 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -28,6 +28,7 @@
SUBDIR += bpft
SUBDIR += braa
SUBDIR += bsd-airtools
+ SUBDIR += bsnmp-regex
SUBDIR += bsnmpd
SUBDIR += bsnmptools
SUBDIR += bwm-ng
diff --git a/net-mgmt/bsnmp-regex/Makefile b/net-mgmt/bsnmp-regex/Makefile
new file mode 100644
index 000000000000..d6e7bbc16de6
--- /dev/null
+++ b/net-mgmt/bsnmp-regex/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: bsnmp-regex
+# Date created: 11 February 2007
+# Whom: brock@cotcomsol.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= bsnmp-regex
+PORTVERSION= 0.1
+CATEGORIES= net-mgmt
+MASTER_SITES= http://memberwebs.com/nielsen/software/bsnmp-regex/
+
+MAINTAINER= brock@cotcomsol.com
+COMMENT= A bsnmpd module allowing creation of counters from log files
+
+HAS_CONFIGURE= yes
+
+MAN1= sockin.1
+MAN5= bsnmp-regex.conf.5
+MAN8= bsnmp-regex.8
+
+PLIST_FILES= bin/sockin \
+ lib/snmp_regex.so \
+ lib/snmp_regex.so.0
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/bsnmp-regex/distinfo b/net-mgmt/bsnmp-regex/distinfo
new file mode 100644
index 000000000000..d032ac7362b1
--- /dev/null
+++ b/net-mgmt/bsnmp-regex/distinfo
@@ -0,0 +1,3 @@
+MD5 (bsnmp-regex-0.1.tar.gz) = bddf0925a97beb3334c34bba0e783e08
+SHA256 (bsnmp-regex-0.1.tar.gz) = 09e2931c2f92333ee225086b1cf82dd8db2094c64d654d4d923bbbb9bd26603e
+SIZE (bsnmp-regex-0.1.tar.gz) = 318916
diff --git a/net-mgmt/bsnmp-regex/pkg-descr b/net-mgmt/bsnmp-regex/pkg-descr
new file mode 100644
index 000000000000..b6dd3d0993a7
--- /dev/null
+++ b/net-mgmt/bsnmp-regex/pkg-descr
@@ -0,0 +1,4 @@
+bsnmp-regex is a module for bsnmpd which allows creation of counters from log
+files, program output or other text data. The counters use regular expressions
+to count the number of matches, or parse out specific text/numbers. The
+resulting data can then be queried or graphed with the usual SNMP tools.