aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/libexif/Makefile1
-rw-r--r--graphics/libexif/files/patch-libexif-exif-data.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/graphics/libexif/Makefile b/graphics/libexif/Makefile
index a35a560a6f2f..38f8e3b10dd2 100644
--- a/graphics/libexif/Makefile
+++ b/graphics/libexif/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libexif
PORTVERSION= 0.6.12
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/graphics/libexif/files/patch-libexif-exif-data.c b/graphics/libexif/files/patch-libexif-exif-data.c
new file mode 100644
index 000000000000..e8471c262f10
--- /dev/null
+++ b/graphics/libexif/files/patch-libexif-exif-data.c
@@ -0,0 +1,11 @@
+--- libexif/exif-data.c.orig Sun Mar 13 03:27:13 2005
++++ libexif/exif-data.c Wed Apr 13 22:42:35 2005
+@@ -231,7 +231,7 @@
+ * the offset must be an even number. If we need to introduce
+ * a padding byte, we set it to 0.
+ */
+- if (s & 1) *ds++;
++ if (s & 1) (*ds)++;
+ *d = exif_mem_realloc (data->priv->mem, *d, *ds);
+ if (!*d) {
+ EXIF_LOG_NO_MEMORY (data->priv->log, "ExifData", *ds);