aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/php52-dba/Makefile14
-rw-r--r--databases/php52-dba/files/patch-config.m446
-rw-r--r--databases/php52-dbase/Makefile14
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/php52-exif/Makefile14
-rw-r--r--security/Makefile1
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/php52-dom/Makefile14
9 files changed, 106 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index ec0cddd15dbd..87a760c234c8 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -519,6 +519,7 @@
SUBDIR += php5-sqlite
SUBDIR += php5-sybase_ct
SUBDIR += php52-dba
+ SUBDIR += php52-dbase
SUBDIR += phpminiadmin
SUBDIR += phpmyadmin
SUBDIR += phpmyadmin211
diff --git a/databases/php52-dba/Makefile b/databases/php52-dba/Makefile
new file mode 100644
index 000000000000..b1f4d34be451
--- /dev/null
+++ b/databases/php52-dba/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-dba
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -dba
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/php52-dba/files/patch-config.m4 b/databases/php52-dba/files/patch-config.m4
new file mode 100644
index 000000000000..02761b927e42
--- /dev/null
+++ b/databases/php52-dba/files/patch-config.m4
@@ -0,0 +1,46 @@
+--- config.m4.orig 2007-12-06 15:17:43.000000000 +0100
++++ config.m4 2008-12-11 12:50:27.000000000 +0100
+@@ -280,6 +280,34 @@
+ THIS_PREFIX=$i
+ THIS_INCLUDE=$i/db4/db.h
+ break
++ elif test -f "$i/include/db47/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db47/db.h
++ break
++ elif test -f "$i/include/db46/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db46/db.h
++ break
++ elif test -f "$i/include/db45/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db45/db.h
++ break
++ elif test -f "$i/include/db44/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db44/db.h
++ break
++ elif test -f "$i/include/db43/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db43/db.h
++ break
++ elif test -f "$i/include/db42/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db42/db.h
++ break
++ elif test -f "$i/include/db41/db.h"; then
++ THIS_PREFIX=$i
++ THIS_INCLUDE=$i/include/db41/db.h
++ break
+ elif test -f "$i/include/db4.6/db.h"; then
+ THIS_PREFIX=$i
+ THIS_INCLUDE=$i/include/db4.6/db.h
+@@ -306,7 +334,7 @@
+ break
+ fi
+ done
+- PHP_DBA_DB_CHECK(4, db-4.6 db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)])
++ PHP_DBA_DB_CHECK(4, db-4.7 db-4.6 db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)])
+ fi
+ PHP_DBA_STD_RESULT(db4,Berkeley DB4)
+
diff --git a/databases/php52-dbase/Makefile b/databases/php52-dbase/Makefile
new file mode 100644
index 000000000000..f08cf3086bf9
--- /dev/null
+++ b/databases/php52-dbase/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-dbase
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= databases
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -dbase
+
+.include "${MASTERDIR}/Makefile"
diff --git a/graphics/Makefile b/graphics/Makefile
index d04ac235dfcd..42d9c3a5c5b4 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -688,6 +688,7 @@
SUBDIR += php5-exif
SUBDIR += php5-ffmpeg
SUBDIR += php5-gd
+ SUBDIR += php52-exif
SUBDIR += phplot
SUBDIR += phpsview
SUBDIR += picpuz
diff --git a/graphics/php52-exif/Makefile b/graphics/php52-exif/Makefile
new file mode 100644
index 000000000000..12cdaffb4052
--- /dev/null
+++ b/graphics/php52-exif/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-exif
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= graphics
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -exif
+
+.include "${MASTERDIR}/Makefile"
diff --git a/security/Makefile b/security/Makefile
index bd083445d2d8..eea17b753e84 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -629,6 +629,7 @@
SUBDIR += php5-hash
SUBDIR += php5-mcrypt
SUBDIR += php5-openssl
+ SUBDIR += php52-filter
SUBDIR += phpdeadlock
SUBDIR += phpmyid
SUBDIR += phpsecinfo
diff --git a/textproc/Makefile b/textproc/Makefile
index cc8e0573a43b..67097076324d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -935,6 +935,7 @@
SUBDIR += php5-xmlwriter
SUBDIR += php5-xsl
SUBDIR += php52-ctype
+ SUBDIR += php52-dom
SUBDIR += po4a
SUBDIR += pocketreader
SUBDIR += pootle
diff --git a/textproc/php52-dom/Makefile b/textproc/php52-dom/Makefile
new file mode 100644
index 000000000000..7eff1248ba29
--- /dev/null
+++ b/textproc/php52-dom/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-dom
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= textproc
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -dom
+
+.include "${MASTERDIR}/Makefile"