aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/netmond/Makefile2
-rw-r--r--net-mgmt/netmond/pkg-install2
2 files changed, 2 insertions, 2 deletions
diff --git a/net-mgmt/netmond/Makefile b/net-mgmt/netmond/Makefile
index 9a39fa1bdb45..60c30ef7dc56 100644
--- a/net-mgmt/netmond/Makefile
+++ b/net-mgmt/netmond/Makefile
@@ -43,7 +43,7 @@ do-install:
@if pw user show netmon 2>/dev/null ; then \
${ECHO} "User 'netmon' exists." ; \
else \
- pw useradd -n netmon -g wheel -c 'Network monitor account' -m ; \
+ pw useradd -n netmon -g wheel -c 'Network monitor account' -s /usr/sbin/nologin ; \
fi
@if pw group show ${BINGRP} 2>/dev/null ; then \
${ECHO} "Group '${BINGRP}' exists." ; \
diff --git a/net-mgmt/netmond/pkg-install b/net-mgmt/netmond/pkg-install
index 4c1773744c6f..007ffc6401b0 100644
--- a/net-mgmt/netmond/pkg-install
+++ b/net-mgmt/netmond/pkg-install
@@ -8,7 +8,7 @@ case $2 in
if pw user show netmon 2>/dev/null ; then
echo "User 'netmon' exists." ;
else
- pw useradd -n netmon -g wheel -c 'Network monitor account' -m ;
+ pw useradd -n netmon -g wheel -c 'Network monitor account' -s /usr/sbin/nologin ;
fi
if pw group show netmon 2>/dev/null ; then
echo "Group 'netmon' exists." ;