aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/swig13/Makefile8
-rw-r--r--devel/swig20/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/devel/swig13/Makefile b/devel/swig13/Makefile
index 1616ccc37dcb..97de191cb106 100644
--- a/devel/swig13/Makefile
+++ b/devel/swig13/Makefile
@@ -103,10 +103,16 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} -fpic -DPIC"
ALL_TARGET= swig runtime
PLIST_SUB+= VER="${VER}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= "Does not install"
+.endif
+
post-install:
# A separate swig13-runtime port might be nice
@(cd ${INSTALL_WRKSRC}/Runtime && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
${LN} -f ${PREFIX}/bin/swig ${PREFIX}/bin/swig${VER}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/swig20/Makefile b/devel/swig20/Makefile
index 1616ccc37dcb..97de191cb106 100644
--- a/devel/swig20/Makefile
+++ b/devel/swig20/Makefile
@@ -103,10 +103,16 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} -fpic -DPIC"
ALL_TARGET= swig runtime
PLIST_SUB+= VER="${VER}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= "Does not install"
+.endif
+
post-install:
# A separate swig13-runtime port might be nice
@(cd ${INSTALL_WRKSRC}/Runtime && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
${LN} -f ${PREFIX}/bin/swig ${PREFIX}/bin/swig${VER}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>