aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/glasteroids/Makefile8
-rw-r--r--games/glasteroids/files/patch-ac4
2 files changed, 3 insertions, 9 deletions
diff --git a/games/glasteroids/Makefile b/games/glasteroids/Makefile
index 87efb65cd33b..c0dae1f4edb9 100644
--- a/games/glasteroids/Makefile
+++ b/games/glasteroids/Makefile
@@ -25,12 +25,6 @@ MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
MAKEFILE= ${FILESDIR}/Makefile.FreeBSD
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-BROKEN= "Does not compile on amd64"
-.endif
-
do-install:
${INSTALL_PROGRAM} -m 2755 -o root -g games ${WRKSRC}/Glasteroids ${PREFIX}/bin/glasteroids
@${MKDIR} ${DATADIR}
@@ -45,4 +39,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/glasteroids/files/patch-ac b/games/glasteroids/files/patch-ac
index 00643ffc1f38..528ea4331054 100644
--- a/games/glasteroids/files/patch-ac
+++ b/games/glasteroids/files/patch-ac
@@ -3,7 +3,7 @@
@@ -1,5 +1,8 @@
#include <stdlib.h>
#include <time.h>
-+#if defined(__FreeBSD__) && (defined(__i386__) || defined(__amd64__))
++#if defined(__FreeBSD__) && defined(__i386__)
+#include <floatingpoint.h>
+#endif
#include "Bobcat.h"
@@ -13,7 +13,7 @@
{
BCworld *world;
-+#if defined(__FreeBSD__) && (defined(__i386__) || defined(__amd64__))
++#if defined(__FreeBSD__) && defined(__i386__)
+ fpsetmask(0);
+#endif
world = BCgetWorld ( );