aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/msyslog/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/sysutils/msyslog/Makefile b/sysutils/msyslog/Makefile
index be15f7840ad5..4766fa2aadd6 100644
--- a/sysutils/msyslog/Makefile
+++ b/sysutils/msyslog/Makefile
@@ -7,7 +7,7 @@
PORTNAME= msyslog
PORTVERSION= 1.08f
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= http://www.corest.com/download/msyslog/ \
ftp://ftp.nuug.no/pub/anders/distfiles/
@@ -65,6 +65,12 @@ pre-patch:
${WRKSRC}/${f}
.endfor
+post-patch:
+.for f in README src/syslogd.c src/man/im_file.8 src/man/im_streams.8 \
+ src/man/im_unix.8 src/man/syslogd.8 src/modules/im_streams.c src/modules/im_unix.c
+ ${REINPLACE_CMD} -e "s|/dev/log|/var/run/log|" ${WRKSRC}/${f}
+.endfor
+
post-install:
${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/share/examples/msyslog
${INSTALL_DATA} ${WRKSRC}/src/examples/* \