aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-DateTime-Calendar-Pataphysical/Makefile25
-rw-r--r--devel/p5-DateTime-Calendar-Pataphysical/distinfo1
-rw-r--r--devel/p5-DateTime-Calendar-Pataphysical/pkg-descr6
-rw-r--r--devel/p5-DateTime-Calendar-Pataphysical/pkg-plist7
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e8297f1cac26..523c0de9e57b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -548,6 +548,7 @@
SUBDIR += p5-DateTime-Calendar-Christian
SUBDIR += p5-DateTime-Calendar-Julian
SUBDIR += p5-DateTime-Calendar-Mayan
+ SUBDIR += p5-DateTime-Calendar-Pataphysical
SUBDIR += p5-DateTime-Event-Cron
SUBDIR += p5-DateTime-Event-Easter
SUBDIR += p5-DateTime-Event-ICal
diff --git a/devel/p5-DateTime-Calendar-Pataphysical/Makefile b/devel/p5-DateTime-Calendar-Pataphysical/Makefile
new file mode 100644
index 000000000000..4e8a900f200d
--- /dev/null
+++ b/devel/p5-DateTime-Calendar-Pataphysical/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-DateTime-Calendar-Pataphysical
+# Date created: 1 july 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DateTime-Calendar-Pataphysical
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DateTime
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Dates in the pataphysical calendar
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DateTime::Calendar::Pataphysical.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-DateTime-Calendar-Pataphysical/distinfo b/devel/p5-DateTime-Calendar-Pataphysical/distinfo
new file mode 100644
index 000000000000..c6a15b81ca54
--- /dev/null
+++ b/devel/p5-DateTime-Calendar-Pataphysical/distinfo
@@ -0,0 +1 @@
+MD5 (DateTime-Calendar-Pataphysical-0.02.tar.gz) = 07cfb7e4a2252d59c3510cf5c26ce550
diff --git a/devel/p5-DateTime-Calendar-Pataphysical/pkg-descr b/devel/p5-DateTime-Calendar-Pataphysical/pkg-descr
new file mode 100644
index 000000000000..1cf278f8d5f1
--- /dev/null
+++ b/devel/p5-DateTime-Calendar-Pataphysical/pkg-descr
@@ -0,0 +1,6 @@
+DateTime::Calendar::Pataphysical is the implementation of the pataphysical
+calendar. Each year in this calendar contains 13 months of 29 days. This
+regularity makes this a convenient alternative for the irregular Gregorian
+calendar.
+
+WWW: http://datetime.perl.org/
diff --git a/devel/p5-DateTime-Calendar-Pataphysical/pkg-plist b/devel/p5-DateTime-Calendar-Pataphysical/pkg-plist
new file mode 100644
index 000000000000..4e1e43233513
--- /dev/null
+++ b/devel/p5-DateTime-Calendar-Pataphysical/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/DateTime/Calendar/Pataphysical.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Calendar/Pataphysical/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Calendar/Pataphysical
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime/Calendar 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DateTime 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime/Calendar 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/DateTime 2>/dev/null || true