aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/demonquake/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/games/demonquake/Makefile b/games/demonquake/Makefile
index 88fe490f6337..9b5334243040 100644
--- a/games/demonquake/Makefile
+++ b/games/demonquake/Makefile
@@ -58,6 +58,10 @@ MAKE_ENV+= BUILD_DEMONQUAKE_SDL=YES
PLIST_FILES+= bin/${PORTNAME}-sdl
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
+ ${WRKSRC}/gl_image.c
+
do-install:
.if !defined(WITHOUT_GLX)
${INSTALL_PROGRAM} ${WRKSRC}/quake/${PORTNAME}-glx ${PREFIX}/bin