aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/jna/Makefile32
1 files changed, 16 insertions, 16 deletions
diff --git a/devel/jna/Makefile b/devel/jna/Makefile
index 8498a7315e13..ec2b37b2cb24 100644
--- a/devel/jna/Makefile
+++ b/devel/jna/Makefile
@@ -7,16 +7,23 @@ CATEGORIES= devel java
MAINTAINER= ports@FreeBSD.org
COMMENT= Java access to native shared libraries
+LICENSE= LGPL21+ APACHE20
+LICENSE_COMB= dual
+LICENSE_FOLE= ${WRKSRC}/LICENSE
+LICENSE_FILE_LGPL21+ = ${WRKSRC}/LGPL2.1
+LICENSE_FILE_APACHE20= ${WRKSRC}/ASL2.0
+
USES= gmake
USE_ANT= yes
USE_JAVA= yes
USE_XORG= x11 xt
MAKE_ARGS= -DCC="${CC}" -DLD="${LD}"
-MAKE_ENV+= ANT_OPTS=-Drelease -DARCH=${ANT_ARCH}
+MAKE_ENV= ANT_OPTS=-Drelease -DARCH=${ANT_ARCH}
USE_GITHUB= yes
GH_ACCOUNT= twall
+PORTDOCS= javadoc platform-${PORTVERSION}-javadoc.jar
PLIST_FILES= %%JAVAJARDIR%%/jna-platform.jar \
%%JAVAJARDIR%%/jna.jar
@@ -24,10 +31,6 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCS= javadoc platform-${PORTVERSION}-javadoc.jar
-.endif
-
.if ${ARCH} == "i386"
ANT_ARCH= x86
.elif ${ARCH} == "amd64"
@@ -36,24 +39,21 @@ ANT_ARCH= x86-64
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
- ${WRKSRC}/native/Makefile
+ ${WRKSRC}/native/Makefile
-post-build-script:
-.if ${PORT_OPTIONS:MDOCS}
+post-build-DOCS-on:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${ANT} javadoc
-.endif
do-install:
${INSTALL_DATA} ${WRKSRC}/build/freebsd-${ANT_ARCH}.jar \
- ${STAGEDIR}${JAVAJARDIR}/jna-platform.jar
+ ${STAGEDIR}${JAVAJARDIR}/jna-platform.jar
${INSTALL_DATA} ${WRKSRC}/build/jna.jar \
- ${STAGEDIR}${JAVAJARDIR}/jna.jar
-.if ${PORT_OPTIONS:MDOCS}
+ ${STAGEDIR}${JAVAJARDIR}/jna.jar
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC}/doc && \
- ${COPYTREE_SHARE} javadoc ${STAGEDIR}${DOCSDIR}
+ @cd ${WRKSRC}/doc && ${COPYTREE_SHARE} javadoc ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/dist/platform-${PORTVERSION}-javadoc.jar \
- ${STAGEDIR}${DOCSDIR}
-.endif
+ ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
1521af3f9017adf36c5bc72b886bb3d06853'>Mark job unsafe and convert to USES=gmakebapt2013-07-101-6/+4 * Fix INDEX by really fixing the kde4-l10n portsbapt2013-07-101-0/+1 * KDE4 l10n fixes.rakuco2013-07-102-3/+1 * Update the KDE Software Compilation to 4.10.5.rakuco2013-07-051-2/+2 * Update to KDE SC 4.10.4, proudly presented by the KDE on FreeBSD team.rakuco2013-07-031-2/+2 * Update to 4.0.4.jkim2013-06-201-4/+4 * - Don't remove directories not created by this portmiwi2013-06-191-2/+0 * KDE/FreeBSD team presents KDE SC 4.10.3 ports!makc2013-05-192-4/+2 * Update to 4.0.3.jkim2013-05-101-4/+4 * Add some shebangfix to allow building most of the ports tree without /usr/bin...bapt2013-05-071-5/+2 * - Convert USE_GETTEXT to USES (part 2)ak2013-04-241-1/+1 * Update to 4.0.2.jkim2013-04-171-4/+4 * - Update Calligra and l10n ports to 2.6.2:avilla2013-03-302-5/+8 * KDE/FreeBSD team presents KDE SC 4.10.1 ports!makc2013-03-274-43/+97 * Update to 4.0.1.jkim2013-03-091-4/+4 * Merge from area51 repository:makc2013-02-052-3/+3 * Update to 3.6.5.jkim2013-02-051-4/+4 * KDE/FreeBSD team presents KDE SC 4.9.5 ports!makc2013-02-044-32/+147 * - Deprecate QT3, KDE3 and unmaintained ports depending on them. QT 3.3.8beat2012-12-301-0/+3 * - Update to 3.5.7.jkim2012-10-272-9/+4 * - Update Calligra Suite to 2.5.2.avilla2012-09-171-2/+2 * - Update Calligra to 2.5.1.avilla2012-09-012-7/+2 * The KDE/FreeBSD team is pleased to announce version 2.5 of Calligra,avilla2012-08-262-15/+3 * - Update to 3.5.6.jkim2012-08-241-4/+4 * - Update LibreOffice and the language packs to 3.5.5.jkim2012-07-181-4/+4 * - Update Calligra to 2.4.3.avilla2012-07-051-2/+2 * - The FreeBSD Office team is proud to announce LibreOffice.org 3.5.4 releasefluffy2012-07-011-4/+4 * KDE/FreeBSD team presents KDE SC 4.8.4, probably the last release in 4.8.x se...makc2012-06-153-3/+33 * - update png to 1.5.10dinoex2012-06-012-1/+2 * - Remove koffice-i18n ports, as they are not very useful withoutavilla2012-05-315-64/+0 * The KDE/FreeBSD team is pleased to announce Calligra Suite 2.4.2, KDEavilla2012-05-319-238/+129 * KDE/FreeBSD team presents long awaited KDE SC 4.8.3!makc2012-05-254-20/+263 * - upgrade to 3.5.2bapt2012-04-23