aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--german/dict/Makefile5
-rw-r--r--german/dict/files/patch-Makefile11
2 files changed, 5 insertions, 11 deletions
diff --git a/german/dict/Makefile b/german/dict/Makefile
index a9eb081ec07b..1e5d248e2bef 100644
--- a/german/dict/Makefile
+++ b/german/dict/Makefile
@@ -15,6 +15,7 @@ LICENSE= BSD2CLAUSE
RUN_DEPENDS= agrep:${PORTSDIR}/textproc/agrep
+NO_BUILD= yes
PLIST_FILES= bin/de-dict share/ger-eng.txt
dict= ger-eng.txt
@@ -23,4 +24,8 @@ post-extract: ${dict}
${dict}:
${GZCAT} < ${DISTDIR}/${dict}.gz > ${WRKSRC}/${.TARGET}
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/dict.sh ${STAGEDIR}${PREFIX}/bin/de-dict
+ ${INSTALL_DATA} ${WRKSRC}/ger-eng.txt ${STAGEDIR}${PREFIX}/share
+
.include <bsd.port.mk>
diff --git a/german/dict/files/patch-Makefile b/german/dict/files/patch-Makefile
deleted file mode 100644
index 1a4f45b44c64..000000000000
--- a/german/dict/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.old Sat Mar 9 12:20:02 2002
-+++ Makefile Sat Mar 9 12:19:37 2002
-@@ -9,7 +9,7 @@
-
- beforeinstall:
- ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
-- ${.CURDIR}/dict.sh ${DESTDIR}${BINDIR}/dict
-+ ${.CURDIR}/dict.sh ${DESTDIR}${BINDIR}/de-dict
- ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m ${NOBINMODE} \
- ${.CURDIR}/${dict} ${DESTDIR}${PREFIX}/share
-