aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--astro/foxtrotgps/Makefile2
-rw-r--r--astro/foxtrotgps/files/patch-src-main21
2 files changed, 22 insertions, 1 deletions
diff --git a/astro/foxtrotgps/Makefile b/astro/foxtrotgps/Makefile
index c922b6fa291c..c00203024e44 100644
--- a/astro/foxtrotgps/Makefile
+++ b/astro/foxtrotgps/Makefile
@@ -3,7 +3,7 @@
PORTNAME= foxtrotgps
PORTVERSION= 1.1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= astro geography
MASTER_SITES= http://www.foxtrotgps.org/releases/
diff --git a/astro/foxtrotgps/files/patch-src-main b/astro/foxtrotgps/files/patch-src-main
new file mode 100644
index 000000000000..5e0ad825bf8e
--- /dev/null
+++ b/astro/foxtrotgps/files/patch-src-main
@@ -0,0 +1,21 @@
+=== modified file 'src/main.c'
+--- src/main.c 2013-01-06 01:48:33 +0000
++++ src/main.c 2013-06-12 04:48:57 +0000
+@@ -77,7 +77,7 @@
+ if (!g_thread_supported ())
+ g_thread_init (NULL);
+ gdk_threads_init ();
+-
++ gdk_threads_enter ();
+ gtk_init (&argc, &argv);
+
+ setlocale (LC_NUMERIC, "C");
+@@ -203,7 +203,7 @@
+
+ gtk_main ();
+
+-
++ gdk_threads_leave ();
+
+ return 0;
+ }