aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-GMPf/Makefile27
-rw-r--r--math/p5-Math-GMPf/distinfo2
-rw-r--r--math/p5-Math-GMPf/pkg-descr5
-rw-r--r--math/p5-Math-GMPf/pkg-plist16
5 files changed, 51 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index a9b19d6817bf..2170b33f1ff1 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -391,6 +391,7 @@
SUBDIR += p5-Math-FFT
SUBDIR += p5-Math-FixedPrecision
SUBDIR += p5-Math-GMP
+ SUBDIR += p5-Math-GMPf
SUBDIR += p5-Math-GSL
SUBDIR += p5-Math-Geometry
SUBDIR += p5-Math-Geometry-Planar
diff --git a/math/p5-Math-GMPf/Makefile b/math/p5-Math-GMPf/Makefile
new file mode 100644
index 000000000000..092e381f2b09
--- /dev/null
+++ b/math/p5-Math-GMPf/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Math-GMPf
+# Date created: 2011-11-30
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-GMPf
+PORTVERSION= 0.35
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:SISYPHUS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Perl interface to the GMP library floating point (mpf) functions
+
+LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp
+TEST_DEPENDS= p5-Math-GMP>=0:${PORTSDIR}/math/p5-Math-GMP \
+ p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
+
+CONFIGURE_ARGS= INC=-I${LOCALBASE}/include LIBS="-L${LOCALBASE}/lib -lgmp"
+PERL_CONFIGURE= yes
+
+MAN3= Math::GMPf.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-GMPf/distinfo b/math/p5-Math-GMPf/distinfo
new file mode 100644
index 000000000000..c93577767707
--- /dev/null
+++ b/math/p5-Math-GMPf/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Math-GMPf-0.35.tar.gz) = ea4765bb6bc5aab22bf02b81b2d5d6c753c10be4acc52564fce07988bbed1bd6
+SIZE (Math-GMPf-0.35.tar.gz) = 37573
diff --git a/math/p5-Math-GMPf/pkg-descr b/math/p5-Math-GMPf/pkg-descr
new file mode 100644
index 000000000000..81f93bdef1c4
--- /dev/null
+++ b/math/p5-Math-GMPf/pkg-descr
@@ -0,0 +1,5 @@
+Math::GMPf is a bigfloat module utilising the GNU MP (GMP) library. Basically
+this module simply wraps all of the mpf floating point functions provided by
+that library. See the Math::GMPf test suite for some examples of usage.
+
+WWW: http://search.cpan.org/dist/Math-GMPf/
diff --git a/math/p5-Math-GMPf/pkg-plist b/math/p5-Math-GMPf/pkg-plist
new file mode 100644
index 000000000000..c866fb9fa4bb
--- /dev/null
+++ b/math/p5-Math-GMPf/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/GMPf.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/GMPf/Random.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/GMPf/V.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf/GMPf.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf/GMPf.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf/Random/Random.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf/Random/Random.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf/V/V.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf/V/V.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf/V
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf/Random
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Math/GMPf
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math