aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/doom/Makefile4
-rw-r--r--graphics/ivtools/Makefile3
-rw-r--r--graphics/libvisual-plugins/Makefile2
-rw-r--r--mail/xfce4-mailwatch-plugin/Makefile3
-rw-r--r--math/goblin/Makefile2
-rw-r--r--misc/goblin/Makefile2
-rw-r--r--net-im/xfce4-messenger-plugin/Makefile3
-rw-r--r--www/xfce4-smartbookmark-plugin/Makefile3
-rw-r--r--x11/slock/Makefile3
9 files changed, 15 insertions, 10 deletions
diff --git a/games/doom/Makefile b/games/doom/Makefile
index b5706e100ffa..040a92fa259c 100644
--- a/games/doom/Makefile
+++ b/games/doom/Makefile
@@ -7,7 +7,7 @@
PORTNAME= doom
PORTVERSION= 1.10
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SF/source
DISTNAME= doomsrc
@@ -21,7 +21,7 @@ ONLY_FOR_ARCHS= i386
USE_GMAKE= yes
USE_ZIP= yes
-USE_XORG= x11
+USE_XORG= x11 sm xextproto xext
NO_WRKSUBDIR= yes
DATADIR= ${DMDIR}
diff --git a/graphics/ivtools/Makefile b/graphics/ivtools/Makefile
index 34de1688b9e8..083db260df50 100644
--- a/graphics/ivtools/Makefile
+++ b/graphics/ivtools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ivtools
PORTVERSION= 1.2.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= SF
EXTRACT_SUFX= .tgz
@@ -24,6 +24,7 @@ CONFIGURE_ARGS= --with-tiff=${PREFIX}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
USE_LDCONFIG= yes
MAKE_ARGS= ARCH=FREEBSD
+USE_XORG= x11 xaw ice xext
MANCOMPRESSED= no
MAN1= idraw.1 iclass.1 drawtool.1 comterp.1 comdraw.1 flipbook.1 graphdraw.1
diff --git a/graphics/libvisual-plugins/Makefile b/graphics/libvisual-plugins/Makefile
index 1649aa098ebb..4a521512702f 100644
--- a/graphics/libvisual-plugins/Makefile
+++ b/graphics/libvisual-plugins/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= visual.0:${PORTSDIR}/graphics/libvisual
WANT_GNOME= yes
USE_GNOME= gnometarget pkgconfig
-USE_GL= gl
+USE_GL= glu
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-alsa
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/mail/xfce4-mailwatch-plugin/Makefile b/mail/xfce4-mailwatch-plugin/Makefile
index 80c378e00fc2..f4f635cf88cb 100644
--- a/mail/xfce4-mailwatch-plugin/Makefile
+++ b/mail/xfce4-mailwatch-plugin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xfce4-mailwatch-plugin
PORTVERSION= 1.0.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail xfce
MASTER_SITES= http://spuriousinterrupt.org/files/mailwatch/ \
http://freebsd.unixfreunde.de/sources/
@@ -23,5 +23,6 @@ USE_GETTEXT= yes
GNU_CONFIGURE= yes
USE_GNOME= gnometarget gtk20 intltool intlhack pkgconfig
USE_XFCE= configenv libgui libutil panel
+USE_XORG= x11 xt xaw
.include <bsd.port.mk>
diff --git a/math/goblin/Makefile b/math/goblin/Makefile
index d7301ac1ff6c..0bfb1049ca30 100644
--- a/math/goblin/Makefile
+++ b/math/goblin/Makefile
@@ -34,7 +34,7 @@ ALL_TARGET= all goblin.a glpk.a
PLIST_SUB+= VERSION=${PORTVERSION:R}
CFLAGS+= -I${LOCALBASE}/include/tcl8.3 -I${LOCALBASE}/include/ \
- ${PTHREAD_CFLAGS}
+ ${PTHREAD_CFLAGS} -I${LOCALBASE}/include/tk8.3
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
WISH= ${LOCALBASE}/bin/wish8.3
diff --git a/misc/goblin/Makefile b/misc/goblin/Makefile
index d7301ac1ff6c..0bfb1049ca30 100644
--- a/misc/goblin/Makefile
+++ b/misc/goblin/Makefile
@@ -34,7 +34,7 @@ ALL_TARGET= all goblin.a glpk.a
PLIST_SUB+= VERSION=${PORTVERSION:R}
CFLAGS+= -I${LOCALBASE}/include/tcl8.3 -I${LOCALBASE}/include/ \
- ${PTHREAD_CFLAGS}
+ ${PTHREAD_CFLAGS} -I${LOCALBASE}/include/tk8.3
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
WISH= ${LOCALBASE}/bin/wish8.3
diff --git a/net-im/xfce4-messenger-plugin/Makefile b/net-im/xfce4-messenger-plugin/Makefile
index cb151bc88f83..a976ee9b171f 100644
--- a/net-im/xfce4-messenger-plugin/Makefile
+++ b/net-im/xfce4-messenger-plugin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xfce4-messenger-plugin
PORTVERSION= 0.1.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-im xfce
MASTER_SITES= ftp://ftp.berlios.de/pub/xfce-goodies/panel-plugins/4.4/
DIST_SUBDIR= xfce4
@@ -23,5 +23,6 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnometarget gtk20 intltool intlhack pkgconfig
USE_XFCE= configenv libgui libutil panel
+USE_XORG= x11 xt xaw
.include <bsd.port.mk>
diff --git a/www/xfce4-smartbookmark-plugin/Makefile b/www/xfce4-smartbookmark-plugin/Makefile
index f96bbabe1fd7..8877ff3347ea 100644
--- a/www/xfce4-smartbookmark-plugin/Makefile
+++ b/www/xfce4-smartbookmark-plugin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xfce4-smartbookmark-plugin
PORTVERSION= 0.4.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www xfce
MASTER_SITES= http://goodies.xfce.org/releases/${PORTNAME}/
DIST_SUBDIR= xfce4
@@ -21,5 +21,6 @@ USE_GETTEXT= yes
GNU_CONFIGURE= yes
USE_GNOME= gnometarget gtk20 intltool intlhack pkgconfig
USE_XFCE= configenv libgui libutil panel
+USE_XORG= x11 xt xaw
.include <bsd.port.mk>
diff --git a/x11/slock/Makefile b/x11/slock/Makefile
index b3f74c1371e3..a4694e7a01e8 100644
--- a/x11/slock/Makefile
+++ b/x11/slock/Makefile
@@ -7,6 +7,7 @@
PORTNAME= slock
PORTVERSION= 0.8
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= http://www.suckless.org/download/ CENKES
@@ -18,7 +19,7 @@ MAKE_ARGS= PREFIX="${PREFIX}" X11LIB="${LOCALBASE}/lib" \
MANPREFIX="${MANPREFIX}/man"
PLIST_FILES= bin/slock
-USE_XORG= x11 xt
+USE_XORG= x11 xt xproto xext
post-patch:
@${REINPLACE_CMD} -e 's|-I/usr/include||;s|-L/usr/lib||;s|= -Os|+=|'\