aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--UPDATING15
-rw-r--r--devel/chora/Makefile9
-rw-r--r--devel/chora/pkg-plist5
-rw-r--r--devel/horde-chora/Makefile9
-rw-r--r--devel/horde-chora/pkg-plist5
-rw-r--r--ftp/gollem/Makefile12
-rw-r--r--ftp/gollem/pkg-plist6
-rw-r--r--ftp/horde-gollem/Makefile12
-rw-r--r--ftp/horde-gollem/pkg-plist6
-rw-r--r--mail/horde-imp/Makefile9
-rw-r--r--mail/horde-imp/pkg-plist8
-rw-r--r--mail/horde4-imp/Makefile9
-rw-r--r--mail/horde4-imp/pkg-plist8
-rw-r--r--mail/imp/Makefile9
-rw-r--r--mail/imp/pkg-plist8
-rw-r--r--www/horde-base/Makefile10
-rw-r--r--www/horde-base/pkg-plist7
-rw-r--r--www/horde-passwd/Makefile11
-rw-r--r--www/horde/Makefile10
-rw-r--r--www/horde/pkg-plist7
-rw-r--r--www/horde4-base/Makefile10
-rw-r--r--www/horde4-base/pkg-plist7
22 files changed, 53 insertions, 139 deletions
diff --git a/UPDATING b/UPDATING
index 97cf55d9b0b6..9550068593b7 100644
--- a/UPDATING
+++ b/UPDATING
@@ -16,6 +16,21 @@ upgrades.
move the appropriate files to this directory manually,
or set the tor_datadir variable accordingly in /etc/rc.conf
+20060414:
+ AFFECTS: users of www/horde, www/horde-php5, www/horde-passwd,
+ deskutils/nag, deskutils/mnemo, deskutils/kronolith,
+ mail/turba, mail/ingo, mail/imp, devel/chora
+ AUTHOR: shaun@inerd.com
+
+ The Horde ports no longer overwrite your existing configuration
+ files during an upgrade: if you have modified any of the files in the
+ config directory of any of these ports, they will be left untouched
+ when you upgrade.
+
+ It is recommended that the new .dist files are examined after an
+ upgrade and any changes merged into your existing config files if
+ necessary.
+
20060408:
AFFECTS: users of www/linux-flashplugin*
AUTHOR: hrs@FreeBSD.org
diff --git a/devel/chora/Makefile b/devel/chora/Makefile
index 2a7614e16284..7c04659a83ab 100644
--- a/devel/chora/Makefile
+++ b/devel/chora/Makefile
@@ -70,7 +70,7 @@ LCHORADIR= ${LHORDEDIR}/chora
PLIST_SUB= CHORADIR=${LCHORADIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= CHORADIR=${CHORADIR} CONFDIR=${CONFDIR}
CHORADIR= ${PREFIX}/${LCHORADIR}
@@ -114,11 +114,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${CHORADIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${CHORADIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${CHORADIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-chora.conf ${HORDE_INC}
@@ -131,6 +127,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/devel/chora/pkg-plist b/devel/chora/pkg-plist
index b5f16266a49e..b20759e18ae8 100644
--- a/devel/chora/pkg-plist
+++ b/devel/chora/pkg-plist
@@ -12,15 +12,10 @@
%%CHORADIR%%/co.php
%%CHORADIR%%/config/.htaccess
%%CHORADIR%%/config/conf.xml
-%%CHORADIR%%/config/cvsgraph.conf
%%CHORADIR%%/config/cvsgraph.conf.dist
-%%CHORADIR%%/config/longIntro.txt
%%CHORADIR%%/config/longIntro.txt.dist
-%%CHORADIR%%/config/mime_drivers.php
%%CHORADIR%%/config/mime_drivers.php.dist
-%%CHORADIR%%/config/prefs.php
%%CHORADIR%%/config/prefs.php.dist
-%%CHORADIR%%/config/sourceroots.php
%%CHORADIR%%/config/sourceroots.php.dist
%%CHORADIR%%/cvs.php
%%CHORADIR%%/cvsgraph.php
diff --git a/devel/horde-chora/Makefile b/devel/horde-chora/Makefile
index 2a7614e16284..7c04659a83ab 100644
--- a/devel/horde-chora/Makefile
+++ b/devel/horde-chora/Makefile
@@ -70,7 +70,7 @@ LCHORADIR= ${LHORDEDIR}/chora
PLIST_SUB= CHORADIR=${LCHORADIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= CHORADIR=${CHORADIR} CONFDIR=${CONFDIR}
CHORADIR= ${PREFIX}/${LCHORADIR}
@@ -114,11 +114,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${CHORADIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${CHORADIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${CHORADIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-chora.conf ${HORDE_INC}
@@ -131,6 +127,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/devel/horde-chora/pkg-plist b/devel/horde-chora/pkg-plist
index b5f16266a49e..b20759e18ae8 100644
--- a/devel/horde-chora/pkg-plist
+++ b/devel/horde-chora/pkg-plist
@@ -12,15 +12,10 @@
%%CHORADIR%%/co.php
%%CHORADIR%%/config/.htaccess
%%CHORADIR%%/config/conf.xml
-%%CHORADIR%%/config/cvsgraph.conf
%%CHORADIR%%/config/cvsgraph.conf.dist
-%%CHORADIR%%/config/longIntro.txt
%%CHORADIR%%/config/longIntro.txt.dist
-%%CHORADIR%%/config/mime_drivers.php
%%CHORADIR%%/config/mime_drivers.php.dist
-%%CHORADIR%%/config/prefs.php
%%CHORADIR%%/config/prefs.php.dist
-%%CHORADIR%%/config/sourceroots.php
%%CHORADIR%%/config/sourceroots.php.dist
%%CHORADIR%%/cvs.php
%%CHORADIR%%/cvsgraph.php
diff --git a/ftp/gollem/Makefile b/ftp/gollem/Makefile
index c6378f7ca1dc..37334847cb17 100644
--- a/ftp/gollem/Makefile
+++ b/ftp/gollem/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gollem
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= ftp www
MASTER_SITES= ftp://ftp.horde.org/pub/gollem/ \
ftp://ftp.planetmirror.com/pub/horde/gollem/ \
@@ -18,7 +19,7 @@ MASTER_SITES= ftp://ftp.horde.org/pub/gollem/ \
http://ftp.horde.org/pub/gollem/
DISTNAME= ${PORTNAME}-h3-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@inerd.com
COMMENT= Gollem is the Horde web-based File Manager
RUN_DEPENDS= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde
@@ -30,7 +31,7 @@ USE_APACHE= 1.3+ # needed to test APACHE_VERSION
PLIST_SUB= GOLLEMDIR=${LGOLLEMDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= GOLLEMDIR=${GOLLEMDIR}
DOCS= README docs/CHANGES docs/CREDITS docs/INSTALL \
@@ -61,11 +62,7 @@ do-install:
@${MKDIR} ${GOLLEMDIR}
@${CP} -Rp ${SUB_DIRS:S|^|${WRKSRC}/|} ${GOLLEMDIR}
@${CP} -p ${WRKSRC}/*.php ${GOLLEMDIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${GOLLEMDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-gollem.conf ${HORDE_INC}
@@ -76,6 +73,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/ftp/gollem/pkg-plist b/ftp/gollem/pkg-plist
index 1451056a40c8..d8b0b444d027 100644
--- a/ftp/gollem/pkg-plist
+++ b/ftp/gollem/pkg-plist
@@ -1,17 +1,11 @@
%%HORDE_INC%%/httpd-gollem.conf
%%GOLLEMDIR%%/clipboard.php
-%%GOLLEMDIR%%/config/backends.php
%%GOLLEMDIR%%/config/backends.php.dist
%%GOLLEMDIR%%/config/conf.xml
-%%GOLLEMDIR%%/config/credentials.php
%%GOLLEMDIR%%/config/credentials.php.dist
-%%GOLLEMDIR%%/config/menu.php
%%GOLLEMDIR%%/config/menu.php.dist
-%%GOLLEMDIR%%/config/mime_drivers.php
%%GOLLEMDIR%%/config/mime_drivers.php.dist
-%%GOLLEMDIR%%/config/motd.php
%%GOLLEMDIR%%/config/motd.php.dist
-%%GOLLEMDIR%%/config/prefs.php
%%GOLLEMDIR%%/config/prefs.php.dist
%%GOLLEMDIR%%/index.php
%%GOLLEMDIR%%/js/stripe.js
diff --git a/ftp/horde-gollem/Makefile b/ftp/horde-gollem/Makefile
index c6378f7ca1dc..37334847cb17 100644
--- a/ftp/horde-gollem/Makefile
+++ b/ftp/horde-gollem/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gollem
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= ftp www
MASTER_SITES= ftp://ftp.horde.org/pub/gollem/ \
ftp://ftp.planetmirror.com/pub/horde/gollem/ \
@@ -18,7 +19,7 @@ MASTER_SITES= ftp://ftp.horde.org/pub/gollem/ \
http://ftp.horde.org/pub/gollem/
DISTNAME= ${PORTNAME}-h3-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@inerd.com
COMMENT= Gollem is the Horde web-based File Manager
RUN_DEPENDS= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde
@@ -30,7 +31,7 @@ USE_APACHE= 1.3+ # needed to test APACHE_VERSION
PLIST_SUB= GOLLEMDIR=${LGOLLEMDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= GOLLEMDIR=${GOLLEMDIR}
DOCS= README docs/CHANGES docs/CREDITS docs/INSTALL \
@@ -61,11 +62,7 @@ do-install:
@${MKDIR} ${GOLLEMDIR}
@${CP} -Rp ${SUB_DIRS:S|^|${WRKSRC}/|} ${GOLLEMDIR}
@${CP} -p ${WRKSRC}/*.php ${GOLLEMDIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${GOLLEMDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-gollem.conf ${HORDE_INC}
@@ -76,6 +73,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/ftp/horde-gollem/pkg-plist b/ftp/horde-gollem/pkg-plist
index 1451056a40c8..d8b0b444d027 100644
--- a/ftp/horde-gollem/pkg-plist
+++ b/ftp/horde-gollem/pkg-plist
@@ -1,17 +1,11 @@
%%HORDE_INC%%/httpd-gollem.conf
%%GOLLEMDIR%%/clipboard.php
-%%GOLLEMDIR%%/config/backends.php
%%GOLLEMDIR%%/config/backends.php.dist
%%GOLLEMDIR%%/config/conf.xml
-%%GOLLEMDIR%%/config/credentials.php
%%GOLLEMDIR%%/config/credentials.php.dist
-%%GOLLEMDIR%%/config/menu.php
%%GOLLEMDIR%%/config/menu.php.dist
-%%GOLLEMDIR%%/config/mime_drivers.php
%%GOLLEMDIR%%/config/mime_drivers.php.dist
-%%GOLLEMDIR%%/config/motd.php
%%GOLLEMDIR%%/config/motd.php.dist
-%%GOLLEMDIR%%/config/prefs.php
%%GOLLEMDIR%%/config/prefs.php.dist
%%GOLLEMDIR%%/index.php
%%GOLLEMDIR%%/js/stripe.js
diff --git a/mail/horde-imp/Makefile b/mail/horde-imp/Makefile
index d53367d4c703..45e068589393 100644
--- a/mail/horde-imp/Makefile
+++ b/mail/horde-imp/Makefile
@@ -120,7 +120,7 @@ PEARDIR?= ${LOCALBASE}/share/pear
PLIST_SUB= IMPDIR=${LIMPDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= IMPDIR=${IMPDIR} PORTSDIR=${PORTSDIR} CONFDIR=${CONFDIR}
IMPDIR= ${PREFIX}/${LIMPDIR}
@@ -226,11 +226,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${IMPDIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${IMPDIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${INSTALL_DATA} ${WRKSRC}/config/conf.xml ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-imp.conf ${HORDE_INC}
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${IMPDIR}
@@ -244,6 +240,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/mail/horde-imp/pkg-plist b/mail/horde-imp/pkg-plist
index a5a551a09a26..b549ed80a254 100644
--- a/mail/horde-imp/pkg-plist
+++ b/mail/horde-imp/pkg-plist
@@ -11,21 +11,13 @@
%%IMPDIR%%/compose.php
%%IMPDIR%%/config/.htaccess
%%IMPDIR%%/config/conf.xml
-%%IMPDIR%%/config/filter.txt
%%IMPDIR%%/config/filter.txt.dist
-%%IMPDIR%%/config/header.php
%%IMPDIR%%/config/header.php.dist
-%%IMPDIR%%/config/menu.php
%%IMPDIR%%/config/menu.php.dist
-%%IMPDIR%%/config/mime_drivers.php
%%IMPDIR%%/config/mime_drivers.php.dist
-%%IMPDIR%%/config/motd.php
%%IMPDIR%%/config/motd.php.dist
-%%IMPDIR%%/config/prefs.php
%%IMPDIR%%/config/prefs.php.dist
-%%IMPDIR%%/config/servers.php
%%IMPDIR%%/config/servers.php.dist
-%%IMPDIR%%/config/trailer.txt
%%IMPDIR%%/config/trailer.txt.dist
%%IMPDIR%%/contacts.php
%%IMPDIR%%/expand.php
diff --git a/mail/horde4-imp/Makefile b/mail/horde4-imp/Makefile
index d53367d4c703..45e068589393 100644
--- a/mail/horde4-imp/Makefile
+++ b/mail/horde4-imp/Makefile
@@ -120,7 +120,7 @@ PEARDIR?= ${LOCALBASE}/share/pear
PLIST_SUB= IMPDIR=${LIMPDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= IMPDIR=${IMPDIR} PORTSDIR=${PORTSDIR} CONFDIR=${CONFDIR}
IMPDIR= ${PREFIX}/${LIMPDIR}
@@ -226,11 +226,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${IMPDIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${IMPDIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${INSTALL_DATA} ${WRKSRC}/config/conf.xml ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-imp.conf ${HORDE_INC}
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${IMPDIR}
@@ -244,6 +240,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/mail/horde4-imp/pkg-plist b/mail/horde4-imp/pkg-plist
index a5a551a09a26..b549ed80a254 100644
--- a/mail/horde4-imp/pkg-plist
+++ b/mail/horde4-imp/pkg-plist
@@ -11,21 +11,13 @@
%%IMPDIR%%/compose.php
%%IMPDIR%%/config/.htaccess
%%IMPDIR%%/config/conf.xml
-%%IMPDIR%%/config/filter.txt
%%IMPDIR%%/config/filter.txt.dist
-%%IMPDIR%%/config/header.php
%%IMPDIR%%/config/header.php.dist
-%%IMPDIR%%/config/menu.php
%%IMPDIR%%/config/menu.php.dist
-%%IMPDIR%%/config/mime_drivers.php
%%IMPDIR%%/config/mime_drivers.php.dist
-%%IMPDIR%%/config/motd.php
%%IMPDIR%%/config/motd.php.dist
-%%IMPDIR%%/config/prefs.php
%%IMPDIR%%/config/prefs.php.dist
-%%IMPDIR%%/config/servers.php
%%IMPDIR%%/config/servers.php.dist
-%%IMPDIR%%/config/trailer.txt
%%IMPDIR%%/config/trailer.txt.dist
%%IMPDIR%%/contacts.php
%%IMPDIR%%/expand.php
diff --git a/mail/imp/Makefile b/mail/imp/Makefile
index d53367d4c703..45e068589393 100644
--- a/mail/imp/Makefile
+++ b/mail/imp/Makefile
@@ -120,7 +120,7 @@ PEARDIR?= ${LOCALBASE}/share/pear
PLIST_SUB= IMPDIR=${LIMPDIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= IMPDIR=${IMPDIR} PORTSDIR=${PORTSDIR} CONFDIR=${CONFDIR}
IMPDIR= ${PREFIX}/${LIMPDIR}
@@ -226,11 +226,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${IMPDIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${IMPDIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${INSTALL_DATA} ${WRKSRC}/config/conf.xml ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-imp.conf ${HORDE_INC}
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${IMPDIR}
@@ -244,6 +240,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/mail/imp/pkg-plist b/mail/imp/pkg-plist
index a5a551a09a26..b549ed80a254 100644
--- a/mail/imp/pkg-plist
+++ b/mail/imp/pkg-plist
@@ -11,21 +11,13 @@
%%IMPDIR%%/compose.php
%%IMPDIR%%/config/.htaccess
%%IMPDIR%%/config/conf.xml
-%%IMPDIR%%/config/filter.txt
%%IMPDIR%%/config/filter.txt.dist
-%%IMPDIR%%/config/header.php
%%IMPDIR%%/config/header.php.dist
-%%IMPDIR%%/config/menu.php
%%IMPDIR%%/config/menu.php.dist
-%%IMPDIR%%/config/mime_drivers.php
%%IMPDIR%%/config/mime_drivers.php.dist
-%%IMPDIR%%/config/motd.php
%%IMPDIR%%/config/motd.php.dist
-%%IMPDIR%%/config/prefs.php
%%IMPDIR%%/config/prefs.php.dist
-%%IMPDIR%%/config/servers.php
%%IMPDIR%%/config/servers.php.dist
-%%IMPDIR%%/config/trailer.txt
%%IMPDIR%%/config/trailer.txt.dist
%%IMPDIR%%/contacts.php
%%IMPDIR%%/expand.php
diff --git a/www/horde-base/Makefile b/www/horde-base/Makefile
index 768c66701098..d3ead20ceed6 100644
--- a/www/horde-base/Makefile
+++ b/www/horde-base/Makefile
@@ -137,7 +137,7 @@ USE_PHP+= mcrypt
. if !defined(WITHOUT_MYSQL)
USE_PHP+= mysql
. endif
-. if defined(WITH_POSTGRESQL)
+. if defined(WITH_POSTGRESQL) || defined(WITH_PGSQL)
USE_PHP+= pgsql
. endif
. if defined(WITH_SQLITE)
@@ -339,11 +339,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${HORDEDIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${HORDEDIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CP} ${WRKSRC}/scripts/set_perms.sh ${HORDESBIN}/horde_set_perms.sh
@${CHMOD} u+x ${HORDESBIN}/horde_set_perms.sh
.if ${APACHE_VERSION} >= 20
@@ -373,7 +369,7 @@ do-install:
.endif
post-install:
- ${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/www/horde-base/pkg-plist b/www/horde-base/pkg-plist
index ecf416f5f932..b6c9440b422b 100644
--- a/www/horde-base/pkg-plist
+++ b/www/horde-base/pkg-plist
@@ -35,20 +35,13 @@
%%HORDEDIR%%/admin/templates.php
%%HORDEDIR%%/admin/user.php
%%HORDEDIR%%/config/.htaccess
-%%HORDEDIR%%/config/conf.php
%%HORDEDIR%%/config/conf.php.dist
%%HORDEDIR%%/config/conf.xml
-%%HORDEDIR%%/config/hooks.php
%%HORDEDIR%%/config/hooks.php.dist
-%%HORDEDIR%%/config/mime_drivers.php
%%HORDEDIR%%/config/mime_drivers.php.dist
-%%HORDEDIR%%/config/motd.php
%%HORDEDIR%%/config/motd.php.dist
-%%HORDEDIR%%/config/nls.php
%%HORDEDIR%%/config/nls.php.dist
-%%HORDEDIR%%/config/prefs.php
%%HORDEDIR%%/config/prefs.php.dist
-%%HORDEDIR%%/config/registry.php
%%HORDEDIR%%/config/registry.php.dist
%%HORDEDIR%%/index.php
%%HORDEDIR%%/js/addEvent.php
diff --git a/www/horde-passwd/Makefile b/www/horde-passwd/Makefile
index 610720ca8fef..aa38ea828ffb 100644
--- a/www/horde-passwd/Makefile
+++ b/www/horde-passwd/Makefile
@@ -20,7 +20,7 @@ MASTER_SITES= ftp://ftp.horde.org/pub/passwd/ \
DISTNAME= passwd-h3-${PORTVERSION}
DIST_SUBDIR= horde
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@inerd.com
COMMENT= A password changing module for Horde
RUN_DEPENDS= ${LOCALBASE}/${LHORDEDIR}/rpc.php:${PORTSDIR}/www/horde
@@ -32,7 +32,7 @@ PLIST_SUB= LPWDDIR=${LPWDDIR} PWDDIR=${PWDDIR} \
HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= PWDDIR=${PWDDIR} CONFDIR=${CONFDIR} HORDEDIR=${HORDEDIR}
DOCS= LICENSE README docs/CHANGES docs/CREDITS docs/INSTALL \
@@ -65,11 +65,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${PWDDIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${PWDDIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R www:www ${PWDDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-pwd.conf ${HORDE_INC}
@@ -82,6 +78,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/www/horde/Makefile b/www/horde/Makefile
index 768c66701098..d3ead20ceed6 100644
--- a/www/horde/Makefile
+++ b/www/horde/Makefile
@@ -137,7 +137,7 @@ USE_PHP+= mcrypt
. if !defined(WITHOUT_MYSQL)
USE_PHP+= mysql
. endif
-. if defined(WITH_POSTGRESQL)
+. if defined(WITH_POSTGRESQL) || defined(WITH_PGSQL)
USE_PHP+= pgsql
. endif
. if defined(WITH_SQLITE)
@@ -339,11 +339,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${HORDEDIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${HORDEDIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CP} ${WRKSRC}/scripts/set_perms.sh ${HORDESBIN}/horde_set_perms.sh
@${CHMOD} u+x ${HORDESBIN}/horde_set_perms.sh
.if ${APACHE_VERSION} >= 20
@@ -373,7 +369,7 @@ do-install:
.endif
post-install:
- ${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/www/horde/pkg-plist b/www/horde/pkg-plist
index ecf416f5f932..b6c9440b422b 100644
--- a/www/horde/pkg-plist
+++ b/www/horde/pkg-plist
@@ -35,20 +35,13 @@
%%HORDEDIR%%/admin/templates.php
%%HORDEDIR%%/admin/user.php
%%HORDEDIR%%/config/.htaccess
-%%HORDEDIR%%/config/conf.php
%%HORDEDIR%%/config/conf.php.dist
%%HORDEDIR%%/config/conf.xml
-%%HORDEDIR%%/config/hooks.php
%%HORDEDIR%%/config/hooks.php.dist
-%%HORDEDIR%%/config/mime_drivers.php
%%HORDEDIR%%/config/mime_drivers.php.dist
-%%HORDEDIR%%/config/motd.php
%%HORDEDIR%%/config/motd.php.dist
-%%HORDEDIR%%/config/nls.php
%%HORDEDIR%%/config/nls.php.dist
-%%HORDEDIR%%/config/prefs.php
%%HORDEDIR%%/config/prefs.php.dist
-%%HORDEDIR%%/config/registry.php
%%HORDEDIR%%/config/registry.php.dist
%%HORDEDIR%%/index.php
%%HORDEDIR%%/js/addEvent.php
diff --git a/www/horde4-base/Makefile b/www/horde4-base/Makefile
index 768c66701098..d3ead20ceed6 100644
--- a/www/horde4-base/Makefile
+++ b/www/horde4-base/Makefile
@@ -137,7 +137,7 @@ USE_PHP+= mcrypt
. if !defined(WITHOUT_MYSQL)
USE_PHP+= mysql
. endif
-. if defined(WITH_POSTGRESQL)
+. if defined(WITH_POSTGRESQL) || defined(WITH_PGSQL)
USE_PHP+= pgsql
. endif
. if defined(WITH_SQLITE)
@@ -339,11 +339,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${HORDEDIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${HORDEDIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CP} ${WRKSRC}/scripts/set_perms.sh ${HORDESBIN}/horde_set_perms.sh
@${CHMOD} u+x ${HORDESBIN}/horde_set_perms.sh
.if ${APACHE_VERSION} >= 20
@@ -373,7 +369,7 @@ do-install:
.endif
post-install:
- ${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
diff --git a/www/horde4-base/pkg-plist b/www/horde4-base/pkg-plist
index ecf416f5f932..b6c9440b422b 100644
--- a/www/horde4-base/pkg-plist
+++ b/www/horde4-base/pkg-plist
@@ -35,20 +35,13 @@
%%HORDEDIR%%/admin/templates.php
%%HORDEDIR%%/admin/user.php
%%HORDEDIR%%/config/.htaccess
-%%HORDEDIR%%/config/conf.php
%%HORDEDIR%%/config/conf.php.dist
%%HORDEDIR%%/config/conf.xml
-%%HORDEDIR%%/config/hooks.php
%%HORDEDIR%%/config/hooks.php.dist
-%%HORDEDIR%%/config/mime_drivers.php
%%HORDEDIR%%/config/mime_drivers.php.dist
-%%HORDEDIR%%/config/motd.php
%%HORDEDIR%%/config/motd.php.dist
-%%HORDEDIR%%/config/nls.php
%%HORDEDIR%%/config/nls.php.dist
-%%HORDEDIR%%/config/prefs.php
%%HORDEDIR%%/config/prefs.php.dist
-%%HORDEDIR%%/config/registry.php
%%HORDEDIR%%/config/registry.php.dist
%%HORDEDIR%%/index.php
%%HORDEDIR%%/js/addEvent.php