aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/gcc/Makefile6
-rw-r--r--lang/gcc41/Makefile6
-rw-r--r--lang/gcc42/Makefile6
-rw-r--r--lang/gcc43/Makefile6
-rw-r--r--lang/gcc44/Makefile6
-rw-r--r--lang/gcc45/Makefile6
-rw-r--r--lang/gcc46/Makefile6
-rw-r--r--lang/gcc47/Makefile6
-rw-r--r--lang/gcc48/Makefile6
9 files changed, 27 insertions, 27 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index a70bc1b23ba6..1f5b6f36661a 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -26,12 +26,12 @@ DISTFILES+= gcc-fortran-${VERSIONSTRING}${EXTRACT_SUFX}
MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.1
-LATEST_LINK?= gcc41${PKGNAMESUFFIX}
-
.if defined(WITH_FORTRAN)
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
.endif
+LATEST_LINK?= gcc41${PKGNAMESUFFIX}
+NOT_FOR_ARCHS= alpha
USE_BISON= yes
USE_BZIP2= yes
USE_GMAKE= yes
@@ -45,7 +45,7 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
-BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
+BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
.endif
.if ${ARCH} == "amd64"
diff --git a/lang/gcc41/Makefile b/lang/gcc41/Makefile
index a70bc1b23ba6..1f5b6f36661a 100644
--- a/lang/gcc41/Makefile
+++ b/lang/gcc41/Makefile
@@ -26,12 +26,12 @@ DISTFILES+= gcc-fortran-${VERSIONSTRING}${EXTRACT_SUFX}
MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.1
-LATEST_LINK?= gcc41${PKGNAMESUFFIX}
-
.if defined(WITH_FORTRAN)
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
.endif
+LATEST_LINK?= gcc41${PKGNAMESUFFIX}
+NOT_FOR_ARCHS= alpha
USE_BISON= yes
USE_BZIP2= yes
USE_GMAKE= yes
@@ -45,7 +45,7 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
-BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
+BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
.endif
.if ${ARCH} == "amd64"
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
index a70bc1b23ba6..1f5b6f36661a 100644
--- a/lang/gcc42/Makefile
+++ b/lang/gcc42/Makefile
@@ -26,12 +26,12 @@ DISTFILES+= gcc-fortran-${VERSIONSTRING}${EXTRACT_SUFX}
MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.1
-LATEST_LINK?= gcc41${PKGNAMESUFFIX}
-
.if defined(WITH_FORTRAN)
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
.endif
+LATEST_LINK?= gcc41${PKGNAMESUFFIX}
+NOT_FOR_ARCHS= alpha
USE_BISON= yes
USE_BZIP2= yes
USE_GMAKE= yes
@@ -45,7 +45,7 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
-BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
+BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
.endif
.if ${ARCH} == "amd64"
diff --git a/lang/gcc43/Makefile b/lang/gcc43/Makefile
index a70bc1b23ba6..1f5b6f36661a 100644
--- a/lang/gcc43/Makefile
+++ b/lang/gcc43/Makefile
@@ -26,12 +26,12 @@ DISTFILES+= gcc-fortran-${VERSIONSTRING}${EXTRACT_SUFX}
MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.1
-LATEST_LINK?= gcc41${PKGNAMESUFFIX}
-
.if defined(WITH_FORTRAN)
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
.endif
+LATEST_LINK?= gcc41${PKGNAMESUFFIX}
+NOT_FOR_ARCHS= alpha
USE_BISON= yes
USE_BZIP2= yes
USE_GMAKE= yes
@@ -45,7 +45,7 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
-BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
+BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
.endif
.if ${ARCH} == "amd64"
diff --git a/lang/gcc44/Makefile b/lang/gcc44/Makefile
index a70bc1b23ba6..1f5b6f36661a 100644
--- a/lang/gcc44/Makefile
+++ b/lang/gcc44/Makefile
@@ -26,12 +26,12 @@ DISTFILES+= gcc-fortran-${VERSIONSTRING}${EXTRACT_SUFX}
MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.1
-LATEST_LINK?= gcc41${PKGNAMESUFFIX}
-
.if defined(WITH_FORTRAN)
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
.endif
+LATEST_LINK?= gcc41${PKGNAMESUFFIX}
+NOT_FOR_ARCHS= alpha
USE_BISON= yes
USE_BZIP2= yes
USE_GMAKE= yes
@@ -45,7 +45,7 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
-BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
+BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
.endif
.if ${ARCH} == "amd64"
diff --git a/lang/gcc45/Makefile b/lang/gcc45/Makefile
index a70bc1b23ba6..1f5b6f36661a 100644
--- a/lang/gcc45/Makefile
+++ b/lang/gcc45/Makefile
@@ -26,12 +26,12 @@ DISTFILES+= gcc-fortran-${VERSIONSTRING}${EXTRACT_SUFX}
MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.1
-LATEST_LINK?= gcc41${PKGNAMESUFFIX}
-
.if defined(WITH_FORTRAN)
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
.endif
+LATEST_LINK?= gcc41${PKGNAMESUFFIX}
+NOT_FOR_ARCHS= alpha
USE_BISON= yes
USE_BZIP2= yes
USE_GMAKE= yes
@@ -45,7 +45,7 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
-BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
+BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
.endif
.if ${ARCH} == "amd64"
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index a70bc1b23ba6..1f5b6f36661a 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -26,12 +26,12 @@ DISTFILES+= gcc-fortran-${VERSIONSTRING}${EXTRACT_SUFX}
MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.1
-LATEST_LINK?= gcc41${PKGNAMESUFFIX}
-
.if defined(WITH_FORTRAN)
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
.endif
+LATEST_LINK?= gcc41${PKGNAMESUFFIX}
+NOT_FOR_ARCHS= alpha
USE_BISON= yes
USE_BZIP2= yes
USE_GMAKE= yes
@@ -45,7 +45,7 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
-BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
+BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
.endif
.if ${ARCH} == "amd64"
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index a70bc1b23ba6..1f5b6f36661a 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -26,12 +26,12 @@ DISTFILES+= gcc-fortran-${VERSIONSTRING}${EXTRACT_SUFX}
MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.1
-LATEST_LINK?= gcc41${PKGNAMESUFFIX}
-
.if defined(WITH_FORTRAN)
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
.endif
+LATEST_LINK?= gcc41${PKGNAMESUFFIX}
+NOT_FOR_ARCHS= alpha
USE_BISON= yes
USE_BZIP2= yes
USE_GMAKE= yes
@@ -45,7 +45,7 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
-BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
+BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
.endif
.if ${ARCH} == "amd64"
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index a70bc1b23ba6..1f5b6f36661a 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -26,12 +26,12 @@ DISTFILES+= gcc-fortran-${VERSIONSTRING}${EXTRACT_SUFX}
MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.1
-LATEST_LINK?= gcc41${PKGNAMESUFFIX}
-
.if defined(WITH_FORTRAN)
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
.endif
+LATEST_LINK?= gcc41${PKGNAMESUFFIX}
+NOT_FOR_ARCHS= alpha
USE_BISON= yes
USE_BZIP2= yes
USE_GMAKE= yes
@@ -45,7 +45,7 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
-BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
+BROKEN= "Bootstrap fails with SPARC-specific error. Reported upstream as http://gcc.gnu.org/PR20633"
.endif
.if ${ARCH} == "amd64"