aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-rb-kqueue/Makefile20
-rw-r--r--devel/rubygem-rb-kqueue/distinfo2
-rw-r--r--devel/rubygem-rb-kqueue/pkg-descr6
4 files changed, 29 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7d6f66718b00..e150087a7b6b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4084,6 +4084,7 @@
SUBDIR += rubygem-rascut
SUBDIR += rubygem-rash
SUBDIR += rubygem-rb-inotify
+ SUBDIR += rubygem-rb-kqueue
SUBDIR += rubygem-rcov
SUBDIR += rubygem-rdoc
SUBDIR += rubygem-require_all
diff --git a/devel/rubygem-rb-kqueue/Makefile b/devel/rubygem-rb-kqueue/Makefile
new file mode 100644
index 000000000000..a16b8000a431
--- /dev/null
+++ b/devel/rubygem-rb-kqueue/Makefile
@@ -0,0 +1,20 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rb-kqueue
+PORTVERSION= 0.2.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Ruby wrapper for BSD kqueue, using FFI
+
+LICENSE= MIT
+
+RUN_DEPENDS= rubygem-ffi>=0.5.0:${PORTSDIR}/devel/rubygem-ffi
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-rb-kqueue/distinfo b/devel/rubygem-rb-kqueue/distinfo
new file mode 100644
index 000000000000..279a270d573f
--- /dev/null
+++ b/devel/rubygem-rb-kqueue/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/rb-kqueue-0.2.0.gem) = c30ee45a9095f86bc7e213fe3b2cfff56f78a08f47fae584ff418d84618d5cb8
+SIZE (rubygem/rb-kqueue-0.2.0.gem) = 14848
diff --git a/devel/rubygem-rb-kqueue/pkg-descr b/devel/rubygem-rb-kqueue/pkg-descr
new file mode 100644
index 000000000000..f9020ee91a15
--- /dev/null
+++ b/devel/rubygem-rb-kqueue/pkg-descr
@@ -0,0 +1,6 @@
+This is a simple wrapper over the kqueue BSD event notification interface
+(supported on FreeBSD, NetBSD, OpenBSD, and Darwin). It uses the FFI gem to
+avoid having to compile a C extension.
+
+WWW: https://github.com/mat813/rb-kqueue
+RG: https://rubygems.org/gems/rb-kqueue