aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/juk/Makefile6
-rw-r--r--deskutils/kdissert/Makefile2
-rw-r--r--deskutils/semantik/Makefile2
-rw-r--r--textproc/skim/Makefile2
4 files changed, 6 insertions, 6 deletions
diff --git a/audio/juk/Makefile b/audio/juk/Makefile
index 0027541ad9fd..9256f1fcd4fc 100644
--- a/audio/juk/Makefile
+++ b/audio/juk/Makefile
@@ -61,11 +61,11 @@ pre-everything::
.endif
do-build:
- cd ${WRKSRC}/arts/runtime && ${GMAKE}
- cd ${WRKSRC}/juk && ${GMAKE}
+ cd ${WRKSRC}/arts/runtime && ${SETENV} ${MAKE_ENV} ${GMAKE}
+ cd ${WRKSRC}/juk && ${SETENV} ${MAKE_ENV} ${GMAKE}
do-install:
- cd ${WRKSRC}/juk && ${GMAKE} install
+ cd ${WRKSRC}/juk && ${SETENV} ${MAKE_ENV} ${GMAKE} install
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
.include <bsd.port.post.mk>
diff --git a/deskutils/kdissert/Makefile b/deskutils/kdissert/Makefile
index 2ff53f12df62..10156383aa76 100644
--- a/deskutils/kdissert/Makefile
+++ b/deskutils/kdissert/Makefile
@@ -40,7 +40,7 @@ do-configure:
QTDIR="${QT_PREFIX}" KDEDIR="${KDE_PREFIX}" scons configure
do-build:
- @cd ${WRKSRC} && scons
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} scons
do-install:
@cd ${WRKSRC} && scons install
diff --git a/deskutils/semantik/Makefile b/deskutils/semantik/Makefile
index 2ff53f12df62..10156383aa76 100644
--- a/deskutils/semantik/Makefile
+++ b/deskutils/semantik/Makefile
@@ -40,7 +40,7 @@ do-configure:
QTDIR="${QT_PREFIX}" KDEDIR="${KDE_PREFIX}" scons configure
do-build:
- @cd ${WRKSRC} && scons
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} scons
do-install:
@cd ${WRKSRC} && scons install
diff --git a/textproc/skim/Makefile b/textproc/skim/Makefile
index 92e68a09f7ab..210cf163c8bb 100644
--- a/textproc/skim/Makefile
+++ b/textproc/skim/Makefile
@@ -55,7 +55,7 @@ post-configure:
-e s,lib/pkgconfig,libdata/pkgconfig,g \
${WRKSRC}/cache/pkg.cache.py
do-build:
- @cd ${WRKSRC} && ./scons
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./scons
do-install:
@cd ${WRKSRC} && ./scons install